[SOLVED] smbmount: ÆØÅ & Synology NAS

bawl
Antal: 149
Tilmeldt:
20-04-2007
User is offline
[SOLVED] smbmount: ÆØÅ & Synology NAS

Hej allesammen

Jeg sidder med et lille problem som jeg gætter på der er en af Jer derude, der hurtigt kan hjælpe mig med.

Jeg har en Synology DS207+ (F/W: DSM 2.0-0640) med et delt drev, (SMB m/ 'smbmount') som jeg mounter via følgende kommando: (igennem et script)

smbmount //xxx.xxx.xxx.xxx/linux /home/xxx/linux -o credentials=/root/.credentials,utf8

Problemet er ÆØÅ, der ikke vises korrekt, i bl.a. Kubuntu 8.04 (både i 'konqueror' og 'd3lphin') i stedet vises blot et par firkanter i stedet for ÆØÅ.

Hvis jeg udelader ',utf8' eller tilføjer ',iocharset=iso8859-1' er resultatet blot at der måske i stedet bliver vist et '?' i stedet for 'Ø'.

Det skal siges at de delte mapper virker fint på WinXP-maskiner (fuldt med ÆØÅ), men hvis jeg tilgår den delte mappe via FTP vises mapperne med ÆØÅ i navnet, slet ikke!?!?

*go figure*

Nogen idéer?

På forhånd tak

/Bawl

P.S.: Sprog og tegnsætning er sat til dansk i 'Systemopsætning'=>'Region og sprog'


bawl
Antal: 149
Tilmeldt:
20-04-2007
User is offline
smbmount

Jeg kan se på følgende nedenstående link at 'smbmount' er ved at blive forladt til fordel for 'mount -t cifs'

http://linux.die.net/man/8/smbmount

Jeg ved ikke om ikke det kunne have noget med noget at gøre.

Nogen der har en ide til hvad 'mount'-kommandoen skulle være i stedet.

Hverken:

sudo mount -t smbfs //xxx.xxx.xxx.xxx/linux /home/xxx/linux -o ,credentials=/root/.credentials

eller

sudo mount -t cifs //xxx.xxx.xxx.xxx/linux /home/xxx/linux -o ,credentials=/root/.credentials

giver det ønskede resultat. ÆØÅ er stadig kun firkantede kasser og spørgsmålstegn.

Hva' er det jeg gør forkert?


jon13
jon13's picture
Antal: 18
Tilmeldt:
23-12-2007
User is offline
Re: smbmount: ÆØÅ & Synology NAS

Jeg har samme nas, og specifikt i forbindelse med ftp kan du slå "gennemtving utf-8" til, eller noget deromkring til i synologys admininterface under ftp server. Det løste det problem for mig med at filer og mapper ikke blev vist. =)


ingvorsen
Antal: 15
Tilmeldt:
23-04-2003
User is offline
Re: smbmount: ÆØÅ & Synology NAS

Prøv denne kommando i stedet:
-o iocharset=utf8,file_mode=0777,dir_mode=0777

Det vil sige i dit tilfæde:
Prøv denne kommando i stedet:
sudo mount -t cifs //xxx.xxx.xxx.xxx/linux /home/xxx/linux -o credentials=/root/.credentials,iocharset=utf8, file_mode=0777,dir_mode=0777

Det virker i mit tilfælde med samme NAS.
Der er forøvrigt netop frigivet en ny firmware til din NAS hvis det har interesse?


bawl
Antal: 149
Tilmeldt:
20-04-2007
User is offline
Re: Re: smbmount: ÆØÅ & Synology NAS

#3

Det virker... (Selvfølgelig)

Thx

Havde lige misset at der selvfølgelig skulle ',iocharset=' foran 'utf8'. *DUH*

smbmount //xxx.xxx.xxx.xxx/linux /home/xxx/linux -o credentials=/root/.credentials,iocharset=utf8

Og jeg har godt set at der er kommet en ny F/W, men jeg ved ikke rigtigt om den medbringer så store fordele at jeg tør tage chancen og opdatere...

Har ikke plads til at foretage backup, så hvis det går galt, ryger tingene.
Det gik ganske vist glat og uden problemer sidst, og jeg kan ikke helt se hvad det skulle være der kunne gå galt, men med computere er det jo ikke altid nok. :D

Anywho... Tak for hjælpen.

/Bawl


bawl
Antal: 149
Tilmeldt:
20-04-2007
User is offline
#2 Jeg synes ikke jeg kan

#2

Jeg synes ikke jeg kan finde den setting under hverken 'FTP' eller 'Network' generelt.

Men ellers lyder det som om du kunne have ret.


jon13
jon13's picture
Antal: 18
Tilmeldt:
23-12-2007
User is offline
Re: [SOLVED] smbmount: ÆØÅ & Synology NAS

under forbindelsesindstillinger:
"Aktiver UTF-8-filnavnssupport"

firmware;DSM 2.0-0731


bawl
Antal: 149
Tilmeldt:
20-04-2007
User is offline
#6 Ahh... Opdaterede til

#6

Ahh... Opdaterede til F/W: DSM 2.1-0832 og så var der bid.

Og nu virker det også via FTP.

Thx.