openSUSE Leap 42.1 udgivet

Den 4. november blev openSUSE Leap 42.1 udgivet. Den inkluderer bl.a. Linux-kerne 4.1.12, KDE Plasma Workspace 5.4, GNOME 3.16, LibreOffice 5.0

En ny type distribution
Det er ikke hver dag, at der kommer en ny markant spiller i Linux-distributionslandskabet. Men det er sket her. openSUSE Leap er på mange måder en helt ny distribution, som adskiller sig fra tidligere openSUSE-udgivelser ved at benytte SUSE Linux Enterprise (SLE12sp1 for at være præcis), som basissystem, men med up-to-date kerne, skrivebordsmiljø og grafiske programmer.

Man får altså et meget stabilt, professionelt og gennemtestet basissystem af enterprise-kvalitet, men med up-to-date skrivebordsmiljø og programmer. En hybrid mellem enterprise- og community-software. Sikkerhedsopdateringer mv. som sendes ud til basissystemet vil være de samme kildekodepakker, som sendes ud til de betalende erhvervskunder, der bruger SUSE Linux Enterprise Server 12 osv.

Til gengæld er openSUSE Leap kun tilgængelig som 64-bit-system (og til ARM).

Hvis man synes openSUSE Leap er for konservativ, kan man i stedet overveje openSUSE Tumbleweed, som er en bleeding edge, rolling release distribution.

En ny form for Long Term Support
openSUSE Leap vil hvert år få en opgradering/"service pack", som opgraderer kernen og de grafiske programmer og skrivebordsmiljøer, men som kun laver mindre justeringer af basissystemet. Ca. hvert 3.-4. år vil der komme en ny stor udgivelse, hvor også basissystemet får en stor opgradering.

Samme gode gamle openSUSE
openSUSE Leap byder naturligvis fortsat på de velkendte SUSE-teknologier og services såsom YaST, zypper, 1-click install, Open Build Service, SUSE Studio, osv. Og det er også muligt at opgradere fra openSUSE 13.2 til openSUSE Leap 42.1.

KDE Plasma 5 Workspace
Da det er den første stabile openSUSE-udgivelse med KDE Plasma Workspace 5 som standardskrivebordsmiljø, bør KDE-brugere være forberedt på forandringer og lidt tilvænning, selvom der ikke er tale om grundlæggende forandringer i brugeroplevelsen ift. KDE4.

Download openSUSE Leap her:
https://software.opensuse.org/

Læs den officielle annoncering her, hvor der også er information om images til ARM-computere:
https://news.opensuse.org/2015/11/04/opensuse-leap...

Guide til openSUSE Leap 42.1 kan findes her:
http://opensuse-guide.org/

OracleJMT
OracleJMT's picture
Antal: 184
Tilmeldt:
26-05-2013
User is offline
Meget flot beskrivelse

Meget flot beskrivelse cb400f. :)

Det skal lige siges, at bruger man Nvidia grafikkort, er det ikke uden problemer, at opdatere fra OpenSuSe 13.2 til OpenSuSe 42.1 Leap.

Jeg måtte lave en clean install forleden, da Nvidia-driverens kernelmoduler ikke automatisk blev indlæst med den nye Linux kerne, hvilket resulterede i sort skærm, og en Xorg, der ikke ville starte X.

Blot som en lille advarsel, at det kan bringe ekstra besvær, bruger man Nvidia-drivere. Ikke, at det ikke kan lade sig gøre, men jeg vil langt hellere anbefale, at tage backup og lave en ren installation. :)


cb400f
cb400f's picture
Antal: 3410
Tilmeldt:
20-02-2005
User is offline
#1 Jeg går ud fra du ikke

#1
Jeg går ud fra du ikke havde tilføjet det nye nvidia-repo inden du opgraderede?

Men der er selvfølgelig altid nogle risici ved at opgradere, en risiko som stiger jo flere 3.parts- og uofficielle repos og pakker man har rodet sig ud i.

Personligt laver jeg altid frisk installation (med genbrug af udvalgte dele af /home/). De 2-3 timer en gang hver 12. måned kan jeg godt ofre. Denne gang var det dog en smule mere omfattende, pga. opgraderingen til KF5/Plasma5.


std
Antal: 4
Tilmeldt:
24-10-2015
User is offline
Jeg lavede en frisk

Jeg lavede en frisk installation, ganske korrekt en SUSE som jeg kender den, bare flottere med Plasma 5, velkørende, og tilvænningen burde ikke kunne volde synderlige problemer, alt i alt er det en rigtig god oplevelse.


OracleJMT
OracleJMT's picture
Antal: 184
Tilmeldt:
26-05-2013
User is offline
Som jeg erindrer, så har du

Som jeg erindrer, så har du ret - Nvidia-repoet glemte jeg ganske enkelt i farten. Men det er en god erfaring til næste gang. :)


xy
xy's picture
Antal: 856
Tilmeldt:
03-10-2007
User is offline
Jeg kan ikke installere

Jeg kan ikke installere Crossover på Leap, da den nu vil åbne rpm-filen med ark

Det samme sker med prøveversionen.

Heller ikke gemt fil og højreklik og åbn med Yast virker

Har aldrig før haft dette problem

Håber det kan løses, da jeg er glad ved Crossover


cb400f
cb400f's picture
Antal: 3410
Tilmeldt:
20-02-2005
User is offline
#5 Det ligner en smutter

#5
Det ligner en smutter ifm. at Apper blev pensioneret fra standardinstallationen.

Men nu er der jo heldigvis mange måder man kan installere pakker på. F.eks. følgende som root i en terminal:

zypper install /sti/til/din/crossover.rpm

Eller

yast -i /sti/til/din/crossover.rpm

Du kan nok også bare installere Apper, og vil så kunne klikke på rpm'er i Dolphin igen. Men i så fald bør du nok deaktivere tjek for opdateringer med Apper, så du ikke kommer til at have to forskellige opdateringsapplets kørende samtidig.


xy
xy's picture
Antal: 856
Tilmeldt:
03-10-2007
User is offline
Troede at jeg havde prøvet

Troede at jeg havde prøvet zypper install, men har så gjort noget forkert.

Crossover blev installeret nu

Dette er blot en del af de pakker Crosover efter jnstallation kom med en besked om nu manglede:

De andre jeg ikke fik kopieret var også alle noget med 32 bit.

libXcomposite1-32bit, libXinerama1-32bit, libcapi20-3-32bit, libgnutls28-32bit, libgphoto2-6-32bit, libgsm1-32bit, liblcms2-2-32bit, libopenal1-32bit, libv4l-32bit, libxslt1-32bit, sane-backends-32bit

De kunne hentes en for en i Yast

Men du har ret mht apper. Det gælder alle rpm-filer at de vil åbnes med ark


xy
xy's picture
Antal: 856
Tilmeldt:
03-10-2007
User is offline
Kan jeg løse problemet med

Kan jeg løse problemet med Apper med en upgradering. Eller skal der en clean install til

Kan ikke lidr at have et halvtfærdigt openSUSE, på min PC


cb400f
cb400f's picture
Antal: 3410
Tilmeldt:
20-02-2005
User is offline
Medmindre jeg har

Medmindre jeg har misforstået noget, så er dit problem med Apper, at Apper ikke er installeret. Løsning: Installer Apper. Det kræver hverken opgradering eller nyinstallation eller noget andet end installation af en enkelt pakke - nemlig apper.

Men du bør i så fald slå tjek af opdateringer fra i Appers indstillinger, medmindre du gerne vil have to update applets kørende.

Men nu ved jeg ikke hvor ofte du manuelt downloader enkelt-rpm'er og installerer dem. Formentlig ikke ret ofte. Så måske skulle du bare acceptere at installere dem med zypper i de sjældne tilfælde. Og så glemme alt om Apper.

Forhåbentlig kommer der på et tidspunkt en løsning så klik på en rpm i Dolphin installerer den med YaST i stedet.


xy
xy's picture
Antal: 856
Tilmeldt:
03-10-2007
User is offline
Jeg har set i YaST, at Apper

Jeg har set i YaST, at Apper ikke er installeret.

Har efterhånden fundet ud af at installere rmp-pakker i terminalen, Ved også hvor meget det kan låse Apper, hvis jeg kører zypper up.

Men de automatiske opdateringer vil jeg ikke undvære, så løsningen bliver nok at lade det være som det er nu og vente og se


knold51
Antal: 1
Tilmeldt:
06-09-2016
User is offline
Tastaturlayout

Er forholdsvis newbie på Linux og har lavet en ren installation af OpenSuse leap 42.1. som er forløbet glat.

Jeg er dog nødt til at gå i Yast/hardware/tastatur hver eneste gang jeg åbner systemet for først at skifte til et andet tastaturlayout end dansk, gemme, og bagefter gå ind igen og skifte tilbage til dansk og gemme det for at få et normalt dansk tastaturlayout med æøå og @ osv på de rigtige pladser.

Næste gang jeg tænder maskinen er den gal igen.

Har forsøgt at rette i filen etc/sysconfig/keyboard, men har angiveligt ikke rettigheder til at skrive til den.


cb400f
cb400f's picture
Antal: 3410
Tilmeldt:
20-02-2005
User is offline
#11Lidt sent svar,

#11
Lidt sent svar, men...

Prøv at sætte tastaturlayoutet i skrivebordsmiljøets indstillinger i stedet for med YaST.

Hvis du har installeret med KDE/Plasma som skrivebordsmiljø, så start "Systemindstillinger" -> Input-enheder -> Tastatur -> Fanebladet "Layouts" -> Og sørg for at du har dansk der.

Hvis du har installeret et andet skrivebordsmiljø end KDE, har det nok også en form for kontrolpanel hvor du kan vælge tastaturlayout.