Mint 18.x kan nu opgraderes til Mint 18.2 Sonya

frogmaster
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Mint 18.x kan nu opgraderes til Mint 18.2 Sonya

Det er nu muligt at opgradere Mint 18.x til Mint 18.2 fra Opdateringshåndtering, både KDE, Xfce, MATE og Cinnamon DE.

Før du gør det, så tjek advarslerne igennem vedr. Grub og nomodeset iht dit grafikkort. Du præsenteres for advarslerne fra Opdateringshåndtering. Der er også en kernel upgrade (4.4.0-83) der passer til Mint 18.2 (Sonya).

Det er også en god ide lige at kikke dette glimrende site igennem før du begynder: https://sites.google.com/site/easylinuxtipsproject...

Hvis du har installeret udvidelser i Systemindstillinger, så skal du formentlig opdatere dem manuelt efter opgradering til Mint 18.2

Og som altid, hvis funktionalitet er vigtigst, så vent en måned eller to, eller indtil der er bred enighed i at eventuelle fejl er rettet.


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
Og som altid, hvis

Og som altid, hvis funktionalitet er vigtigst, så vent en måned eller to, eller indtil der er bred enighed i at eventuelle fejl er rettet.

Normalt vil jeg altid anbefale det samme, men denne gang er en undtagelse, da 18.2 er ekstraordinært stabil. Jeg kører det på min desktop, og jeg kan simpelthen ikke finde nogle bugs nogen steder. Jeg har testet det ved intenst daglig brug hver dag, siden udgivelse. Alle jeg har set og hørt på nettet har sagt det samme. Denne gang er det noget andet.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
#1 Ja enig. Jeg har også

#1

Ja enig. Jeg har også opgraderet min test maskine (Cinnamon), inklusiv en VM med KDE, og opgraderingen gik glat igennem. Der kan dog være noget, på visse maskine typer, der måske ikke gør, ifølge Mint 18.2's Release Notes: https://www.linuxmint.com/rel_sonya_cinnamon.php

Hvis det skulle ske, så vil jeg kalde det ganske godt dokumenteret, med anvisninger på at løse et potentielt problem.


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
Den er naturligvis ikke

Den er naturligvis ikke perfekt, frogmaster. Men det er muligvis den bedste Mint siden 11 Katya, efter min mening.


km
Antal: 3
Tilmeldt:
06-03-2016
User is offline
det må jeg osse prøve

Det lyder så lovende at jeg i går har opgraderet til mint 18.2 (KDE). Jeg brugte "apt-get dist-upgrade" uden vanskeligheder. Det jeg mest arbejder med er billede og lyd, så det er audacity, kdenlive, digikam, rawtherapie etc.. Det er faktisk første gang i mine 10-12 år med linux at jeg laver en dist-upgrade.
Det fungerer ok.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Det er korrekt, og som du

Det er korrekt, og som du nævner, så er opgraderinger heller ikke noget jeg almindeligvis anbefaler.

I forbindelse med KDE's Plasma 5, så virker den overbevisende på mit system. Jeg kan ikke tale for andre distributioner end Mint's, men der kan være grund til at mene at det også gælder for andre Linux.

Hvis du, eller en anden arbejder med billede og lyd, streamet indover samba (CIFS) LAN, inklusiv fra Mac's, så installer smb4k på Linux. Det løser alle eventuelle media streaming problemer på LAN, uanset om det handler om KDE eller et andet Linux DE.

Tak til cb400f for den viden.

Vedr. grafikkort drivere, så ønsker nogle måske at forsøge med Open Source versionen fremfor en eventuel proprietær driver på Mint 18.2. På mit system med [AMD/ATI] BeaverCreek [Radeon HD 6520G], giver Open Source driveren både bedre ydelse og mindre ressource forbrug.


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
Vedr. grafikkort drivere,

Vedr. grafikkort drivere, så ønsker nogle måske at forsøge med Open Source versionen fremfor en eventuel proprietær driver på Mint 18.2.

Og så vil jeg for en god ordens skyld anbefale, at det kun gøres med Intel og AMD. Opensource driveren Nouveau til Nvidia er noget værre lort.


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
apt-get dist-upgrade Du kan

apt-get dist-upgrade

Du kan med apt kommandoerne faktisk nøjes med, at skrive sudo apt install, sudo apt dist-upgrade, sudo apt update osv.

Du behøver ikke -get længere. :-)


km
Antal: 3
Tilmeldt:
06-03-2016
User is offline
apt vs apt-get

tak for besked om apt. Jeg havde mere eller mindre registreret at der var et eller andet u
ndervejs. Nu er jeg så lidt længere https://www.maketecheasier.com/apt-vs-apt-get-ubun...
og apt -help, og så har jeg prøvet apt update/upgrade; ok.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Den er naturligvis ikke

#3: Den er naturligvis ikke perfekt, frogmaster. Men det er muligvis den bedste Mint siden 11 Katya, efter min mening.

Nu har jeg testet Cinnamon upgraderingen til 18.2 yderligere, og tror jeg har fundet en rimelig fatal fejl. Problemet består PT i at Mint bruger MDM som Login.

Efter opdatering af Grub (sudo update-grub) mister Mint 18.2 login billedet fra 18.1, hvor man i stedet præsenteres for en sort skærm med credentials. Det er ikke i sig selv et problem, men hvis brugeren synes han el. hun vil have billede tilbage i login skærmen, så skal MDM udskiftes med Ubuntu's LightDM (sudo apt-get install slick-greeter lightdm lightdm-settings apparmor) og MDM slettes med (sudo remove mdm).

(Alternativt kan man bruge et andet login tema, men Mint X eget giver blot denne sorte skærm.)

Det går også fint, men systemet efterlader stadig en konfigurations fil til MDM. Hvis man sletter den, mister Mint 18.2 PT evnen til at boote., eller rettere, den booter, men kan ikke starte X. Det er muligt at starte uden DE.

Noget andet er en clean install af Mint 18.2 64 bit d. 17. juli 2017. Den kommer uden support af 32 bit kompatibilitet. Det er ikke specielt brugervenligt, så hvis man ikke ved man skal installere sudo apt install ia32-libs, så vil man opleve at visse programmer ikke kører.

Jeg synes det er relevant at nævne ...


FrugalMan
FrugalMan's picture
Antal: 981
Tilmeldt:
18-12-2007
User is offline
Efter opdatering fra 18.1

Efter opdatering fra 18.1 til 18.2 oplever jeg dette problem når jeg logger ind
Problemer under opstat af Cinnamon

Opstarten af Cinnamon fuldførtes, men et eller flere panelprogrammer. skrivebordsprogrammer eller udvidelser kunne ikke indlæses.

Tjek din systemlog og loggen for Cinnamons lup for mulige problemer. Du kan deaktivere de(n) prolomatiske udvidelse(r) i Systemindstillinger for at forhindre denne meddelse i at dukke op igen. Kontakt venligst udvikleren.

Men hvilke filer skal jeg se i?. Jeg kan heller ikke finde noget i Systemindstillinger.

EDIT: Jeg så fandt jeg problemet, sådan er der altid :) Det var Cinnamon Twaeks der lige skulle opdateres, så blev det slut med meddelsen.


joedalton
Antal: 78
Tilmeldt:
26-01-2009
User is offline
uden -get er ikke helt det samme

#7:
Hej, prøvede lige på en Debian Sid

sudo apt-get upgrade gav ingen filer til installation, men det gjorde sudo apt upgrade. (virker som om at tilbageholdte pakker ryger med, når -get udelades), så der er ikke samme funktionalitet ved bare at undlade -get.

joe@baerbar:~$ sudo apt-get upgrade
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen... Færdig
Følgende pakke blev installeret automatisk, og behøves ikke længere:
alsa-base
Brug »sudo apt autoremove« til at fjerne den.
Følgende pakker er blevet holdt tilbage:
libvlc-bin libvlc5 libvlccore8 linux-image-amd64 vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt
vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 14 opgraderes ikke.
joe@baerbar:~$ sudo apt upgrade
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen... Færdig
Følgende pakker blev installeret automatisk, og behøves ikke længere:
alsa-base liblivemedia57
Brug »sudo apt autoremove« til at fjerne dem.
Følgende NYE pakker vil blive installeret:
liblivemedia58 linux-image-4.11.0-2-amd64
Følgende pakker vil blive opgraderet:
libvlc-bin libvlc5 libvlccore8 linux-image-amd64 vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt
vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
14 opgraderes, 2 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
56,1 MB skal hentes fra arkiverne.
Efter denne handling, vil 192 MB yderligere diskplads være brugt.
Vil du fortsætte? [J/n]


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
så der er ikke samme

så der er ikke samme funktionalitet ved bare at undlade -get.

Nej, det er en evolution og forbedring fra apt-get. Hvad skulle det ellers være? Apt-get er forældet.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Hej, prøvede lige på

#11:

Hej, prøvede lige på en Debian Sid
sudo apt-get upgrade gav ingen filer til installation, men det gjorde sudo apt upgrade. (virker som om at tilbageholdte pakker ryger med, når -get udelades), så der er ikke samme funktionalitet ved bare at undlade -get.

Dit eksempel viser at det sker på Debian.
Jeg har ingen tilbageholdte pakker på Mint 18, men jeg har på Mint 17. På Mint 17 opgraderer terminal kommandoen (apt-get upgrade) disse tilbageholdte pakker.

Her er et eksempel fra et gammelt bash, jeg bruger til at advare brugere der ikke er vant til Linux:

#!/bin/bash

echo -e "\033[1;31mWARNING! \033[0mThis will override policy settings within the graphical Update Manager. If you have deliberately downgraded packets such as an older version of Samba, a new version will be installed that's known to break LAN connections to OS X"
echo
echo "You may want to abort this script and instead use the graphical Update Manager to keep the system updated"
sudo apt-get update && sudo apt-get upgrade

# We're gonna exit the terminal
tput setaf 3
tput bold
read -n1 -r -p "Press any key to exit..." key
tput sgr0
exit
$SHELL

For en ordens skyld virker apt (uden -get) også på Ubuntu 14.04 og Mint 17.

uname -a
Linux mint-17-3 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:37:25 UTC 2015 i686 i686 i686 GNU/Linux

sudo apt upgrade
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen ... Færdig
Følgende pakker vil blive opgraderet:
libexpat1 libldb1 libnss-winbind libpam-winbind libparse-pidl-perl
libsmbclient libsmbsharemodes0 libwbclient0 linux-libc-dev python-ldb
python-samba samba samba-common samba-common-bin samba-doc
samba-dsdb-modules samba-libs samba-vfs-modules smbclient winbind
20 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
10,2 MB skal hentes fra arkiverne.
Efter denne handling, vil 6.448 kB yderligere diskplads være brugt.
Vil du fortsætte? [J/n]

sudo apt-get upgrade
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Beregner opgraderingen ... Færdig
Følgende pakker vil blive opgraderet:
libexpat1 libldb1 libnss-winbind libpam-winbind libparse-pidl-perl
libsmbclient libsmbsharemodes0 libwbclient0 linux-libc-dev python-ldb
python-samba samba samba-common samba-common-bin samba-doc
samba-dsdb-modules samba-libs samba-vfs-modules smbclient winbind
20 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
10,2 MB skal hentes fra arkiverne.
Efter denne handling, vil 6.448 kB yderligere diskplads være brugt.
Vil du fortsætte? [J/n]

I dette tilfælde (Mint 17.3) er samba version:
samba --version
Version 4.1.6-Ubuntu

Hvis jeg bruger apt-get upgrade eller apt upgrade, så vil maskinens LAN forbindelse knække til OS X med de ovenstående terminal opgraderinger.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Wobbly Windows i Cinnamon

Hvis man synes lignende funktioner, som Wobbly Windows i KDE er sjovt, men oplever ghost virkninger på skærmen med fx Cinnamon og derfor mener det ikke fungerer, så kan løsningen være:

How to make Wobbly Windows work in Mint 18.

- Install the Wobbly Windows extension within System Settings > Extensions
- Update the extension if any
- As root, edit: gksudo xed /etc/environment and add the line:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling CLUTTER_VBLANK=True

- Save file
- Log out and in
- Enable Wobbly Windows

Eksempel: https://www.dropbox.com/s/reg4owedjaqdjp2/wobbly-w...


OracleJMT
OracleJMT's picture
Antal: 191
Tilmeldt:
26-05-2013
User is offline
Hvis man bruger Nvidia og

Hvis man bruger Nvidia og oplever screen tearing, kan man lave en xorg.conf i nvidia-settings med root, såfremt den ikke eksisterer i forvejen.

Derefter åbner du /etc/X11/xorg.conf, eller hvor du har placeret den. Du kan også lave en 20-nvidia.conf i xorg.conf.d. Dog er /etc/X11/xorg.conf en fin nok placering.

I selve xorg.conf scroller du ned til rubrikken "screen," og der hvor du ser der står "metamodes" føjer du en ekstra linje ind, som her:

Klik her

Gem og genstart.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Gennemsigtige vinduer i Cinnamon

Transparente vinduer kan være ganske nyttige, eksempelvis hvis man ønsker at læse en tekst bag vinduet. Det kræver ingen udvidelser, men indstillingen er gemt lidt af vejen, så den kan være svær at finde:

Systemindstillinger > Vinduer > Handlig på titlelinje med muserulning > Juster uigennemsigtighed.


frogmaster
frogmaster's picture
Antal: 3174
Tilmeldt:
20-05-2010
User is offline
Skrivebords gitter i Mint 18.2 Cinnamon

Skrivebordet er ændret i Mint 18.2 Cinnamon. Desktop grid er forbedret siden 18.1.

Standard indstillingen er lidt klodset med en stor ikon afstand, men det kan ændres fra dconf-redigering. Den skal først installeres.

- sudo apt install dconf-editor

- Fra et tomt sted på skrivebordet, højreklik > Skrivebord og fjern hakket i Arranger automatisk. Lad hakket blive i Placér på gitter.

- Start dconf og naviger til org > nemo > desktop
- Ændr horizontal-grid-adjust til en værdi der passer dig. Jeg vil foreslå 0.5
- Ændr vertical-grid-adjust til fx 0.8
- Ændr font til Noto Sans 9

Disse værdier giver et skrivebord hvor ikonerne er placeret som vist på billedet: https://www.dropbox.com/s/d60ifk632fph96i/skrivebo...