[løst]Umlaut + andre specialtegn virker ikke i Arch + LXDE

casperh
Antal: 414
Tilmeldt:
16-08-2007
User is offline
[løst]Umlaut + andre specialtegn virker ikke i Arch + LXDE

Hej

Jeg kører med Arch Linux + LXDE, men umlaut og andre special tegn som ä, Ö osv. virker ikke. Når jeg vil skrive fx ä, får jeg ^a (altså shift+^¨~-knappen).

Fra min rc.conf:

LOCALE="en_DK.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Europe/Copenhagen"
KEYMAP="dk.map.gz"
CONSOLEFONT=cp850-8x16
CONSOLEMAP=8859-15
USECOLOR="no"

Fra min locale.gen:

en_DK
en_DK.iso88591
en_DK.utf8
en_US
en_US.iso88591
en_US.utf8

Jeg skal såvidt muligt køre med dansk keyboard mens jeg har engelsksprog i systemet.

æøå virker.

På forhånd tak

Casper.


dk_zero-cool
dk_zero-cool's picture
Antal: 2529
Tilmeldt:
21-12-2007
User is offline
Re: Umlaut + andre specialtegn virker ikke i Arch + LXDE

Du skal i din rc.conf ændre en_DK til en_US

Det du sætter har INTET med tastatur at gøre, det er Sprog og Område. Det vil sige at du vælger (Danish version of the English language), og det findes ikke. Det hele er sprog indstillinger. Tastaturet sætter du i din xorg.conf for X, plus dit keyboard map som allerede er valgt som dansk (dk.map...)


Anda
Antal: 436
Tilmeldt:
08-11-2008
User is offline
Re: Umlaut + andre specialtegn virker ikke i Arch + LXDE

Bruger du 'nodeadkeys' under 'InputDevice' i xorg.conf ?

Hvis du gør det, skal denne linje fjernes.


casperh
Antal: 414
Tilmeldt:
16-08-2007
User is offline
Re: Umlaut + andre specialtegn virker ikke i Arch + LXDE

Det gjorde det, tak Anda og dk_zero-cool :-)