Installation af Wireless Driver

Domiino
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Installation af Wireless Driver

Jeg har en ældre Lenovo 3000 v200 til at stå jeg har smidt Midt Linux på - dejligt system!

Men det er som om at Linux ikke kender driveren, og kan læse mig frem til at den skal installeres manuelt.

Jeg har fundet frem til det er her jeg skal ind og rode: Indsæt tekst her...

Men - jeg aner jo ikke hvilket netkort der sidder i bærbaren, nogen der ved hvad jeg kan gøre?


lbm
lbm's picture
Antal: 824
Tilmeldt:
14-06-2006
User is offline
Lyder mærkeligt hvis at et

Lyder mærkeligt hvis at et ældre wifi kort ikke er direkte understøttet!

Du kan prøve at skrive lspci og se om det dukker op.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Det må være denne

Det må være denne her:

06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)


cb400f
cb400f's picture
Antal: 3495
Tilmeldt:
20-02-2005
User is offline
iwlwifi-driveren er en del

iwlwifi-driveren er en del af mainline-kernen og bør understøtte det kort. Så du behøver i hvert fald ikke installere driveren manuelt.

Hvis det er den Ubuntu-baserede version af Linux Mint (går ud fra det er den der menes med "Midt Linux"), burde firmwaren være installeret som standard, men hvis det er den Debian Testing-baserede Linux Mint ("LMDE"), du har installeret, er det muligt at firmwaren ikke er installeret som standard.

Dukker dit wifi-interface slet ikke op i NetworkManager-appletten i systray eller i outputtet af 'iwconfig' f.eks.?


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Jeg har fået hentet den fra

Jeg har fået hentet den fra siden, og nu mangler jeg bare at installer den ind i kernel, men er lidt i tvivl om hvordan det gøre da der er flere forskellige guides til det.


lbm
lbm's picture
Antal: 824
Tilmeldt:
14-06-2006
User is offline
Prøv at kigge her, jeg går

Prøv at kigge her, jeg går ud fra at mint og debian er ens på de punkter?

http://wiki.debian.org/iwlegacy


persen61
persen61's picture
Antal: 232
Tilmeldt:
04-01-2009
User is offline
RE: wireless driver

Tilslut din maskine til netkabel, hent de sidste nye opdateringer.
Genstart maskinen, nu skulle det gerne virke.
Har selv kørt med det netkort ingen problemer i Mint.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Det ser ikke ud til den vil

Det ser ikke ud til den vil tage imod den repository

Jeg har prøvet både at tilføje wheezy og Squeeze.

Her er fejlen:

W: GPG-fejl: http://http.debian.net wheezy Release: Følgende signaturer kunne ikke verificeret, da den offentlige nøgle ikke er tilgængelig: NO_PUBKEY AED4B06F473041FA
W: GPG-fejl: http://http.debian.net squeeze Release: Følgende signaturer kunne ikke verificeret, da den offentlige nøgle ikke er tilgængelig: NO_PUBKEY AED4B06F473041FA
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ       
Læser tilstandsoplysninger... Færdig
Følgende NYE pakker vil blive installeret:
  firmware-iwlwifi
0 opgraderes, 1 nyinstalleres, 0 afinstalleres og 231 opgraderes ikke.
0 B/3.579 kB skal hentes fra arkiverne.
Efter denne handling, vil 7.399 kB yderligere diskplads være brugt.
ADVARSEL: Følgende pakkers autenticitet kunne ikke verificeres!
  firmware-iwlwifi
Installér disse pakker uden verifikation (y/N)? Y
(Læser database ... 148787 filer og kataloger installeret i øjeblikket.)
Udpakker firmware-iwlwifi (fra .../firmware-iwlwifi_0.36+wheezy.1_all.deb) ...
dpkg: fejl under behandling af /var/cache/apt/archives/firmware-iwlwifi_0.36+wheezy.1_all.deb (--unpack):
forsøger at overskrive '/lib/firmware/iwlwifi-105-6.ucode', som også er i pakken linux-firmware 1.106
dpkg-deb: fejl: underproces indsæt blev dræbt af signal (Broken pipe)
Der opstod fejl under behandlingen:
/var/cache/apt/archives/firmware-iwlwifi_0.36+wheezy.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
06:00.0 Network controller:

06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Er du sikker på at Lenovo 3000 v200 har intels wi-fi kort? Samme model findes også med et wi-fi Broadcom.

Måske kan du se hvilket kort der sidder i, ved at installere:

sudo apt-get install hardinfo

(System Profiler and Benchmark)


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Der sidder en Broadcom

Der sidder en Broadcom Ethernet Controller i - men ikke i Wireless... der står Intel Corporation PRO/Wireless 4965 AG or AGN


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
OK. Jeg vil godt prøve at

OK. Jeg vil godt prøve at kikke efter en fungerende driver, men så skal jeg også lige have at vide hvilken version af Mint du har installeret.

Husk også at debian ikke er kompatibel med mint, der er en ubuntu derivat og kræver ubuntu kompatibilitet.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Jeg har lige prøvet at

Jeg har lige prøvet at smide Ubuntu på maskinen. Men det er nøjagtigt samme fejl - manglende drivere.

Jeg har installeret Ubuntu 13.04

Du er en superman hvis du kan få den op at kører!


cb400f
cb400f's picture
Antal: 3495
Tilmeldt:
20-02-2005
User is offline
Hvad er det der får dig til

Hvad er det der får dig til at tro at der mangler driver? Og at det ikke er noget andet der er galt? Det kort burde være understøttet ud ad æsken på enhver mainstream-distro fra dette årti.

Er du sikker på at der ikke er slukket for wifi på en hardware-kontakt?


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Nope... har tripple tjekket.

Nope... har tripple tjekket. Skyder jeg den først fra, så går Bluetooth ud, slår jeg den til igen går Bluetooth til, Wlan blinker lige en enkelt gang og så stopper den igen.


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
Intel har nogle divergerende

Intel har nogle divergerende oplysninger. De lister driveren, men den er alligevel ikke til download i versionen. Måske en af de listede virker:

https://downloadcenter.intel.com/Detail_Desc.aspx?...

Jeg kan se at du ikke er den eneste der ikke kan få wi-fi kortet til at fungere.

Andet sted nævnes driveren på ubuntu 11.10 fungerer:

http://ubuntudanmark.dk/forum/viewtopic.php?f=31&t...

http://askubuntu.com/questions/65193/why-does-ubun...

Download:

http://old-releases.ubuntu.com/releases/oneiric/

Tilsvarende Mint 12.

http://linuxmint.com/rel_lisa.php


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Hmmm... så må jeg jo

Hmmm... så må jeg jo installer Mint 12... men ok, det er heller ikke min primære PC, så jeg må jo nøjes med en lidt ældre... det går nok.

Jeg prøver at hente den og installer den istedet.


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
Jo men prøv at se her før

Jo men prøv at se her, før du du installere mint 12:

http://wireless.kernel.org/en/users/Drivers/iwlega...

Intel® Wireless WiFi Link 4965AGN kan tilsyneladende downloades.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Cool! Men så lige et

Cool!

Men så lige et spørgsmål - hvordan installer jeg dem og hvilken skal jeg vælge hvis jeg nu installer den nye Mint Linux?


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
#17Det kan jeg ikke svare

#17

Det kan jeg ikke svare på siden jeg ikke har lenovo'en. Driverne supporteres med 2.6 kernel, men nyere mint har PT 3.6 kernels og højere.

Jeg ville forsøge med den nederste først. Når du udpakker tgz filen, er der en readme file med installeringsinstruks.

Kan du ikke få en af driverne til at virke, ville jeg forsøge med en mint 13 LTS eller ubuntu 12.04 (LTS) før forsøg med mint 12.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Der står i Readme filen at

Der står i Readme filen at jeg skal cp ucode filen til min /lib/firmware - DONE! Og så skal jeg loade driveren? Jeg har hentet den nederste af dem på listen og jeg har Linux Mint 15 "Olivia" installeret lige pt....


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
Jeg går ud fra at linux

Jeg går ud fra at linux firmware er default installeret i mint 15?

Kik efter om iwlwifi-4965-2.ucode findes i /lib/firmware

http://db.tt/7QCUA1KC

Hvis den ikke gør, kopier iwlwifi-4965-2.ucode fra den downloadede tgz til /lib/firmware med root tilladelse. Findes iwlwifi-4965-2.ucode i forvejen, tag en backup af originalen, og kopier den nye til mappen firmware.

Søg på Yderligere drivere fra mint menuen, og aktiver wi-fi driveren derfra.

Genstart maskinen og se om det har hjulpet.

Kontroller med dmesg fra en terminal, og kik efter alt hvad der relatere til wi-fi.

Hvis det stadig ikke virker, kopier backup af iwlwifi-4965-2.ucode tilbage til firmware (med root tilladelse).

Prøv og se hvad du får ud af dette site:
https://bugs.launchpad.net/ubuntu/+source/linux-re...


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Det er vildt underligt...

Det er vildt underligt... jeg kan se den både i dmesg, lspci - jeg kan se den kender navnet på Driveren osv.. jeg har prøvet at hente en ny og overskrive den gamle... genstarte... jeg har tjekket at "alt" er som det plejer at være. Men den vil bare ikke en ski!

Jeg har prøvet at indtaste alle informationer ind manuelt for at se om det kunne det... heller ikke. Det er da lidt underligt. Og det har været gældende for ALLE de Linux Distoer jeg har prøvet indtil nu. Ubuntu, Debian og Mint... måske jeg skal prøve med en helt anden Kerne? Fedora eller noget?


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
måske jeg skal prøve

#21: måske jeg skal prøve med en helt anden Kerne? Fedora eller noget?

Ja, og hvis det heller ikke virker, så er det formentlig kortet der er defekt. Det kan også være routeren der ikke bryder sig om det.

Hvis du ikke allerede har set på Youtube efter forslag, kan du måske være heldig at finde en løsning. Jeg mener at huske, at det muligvis kan lade sig gøre at installere ndiswrapper og en windows driver fra inf-filen.

https://www.google.dk/search?q=wifi+in+ubuntu+13.0...

Alternativt kan du købe en wi-fi dongle.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Jeg kan nemt få den til at

Jeg kan nemt få den til at virke med Windows 7 og 8... ingen problem. Så det er ikke kortet der er defekt.

Men det ender nok med en dongle....


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Nu er jeg kommet et skridt

Nu er jeg kommet et skridt videre i min efterforskning.

Jeg har installeret en ren rå Debian, og sjovt nok kom den op med manglende driver under installationen, jeg fandt driveren på nettet - lagde den på en USB Stick og fik den installeret. Sjovt nok - så kunne den finde mit Wireless Netværk, den tog også imod koden... alt virkede og hele installationen gik faktisk igennem WIFI... men efter installationen kunne den ikke starte Wireless.... jeg kan se den, men aktiverer jeg den går den bare direkte over på deaktiveret bagefter...

Er der nogen der kan gennemskue den?


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Nu har jeg fundet mig en

Nu har jeg fundet mig en D-Link DWA-121 Pico USB WLAN Dongle... sat den i - og det ser også ud til at min Linux Distro finder den... men men men... jeg har ikke aktiver og finde noget Wireless hjemme alligevel..

Jeg har installeret WIFI Radar - og den kan både finde netværk med det indbyggede WIFI Kort og med D-LINK DWA-121 kortet... men jeg kan bare ikke connect. Jeg har prøvet med Windows maskiner og med Mobiltelefoner.. igen - INGEN Problemer... hvad kan der være galt?


kenneth
kenneth's picture
Antal: 457
Tilmeldt:
02-01-2008
User is offline
Det er et generelt problem i

Det er et generelt problem i driveren til den linie af netkort, jeg har selv en bærbar med Intel 3945AGN som virker fint når jeg installere arch med live mediet, lige så snart maskinen er genstartet er det trådløse net total dødt, selv om at alt hvad det trådlæse kræver for at virke er installeret, så mit gæt og bud, vil være at det er kernen der nok ikke lige kan hitte ud af, hvad kortet er for noget, har du prøvet med en ældre kernel? jeg har ved samme lejlighed opserveret at forskellige distroer får wifi lamperne til at lyse og blinke tilfældigt selvom der er klippe stabil forbindelse, hvilket ikke gør så meget, det er bare irrirterende at se på.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Så er det store spørgsmål

Så er det store spørgsmål - hvorlangt skal jeg gå tilbage i Kernel? Og hvor kan jeg finde sådan en henne? Jeg il allerhelst kører på en Debian Installation, da det er det jeg har brugt lige siden tiders morgen...

Netkortet har jo drivere til Kernel 2.6... så det er nok derned af jeg skal for at få det til at virke...


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
GENNEMBRUD!!!!! Jeg fandt

GENNEMBRUD!!!!!

Jeg fandt dette link: http://askubuntu.com/questions/143208/unable-to-en...

Jeg kan også få det til at virke med:

"rfkill list"

Der i listen er der en Acer-Driver jeg så fjerner med:

"rmmod acer-wmi"

Men den er i problemer igen efter jeg har genstartet....

Hvordan kan jeg permanent fjerne den fra listen?


frogmaster
frogmaster's picture
Antal: 4831
Tilmeldt:
20-05-2010
User is offline
Hvordan kan jeg

#28: Hvordan kan jeg permanent fjerne den fra listen?

Jeg vil foreslå du klipper alle andre wi-fi drivere fra /lib/firmware til en backup mappe. Lade være med at slette dem.

Problemet skyldes formentlig, som nævnt flere gange, kernel support.

Har du forsøgt med en dongle? De koster ikke alverden. Før du eventuelt forsøger, kan det betale sig først at undersøge hvilken der virker bedst.


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
Der ligger kun en fil

Der ligger kun en fil derinde:

"iwlwifi-4965-2.ucode" og en mappe ved navnet "hp"


osjensen
osjensen's picture
Antal: 1692
Tilmeldt:
14-01-2007
User is offline
Du kan sikkert "blackliste"

Du kan sikkert "blackliste" acer-wmi, så modulet ikke indlæses ved opstart:

http://www.cyberciti.biz/tips/avoid-linux-kernel-m...

os.

--------------------------------------------------------
Søg på linuxin:
https://duckduckgo.com/?q=+site%3Alinuxin.dk+%3F&i...


Domiino
Domiino's picture
Antal: 640
Tilmeldt:
26-03-2008
User is offline
SÅDANNER! Nu starter den

SÅDANNER!

Nu starter den bare op som smurt og ALT virker som det skal... tak for hjælpen allesammen!