Promblem med hp printer

leon
Antal: 16
Tilmeldt:
24-04-2011
User is offline
Promblem med hp printer

Hej alle.

Jeg køre opensuse 13.1 og har lige købt en HP Coller Laserjet CO1025. Opensuse kan godt se printeren men jeg ikke skrive ud. Jeg har instaleret CUPS og hplib men når jeg prøver at udskrive for jeg nedenstående fejl besked i /var/log/cups/error_log

E [14/Aug/2015:14:21:45 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [14/Aug/2015:14:23:34 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [14/Aug/2015:14:25:37 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!

Jeg har søgt på google uden støre hjælp, så jeg håber nogle her kan hjælpe.

Mvh Leon


osjensen
osjensen's picture
Antal: 1201
Tilmeldt:
14-01-2007
User is offline
Har du

Har du installeret:
hplip
hplip-common
hplip-gui
hplip-hpijs
hplip-libs

og installeret den vej, med hp-værktøjet.


leon
Antal: 16
Tilmeldt:
24-04-2011
User is offline
hplip instaleret

Jeg har instaleret hplib men de andre der er listet hvor finder jeg dem?

Mvh Leon


osjensen
osjensen's picture
Antal: 1201
Tilmeldt:
14-01-2007
User is offline
Måske

Måske her:
https://software.opensuse.org/package/hplip

Der må være en Opensuse bruger, der kan hjælpe dig videre.
Jeg har ikke Suse installeret.

På min installation er de med på installations-cden, og i pakkehåndteringen.

Måske et bedre link:
https://en.opensuse.org/SDB:How_to_set-up_a_HP_pri...


SteenA
Antal: 60
Tilmeldt:
01-08-2013
User is offline
Jeg har: hplip-hpijs - Only

Jeg har:
hplip-hpijs - Only plain printing with HPLIP printer drivers
hplip-sane - Only plain scanning with HPLIP scan drivers
installeret når jeg tjekker i Yast.


cb400f
cb400f's picture
Antal: 3434
Tilmeldt:
20-02-2005
User is offline
#0Jeg har selv en HP

#0
Jeg har selv en HP farvelaser-printer og har følgende installeret (på openSUSE 13.2):

cb400f@klaptop:~> rpm -qa *hplip*
hplip-3.14.6-2.2.4.x86_64
hplip-hpijs-3.14.6-2.2.4.x86_64
hplip-sane-3.14.6-2.2.4.x86_64

Kan du tjekke hvilken version af hplip du har installeret?

Ifølge http://hplipopensource.com/hplip-web/supported_dev... skulle din printer kræve mindst HPLIP 3.12.4 og openSUSE 13.1 kommer med HPLIP 3.13.10 som standard, så det burde sådan set virke.

Hvilke(n) tilslutningsmulighed(er) har du prøvet? USB? Wifi? Netværkskabel? Det drillede f.eks. for mig med netværkskabel, så jeg bruger bare USB, da det virkede uden problemer, og det ikke gør nogen forskel for mig.

Det kan godt være du skulle overveje at prøve at opgradere til en nyere HPLIP, det kan du f.eks. gøre sådan her:

1) Tilføj "Printing"-softwarekilden
zypper addrepo -f http://download.opensuse.org/repositories/Printing... printing

2) Installer/opgrader pakken (du vil nok blive spurgt om at tillad "leverandørændring" for nogle pakker, sig "ja" til det).
zypper install 'hplip>=3.15.6'


leon
Antal: 16
Tilmeldt:
24-04-2011
User is offline
Problemet er løst.

Okay det er næsten til grin selvom jeg brugte mange timer på google i går uden at finde noget kiggede jeg igen i dag. Jeg havde åbenbart brug for nogle nye øjne "jed syntes ikke jeg så det igår" men man skal køre neden stående komando i et shell vinndue og et gui åbnes og så skal der bare trykkes next.

su - -c "hp-setup"

Men tak for de mange svar.

Mvh Leon


Sprove
Antal: 21
Tilmeldt:
23-10-2014
User is offline
Printer: Canon Pixma MG6650

Jeg har fornylig købt ovennævnte printer, som laver udmærkede kopier i Windows7.

Når jeg kobler min Linux-PC (Mint 17.1), stopper legen, og det er ikke muligt at vriste
en kopi ud af printeren.

Er der nogen, som ved, hvad det skyldes - og kan jeg gøre noget ved det? Forhandleren
aner ikke, hvad det skyldes !?!

På forhånd tak for svar
Mvh Torkel Sprove


osjensen
osjensen's picture
Antal: 1201
Tilmeldt:
14-01-2007
User is offline
#7 Har du installeret

#7
Har du installeret hplip-sane pakken som vist i #5