[LØST] MySQL Replication Connecting but no synkronization

peque
Antal: 890
Tilmeldt:
20-04-2005
User is offline
[LØST] MySQL Replication Connecting but no synkronization

Hej Forum.

Jeg sidder og har lavet flere replikationer på MySQL databaser, men er kommet til en fejl jeg ikke lige kan se hvad problemet er.

Hvad der undrer mig er - jeg får dette i MySQL.err på SlaveDB

Slave SQL thread for channel 'skibsnavn' initialized, starting replication in log 'mysql-bin.000001' at position 154, relay log './mysqld-relay-bin-skibsnavn.000001' position: 4
Slave I/O thread for channel 'skibsnavn': connected to master 'mysql_replic@12.34.56.78:3306',replication started in log 'mysql-bin.000001' at position 154
2015-08-31T07:57:01.329155Z 66 [Note] Coordinator and workers enter synchronization procedure when scheduling event relay-log: ./mysqld-relay-bin-skibsnavn.000002 pos: 153
2015-08-31T07:57:01.329186Z 66 [Note] Coordinator synchronized with Workers, waited entries: 0, cant_sync: 0

Og på selve Master DB har jeg følgende:

2015-08-31T07:57:32.280428Z 4 [Note] Start binlog_dump to master_thread_id(4) slave_server(1), pos(mysql-bin.000001, 154)

Men et select Statement viser intet i den synkroniserede tabel.
jeg er sikker på at min slave har adgang og kan replikere.
jeg er sikker på at begge steder kører binlog format Statement.

Har nulstillet slave variabler, databaser og tabeller flere gange men samme resultat. Kan se min slave henter relay-bin filer og de ligger på slave men der kommer bare ikke noget data i tabellen.

Hvad kan fejlen være her ???


lbm
lbm's picture
Antal: 807
Tilmeldt:
14-06-2006
User is offline
Starter du/importere du

Starter du/importere du dataen fra den korrekte positon, og findes den position in binlog filen ?


peque
Antal: 890
Tilmeldt:
20-04-2005
User is offline
Som jeg har gjort

Som jeg har gjort her:
oprettet database med script på Master unikt ID 20
Oprettet database med script på Slave unikt ID 1
Flushes binlog filer på begge server
Master status viser pos 154 på mysql-bin.000001 - hvilket bruges i Slave oprettelsen

Data insertes i Master.
Oprettet slave forbindelse fra Slave server som accepterer.

Derefter initializeres forbindelsen og der connectes - Men der replikeres ikke data .
Jeg kan se binlog filer mm

Tror jeg har fundet fejlen i dette
Da det er et færdigt image der clones ud til de enkelte master DB da der er mange ad disse.
Problemet opstår ved server-UUID i autoconf.cnf er duplikeret.
Slettet autoconf.cnf og genstartet MySQL og pling så kører det.