Plasma kunne ikke bruge OpenGL2

jørgen
Antal: 163
Tilmeldt:
23-02-2003
User is offline
Plasma kunne ikke bruge OpenGL2

Jeg har opgraderet min openSUSE fra Leap 42.2 til 42.3 med
- zypper up
- skift af sti på repositories
- zypper dup

Efter opdatering vil det grafiske system ikke genstarte.

Jeg får fejlmeldingen:
"Plasma kunne ikke starte, da den ikke kunne bruge OpenGL2
Tjek at dine grafikdrivere er sat korrekt op"

Hvordan hulen tjekker jeg om mine grafikdrivere er sat korrekt op?
Jeg har et Nvidia GeForce8600 GT sikkert forældet

Gode ledetråde modtages med tak


cb400f
cb400f's picture
Antal: 3432
Tilmeldt:
20-02-2005
User is offline
Har du installeret den

Har du installeret den proprietære Nvidia-driver? Se http://opensuse-guide.org/3d.php

Jeg har ikke styr på den aktuelle understøttelse fra Nouveau (den frie driver) af forskellige kort. Men den er sikkert ikke så fancy.


jørgen
Antal: 163
Tilmeldt:
23-02-2003
User is offline
Ja, jeg har Nvidia

Ja, jeg har Nvidia repository aktivt.


cb400f
cb400f's picture
Antal: 3432
Tilmeldt:
20-02-2005
User is offline
Hvis du kan få fingre i en

Hvis du kan få fingre i en terminal kan du prøve at kigge på

'zypper se -s nvidia' for at se hvilke nvidia-pakker der faktisk er installeret.

'hwinfo --gfxcard' burde også fortælle lidt om hvilken driver der er loadet. Ved ikke helt om det gælder hvis X ikke kan starte.

Du kan kigge lidt i /var/log/Xorg.0.log for at se om der er noget info om hvad der går galt.

Får du en display manager/login-skærm, eller kommer du ikke engang så langt? Hvis du får en login-skærm kan du prøve at logge ind i en icewm-session derfra, og se om det virker. Og så har du også grafiske værktøjer mv. du kan arbejde videre med.


jørgen
Antal: 163
Tilmeldt:
23-02-2003
User is offline
Tak for tips. Dem vil jeg

Tak for tips.
Dem vil jeg forfølge snarest.

Jeg får ikke en login skærm. Jeg kan skifte session (Ctrl+Alt+F2) logge ind som root, og f.eks. starte Yast.
Jeg har uden held forsøgt derfra at starte ICEWM - har også forsøgt at installere Gnome, og ændre wm til GDE i /etc/... via den tegnbaserede Yast, men det var ikke succesfuldt.

Min backup plan er at notere partitioneringen, og køre en installation fra en "boot-bar" stick net netværksinstallationen af Leap. Det ville bare være ærgerligt, hvis løsningen lå et snuptag borte :-)


jørgen
Antal: 163
Tilmeldt:
23-02-2003
User is offline
Hmmm, jeg opgav at få

Hmmm, jeg opgav at få forstand på det dine forslag viste mig.

Jeg valgte at køre en opgradering fra en USB med netværksinstallationen af Leap 42.3
Opgraderingen deaktiverede nvdia repository og ryddede op i grafikdriverne, så nu kører det fint igen. Tusind tak for din tid og hjælp.

Ja, pacman blev også deaktiveret, så jeg må lige en tur rundt omkring codecs mv en gang mare, men der har du jo fine 1-clik links.