Nødvendigt program allerede installeret

steen
Antal: 34
Tilmeldt:
11-09-2003
User is offline
Nødvendigt program allerede installeret

Hej, jeg får denne fejlmeddelelse, når jeg prøver at køre et program i LinuxMint

minergate-cli: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by minergate-cli)
minergate-cli: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.8' not found (required by minergate-cli)
minergate-cli: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by minergate-cli)

Når jeg kører denne kommando
sudo apt-get install libdouble-conversion1v5

Kommer denne meddelse
libdouble-conversion1v5 is already the newest version (2.0.1-3ubuntu2).

Er det bare at kopiere de 3 filer i den mappe, programmet fortæller, eller findes der en smartere måde, så jeg ikke skal gøre det igen ved evt. nyere versioner?

Mvh

Steen

Min hjemmeside med opskrifter på krydderiblandinger https://about.me/asmusu2


osjensen
osjensen's picture
Antal: 1326
Tilmeldt:
14-01-2007
User is offline
Er libqt5core5a installeret?
dpkg -S  /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
libqt5core5a:amd64: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
bruger@bruger-virtual-machine ~ $

Er libqt5core5a og libQt5Network5 installeret?

På den her Fri-computer-mint, ser de ud til at være plasseret rigtigt.


mich
mich's picture
Antal: 954
Tilmeldt:
13-10-2007
User is offline
Prøv sym-links

#0: Er det bare at kopiere de 3 filer i den mappe, programmet fortæller, eller findes der en smartere måde, så jeg ikke skal gøre det igen ved evt. nyere versioner?

Frem for at flytte eller kopiere filerne, ville jeg nok prøve at lave sym-links, der hvor programmet prøver at finde dem.

./mich


steen
Antal: 34
Tilmeldt:
11-09-2003
User is offline
Det virker til de andre

Det virker til de andre libQt programmer er installeret i en nyere version.

Hvordan laver jeg symlinket?

ln -s /path/to/file /path/to/symlink

Alså hvad for en er kilde og hvilken er mål?

Det er da et forsøg værd, om programmet kan bruge den nyere udgave

Mvh

Steen

Min hjemmeside med opskrifter på krydderiblandinger https://about.me/asmusu2


osjensen
osjensen's picture
Antal: 1326
Tilmeldt:
14-01-2007
User is offline
Hvis du har

Hvis du har libQt5Core.so.10, men skal bruge libQt5Core.so.5

sudo ln -s /usr/lib/x86_64-linux-gnu/libQt5Core.so.10  /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

Jeg går ud fra at libQt filerne, er i /usr/lib/x86_64-linux-gnu/ mappen.