sådan opdaterede jeg Libreoffice på min Linux Mint LMDE 3

Tony
Antal: 14
Tilmeldt:
07-02-2012
User is offline
sådan opdaterede jeg Libreoffice på min Linux Mint LMDE 3

Opdaterer Libreoffice på min Linux Mint LMDE 3
Download først opdateringerne fra Libreoffice´s hjemmeside og den Danske tilføjelse (husk det skal være –.deb versionerne)
Udpak disse 2 filer og flyt/kopier disse 2 filer til skrivebordet
Åbne terminal :
Ctrl + alt og t
indtast: sudo apt purge libreoffice* og svar J og enter
ls og enter for at se hvad mit skrivebord hedder
cd Skrivebord og enter
ls og enter
maker pakken der hedder Libreoffice_6.1.1.2_Linux_x86-64_deb og højre klik på det markerede vælg kopier
og skriv CD og et mellemrum og højreklik og indsæt og enter
ls og enter
cd DEBS og enter
ls og enter
sudo dpkg –i *.deb og enter n installeres ny Libreoffice
cd .. enter og cd .. enter nu skulle jeg være tilbage til /Skrivebord$
nu til Dansk sprog i Libreoffice
ls og enter
maker pakken der hedder Libreoffice_6.1.1.2_Linux_x86-64_deb_laungpack_da og højre klik på det markerede vælg kopier
og skriv CD og et mellemrum og højreklik og indsæt og enter
ls og enter
cd DEBS og enter
ls og enter
sudo dpkg –i *.deb og enter nu installeres ny Danske sprog pakke i Libreoffice

Nu kan du lukke terminal vinduet og den nye Libreoffice skulle være installeret 


FrugalMan
FrugalMan's picture
Antal: 1186
Tilmeldt:
18-12-2007
User is offline
Er det LibreOffice 6.1.1.2

Er det LibreOffice 6.1.1.2 10

"Man kan modstå alt undtagen fristelser" - Oscar Wilde
Frit Software


OracleJMT
OracleJMT's picture
Antal: 378
Tilmeldt:
26-05-2013
User is offline
Så er det heller ikke

Så er det heller ikke sværere, at holde sig opdateret og samtidig undgå besværet med selv, at hente og installere fra hjemmesiden

Libreoffice flatpak

Been around in IT & IT security since 07'
Entered the Nix* world in march 2011
Have tried & used most, if not all systems available, except LFS

I'm platform agnostic, I use what works for me
My favorites are:

Linux: Ubuntu, Slackware, OpenSUSE, Debian, Fedora
Unix: FreeBSD, OpenBSD, Illumos/Openindiana, DragonflyBSD, NetBSD, OSX


FrugalMan
FrugalMan's picture
Antal: 1186
Tilmeldt:
18-12-2007
User is offline
Så er det heller ikke

#2: Så er det heller ikke sværere, at holde sig opdateret og samtidig undgå besværet med selv, at hente og installere fra hjemmesiden

Nej
Hvis du bruger Arch eller Antergos, så har du altid den nyeste version :)

"Man kan modstå alt undtagen fristelser" - Oscar Wilde
Frit Software


OracleJMT
OracleJMT's picture
Antal: 378
Tilmeldt:
26-05-2013
User is offline
Hvis du bruger Arch eller

Hvis du bruger Arch eller Antergos

Men det gør jeg ikke. :-) Og det er der andre der heller ikke gør. Så hvis man bruger f.eks. Debian Stable, Ubuntu og Linux Mint, hvor pakker er ligeså gamle som gravballemanden, så kan det være en idé at ty til lidt andre metoder, såsom Flatpak.

O.P gør det så besværligt, som det overhovedet kan blive. Det er der ingen grund til. Især ikke, når der refereres til, at rode sig ud i apt, som i forhold til RPM har en syntaks, der er helt i skoven.

Been around in IT & IT security since 07'
Entered the Nix* world in march 2011
Have tried & used most, if not all systems available, except LFS

I'm platform agnostic, I use what works for me
My favorites are:

Linux: Ubuntu, Slackware, OpenSUSE, Debian, Fedora
Unix: FreeBSD, OpenBSD, Illumos/Openindiana, DragonflyBSD, NetBSD, OSX


FrugalMan
FrugalMan's picture
Antal: 1186
Tilmeldt:
18-12-2007
User is offline
Så hvis man bruger

#4: Så hvis man bruger f.eks. Debian Stable, Ubuntu og Linux Mint, hvor pakker er ligeså gamle som gravballemanden, så kan det være en idé at ty til lidt andre metoder, såsom Flatpak.

Nemlig. Det kommer jeg også til at bruge, hjælpe med, når min datter skal have ny stationær computer om 1-2 måneder, hvor hun skal bruge linux Mint, og Windows 10 i VM inden i Linux.

"Man kan modstå alt undtagen fristelser" - Oscar Wilde
Frit Software


OracleJMT
OracleJMT's picture
Antal: 378
Tilmeldt:
26-05-2013
User is offline
Mon det bliver svært, at

Mon det bliver svært, at hjælpe med, da flatpaks kan installeres med ét klik i Linux Mints Softwarecenter? :-)

Been around in IT & IT security since 07'
Entered the Nix* world in march 2011
Have tried & used most, if not all systems available, except LFS

I'm platform agnostic, I use what works for me
My favorites are:

Linux: Ubuntu, Slackware, OpenSUSE, Debian, Fedora
Unix: FreeBSD, OpenBSD, Illumos/Openindiana, DragonflyBSD, NetBSD, OSX


FrugalMan
FrugalMan's picture
Antal: 1186
Tilmeldt:
18-12-2007
User is offline
Mon det bliver svært,

#6: Mon det bliver svært, at hjælpe med, da flatpaks kan installeres med ét klik i Linux Mints Softwarecenter? :-)

HaHa :) Hun skal have vist det nogle gange. Computer er ikke hende. Hun er expert i at lave koks i det, så det er godt hun har den gamle der ved en del om linux, .

"Man kan modstå alt undtagen fristelser" - Oscar Wilde
Frit Software


OracleJMT
OracleJMT's picture
Antal: 378
Tilmeldt:
26-05-2013
User is offline
Jeg kan huske dengang før

Jeg kan huske dengang før OSX, og før Linux blev "lækkert" at bruge for masserne, dengang Windows 98 var på alle computere i hele landet. Da kan jeg huske jeg tænkte, at det var det mest røvsyge i hele verden, og jeg ville helst slippe for, at skulle sidde ved sådan en maskine. Så jeg ved udmærket hvordan det er, når tingene bare skal gøres og bare skal virke.

Been around in IT & IT security since 07'
Entered the Nix* world in march 2011
Have tried & used most, if not all systems available, except LFS

I'm platform agnostic, I use what works for me
My favorites are:

Linux: Ubuntu, Slackware, OpenSUSE, Debian, Fedora
Unix: FreeBSD, OpenBSD, Illumos/Openindiana, DragonflyBSD, NetBSD, OSX


frugtoase
Antal: 96
Tilmeldt:
26-07-2005
User is offline
#0 Du kan også installere

#0
Du kan også installere nyeste LibreOffice fra Backports:

echo 'deb http://ftp.debian.org/debian stretch-backports main contrib non-free' | sudo tee -a /etc/apt/sources.list.d/stretch-backports.list

sudo apt-get -t stretch-backports install libreoffice libreoffice-l10n-da


frogmaster
frogmaster's picture
Antal: 3785
Tilmeldt:
20-05-2010
User is online
Prøv først om det

Prøv først om det eventuelt er muligt, med den Linux OS installation du nu sidder med, om det fra og med LibreOffice version 6, nu er muligt direkte at opgradere fra:

LibreOffice > Hjælp > Søg efter opdateringer ... (Hent/Installer)

Det behøver ikke at være mere besværligt end det måske er.

Windows brugere kan installere og vedligeholde nye versioner gennem Chocolatey Repository (ikke kun LibreOffice), for dermed udgå de mange maliciøse forsøg (eller forsøg på at opgradere Freeware til betalingsversioner), fra tåbelige hjemmesider, der typisk kendetegner Microsoft Windows gennem de sidste 20 år:

https://chocolatey.org/

Hvis du sidder med en Windows 7 eller 10 og du har læst infomationerne i ovenstående link vedr. Chocolatey, men ikke forstår hvordan du kommer videre, så vær venlig at spørge her, eventuelt i en ny tråd ...