Installere linux på en laptop med UEFI

Akker
Antal: 277
Tilmeldt:
25-06-2008
User is offline
Installere linux på en laptop med UEFI

Jeg vil gerne installere linux (KDE Neon eller LinuxMint) på en Lenovo X230 som har UEFI boot ... Linux skal være eneste system på den.

Har prøvet at søge lidt rundt, og hvis ellers jeg har forstået det korrekt, så skulle det være nok at disable UEFI Secure Boot i BIOS? ... Jeg vil gerne disable UEFI Secure Boot, for at være sikker på at kunne installere linux distro's der ikke er UEFI certifikerede.

Der er et sted i BIOS, hvor der står noget med at kunne boote såvel UEFI som Legacy (Booth), og man kan så også vælge, om der skal boote's Legacy eller UEFI først ... Behøver jeg at ændre noget der?
Som sagt, den står til at kunne boote Booth, og at den skal starte med at boote Legacy.

Men kan det virkeligt være så simpelt?
Starte med at disable UEFI Secure Boot i BIOS, og så ellers lade min linux distro by choice overtage laptop'en?


frogmaster
frogmaster's picture
Antal: 3785
Tilmeldt:
20-05-2010
User is offline
Men kan det virkeligt

#0: Men kan det virkeligt være så simpelt?
Starte med at disable UEFI Secure Boot i BIOS, og så ellers lade min linux distro by choice overtage laptop'en?

Ja det burde være nok, men eksempelvis Ubuntu 18.04, Mint 19, med flere 64 bit derivat udgaver supportere UEFI, til forskel fra 32 bit Linux OS der ikke gør. Hvis der er tale om 64 bit OS, så bør det fungere uden at deaktivere UEFI.

Hvis der i forvejen er Windows 10 præinstalleret, så kan UEFI og Secure Boot almindeligvis deaktiveres fra Windows 10.

Imidlertid er der forskel på BIOS fra den ene maskine til den anden. Derfor er du muligvis nødt til at prøve dig frem. Jeg kan ikke svare konkret i henhold til Lenovo X230.


osjensen
osjensen's picture
Antal: 1332
Tilmeldt:
14-01-2007
User is offline
Starte med at disable UEFI

Starte med at disable UEFI Secure Boot i BIOS, og så ellers lade min linux distro by choice overtage laptop'en?

Det var det eneste, jeg gjorde på min Asus.
Måske også justere boot rækkefølgen.


Akker
Antal: 277
Tilmeldt:
25-06-2008
User is offline
Mange tak for jeres

Mange tak for jeres kommentarer ... Desværre gik det ikke så nemt som jeg havde håbet.

I BIOS var UEFI Secure Boot i forvejen slået fra, så der skulle ikke ændres noget.
Derfor installerede jeg KDE Neon (baseret på Ubuntu 18.04), og selve installationen var der ingen problemer med.
Da jeg så efterfølgende genstarter PC'en, går igennem det den skal med BIOS osv., siger også at KDE Neon starter op ... Men der kommer ingen login screen, så jeg kan ikke komme videre.
PC'en reagerer overhovedet heller ikke, hvis jeg trykker på tasterne F1-F12 ... Ville se om der kunne komme en eller anden login prompt den vej rundt, men desværre intet.

Nu tænker jeg, at det jo måske kunne være KDE Neon, der på en eller anden måde er problemet.
Desværre kan jeg ikke uden videre få en anden distro på USB stick'en, da jeg ikke sidder hjemme ved min egen PC ... Det er kærestens jeg lige har gjort (midlertidigt) ubrugelig.

Så lige nu ved jeg ikke lige helt, hvad jeg evt. kunne prøve ... Nogen forslag?


osjensen
osjensen's picture
Antal: 1332
Tilmeldt:
14-01-2007
User is offline
Kummer du forbi en GRUB

Kommer du forbi en GRUB menu

kan du prøve
https://wiki.ubuntu.com/RecoveryMode

startx
vil sikkert give en brugbar fejl-meling, hvis det er kde der fejler.


Akker
Antal: 277
Tilmeldt:
25-06-2008
User is offline
Kommer du forbi en GRUB

#4: Kommer du forbi en GRUB menu

Næh, det gør jeg ikke, for der er tale om at linux installationen skal være eneste styresystem på PC'en.

Men jeg har så efterfølgende fundet fejlen.
Der har simpelthent, på en eller anden måde, været en fejl i det image der ligger på USB stick'en ... Noget jeg overhovedet ikke forstår, eftersom jeg har brugt det samme image til at installere KDE Neon på min egen PC.
Efterfølgende har jeg så fået hentet og installeret et nyt image på samme USB stick, og nu kunne jeg sagtens installere KDE Neon på PC'en.

Synes nu godt nok den starter noget langsom op, der er trods alt tale om en i5-3320M CPU ... KDE Neon starter ganske hurtigt op på min i7-3630QM CPU ... Betyder forskellen i antal cores og threads virkeligt så meget?

Men problemet er løst nu.
Siger mange tak for hjælpen.


OracleJMT
OracleJMT's picture
Antal: 378
Tilmeldt:
26-05-2013
User is offline
Systemd kan drille mht.

Systemd kan drille mht. opstartsfase og opstartstid. Det er fordi den venter på daemons skal starte (ved boot) og lukke ned (ved shutdown) Det er et flaw i Systemd init, som ikke eksisterede ved hverken Upstart init eller SysVinit før i tiden.

Hvis du trykker ESC, når opstarten/nedlukningen hænger, vil du med sikkerhed opdage, at en eller anden session står og tæller. Det er Systemd, der nokker i det.

At bootfasen er hurtigere på din i7, end på din i5 er højst sandsynligt et tilfælde, da det højst sandsynligt skyldes en buggy Systemd.

Been around in IT & IT security since 07'
Entered the Nix* world in march 2011
Have tried & used most, if not all systems available, except LFS

I'm platform agnostic, I use what works for me
My favorites are:

Linux: Ubuntu, Slackware, OpenSUSE, Debian, Fedora
Unix: FreeBSD, OpenBSD, Illumos/Openindiana, DragonflyBSD, NetBSD, OSX


Akker
Antal: 277
Tilmeldt:
25-06-2008
User is offline
Hvis du trykker ESC,

#6: Hvis du trykker ESC, når opstarten/nedlukningen hænger, vil du med sikkerhed opdage, at en eller anden session står og tæller. Det er Systemd, der nokker i det.

Okay, det må jeg prøve at checke op på med denne PC.
Kan dog genkende det du siger, fra min egen PC, den med i7 CPU.
Her har jeg 3 linux distro's installeret ... Manjaro Cinnamon, Linux Mint Cinnamon og KDE Neon ... KDE Neon blev installeret sidst af de 3, op til et par uger efter de Manjaro og Linux Mint.
Før installation af KDE Neon, så startede de 2 andre lynhurtigt op, men efter KDE Neon blev installeret, så hænger de i opstarten, men dog ikke ved nedlukning.
I Manjaro kan jeg så se, at der står en tæller, der tæller ned fra 1:30 min. ... Mega træls.
I Linux Mint står logoet bare og hænger længe, før der ligesom sker noget yderligere ... også Mega træls.
Men KDE Neon starter ganske hurtigt op ... Hmmmm.

Med det du fortæller, så kunne det jo godt lyde til at Systemd init nokker i det.


frogmaster
frogmaster's picture
Antal: 3785
Tilmeldt:
20-05-2010
User is offline
Før installation af KDE

#7: Før installation af KDE Neon, så startede de 2 andre lynhurtigt op, men efter KDE Neon blev installeret, så hænger de i opstarten, men dog ikke ved nedlukning.
I Manjaro kan jeg så se, at der står en tæller, der tæller ned fra 1:30 min. ... Mega træls.

Jeg har også oplevet fænomenet (at den står og tæller ned fra 1 min + X antal sek) under nedlukning. Det sker når noget ikke er afsluttet korrekt.

Uden præcist at kende årsagerne, for jeg tror der kan være mere end en (systemd kan være involveret), så er det i dit tilfælde tilsyneladende sket efter installation af KDE Neon (rebased on Ubuntu 18.04)?

Er det korrekt, så kunne det muligvis have med bootloaderen i KDE Neon at gøre på din triple boot, eftersom det i din beskrivelse, også påvirker de to andre hardware installerede OS, men tilsyneladende først efter installering af KDE Neon.

Jeg har eksempelvis oplevet denne nedtælling i Kali Linux med Gnome (single boot), der er et derivat af Debian og iøvrigt også i en single boot med Cinnamon Manjaro (Arch).

Muligvis kan ukorrekt afslutning af keyring være årsag eller indblandet ...?

Lidt mere overordnet, så kan det være sin sag at holde rede på et OS. Når maskinen har tre installeret, så bliver det, rundt regnet, tre gange sværere. Det kan nogenlunde undgås ved at droppe dualboot og istedet installere virtuelle OS. Det gør fejlfinding, alt andet lige, lidt mere overskuelig.


frogmaster
frogmaster's picture
Antal: 3785
Tilmeldt:
20-05-2010
User is offline
Men jeg har så

#5: Men jeg har så efterfølgende fundet fejlen.
Der har simpelthent, på en eller anden måde, været en fejl i det image der ligger på USB stick'en ... Noget jeg overhovedet ikke forstår, eftersom jeg har brugt det samme image til at installere KDE Neon på min egen PC.
Efterfølgende har jeg så fået hentet og installeret et nyt image på samme USB stick, og nu kunne jeg sagtens installere KDE Neon på PC'en.

Det kan give mening. Hvis OS har forsøget at skrive på nøglen og skrivebeskyttelsen ikke har forhindret det, eller nøglen har været i for tæt kontakt med magnetisk påvirkning, fx ligget på en højtaler eller sammen med en telefon, så kan det i teorien ændre på nøglens data. Der er formentlig flere mulige forklaringer.


mich
mich's picture
Antal: 958
Tilmeldt:
13-10-2007
User is offline
Det kan give mening.

#9: Det kan give mening. Hvis OS har forsøget at skrive på nøglen og skrivebeskyttelsen ikke har forhindret det, eller nøglen har været i for tæt kontakt med magnetisk påvirkning, fx ligget på en højtaler eller sammen med en telefon, så kan det i teorien ændre på nøglens data. Der er formentlig flere mulige forklaringer.

Den teori tror jeg ikke på. USB sticks er ren SSD, d.v.s. elektronik, der ikke er magnetisk baseret, og de bliver derfor ikke påvirket af magnetfelter.

Jeg tror mere på, at der formenlig er flere mulige forklaringer.

./mich


mich
mich's picture
Antal: 958
Tilmeldt:
13-10-2007
User is offline
Jeg tror mere på, at

#10: Jeg tror mere på, at der formenlig er flere mulige forklaringer.

Som f.eks. at der har været en skrivefejl på det første image. Det sker af og til både ved skrivning til USB og til CD.

./mich


frogmaster
frogmaster's picture
Antal: 3785
Tilmeldt:
20-05-2010
User is offline
Den teori tror jeg ikke

#10: Den teori tror jeg ikke på. USB sticks er ren SSD, d.v.s. elektronik, der ikke er magnetisk baseret, og de bliver derfor ikke påvirket af magnetfelter.

Jeg tror du har ret, for det er korrekt at en stick ikke er magnetisk baseret. Alligevel er jeg ikke sikker på om et tilstrækkeligt stærkt magnetisk felt (elektrostatisk induktion), kan påvirke nøglen, men jeg ved ikke nok om det.

Der er en her (Ryszard), der hævder at han har oplevet det: https://www.physicsforums.com/threads/usb-in-magne...

Som du nævner er det underligt at nøglen har fungeret på en maskine, men ikke på den næste. Det kunne muligvis også skyldes en fejl i maskinens USB driver, eller midlertidig fejl af indlæsning af driveren under post? Hvis den fejl opstår, så virker det måske ved at prøve flere gange.

USB (Universal Serial Bus) er ikke så universel som akronymet hentyder. Der er problemer med version 3, der ikke er kompatible med version 2, såvel som Apples USB to RJ45 Converter ikke fungerer på en PC uden driveren fra Apples Bootcamp.

Der kan også være problemer med, vel især, low cost USB devices.