Opsætning NordVPN

Marle
Antal: 1
Tilmeldt:
06-02-2019
User is offline
Opsætning NordVPN

Hej alle

Jeg kæmper en kamp for at få NordVpn op på min Linux Mint Cinnemon

Får denne fejl:

Du kan muligvis rette det ved at køre »apt-get -f install«:
Følgende pakker har uopfyldte afhængigheder:
libc6-dbg : Afhængigheder: libc6 (= 2.23-0ubuntu4) men 2.23-0ubuntu3 forventes installeret
E: Uopfyldte afhængigheder. Prøv »apt-get -f install« uden pakker (eller angiv en løsning).

Synes jeg har prøvet alt....


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Hej Marle, og

Hej Marle, og velkommen.

Mint-brugerne, er nok på vinter-ferie.
Du må nøjes med en "Mint substitute", ind til videre.

Hvor gammel er den Mint Cinnemon?
Er den opdateret?

Den Mint Xfce 2018, jeg har på "tålt ophold" i en WM, siger
lib6 2.27-3ubuntu1
så din lib6, ser lidt gammel ud.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Hej MarleHar du en gratis

Hej Marle

Har du en gratis eller betalt version af NordVPN?
Taler du om VPN klienten eller forsøger du at opsætte en VPN server?

Installerede du NordVPN / OpenVPN fra terminalen eller fra deres hjemmeside?:
https://support.nordvpn.com/Connectivity/Linux/118...

Hvilken version af Mint bruger du? Jeg tror ikke du har opgraderet din Mint installation, Vær venlig af be- eller afkræfte ...

#0: Følgende pakker har uopfyldte afhængigheder:
libc6-dbg : Afhængigheder: libc6 (= 2.23-0ubuntu4) men 2.23-0ubuntu3 forventes installeret

Det kunne (måske) skyldes at den installerede libc6-dbg er for ny, og/eller at din version af NordVPN eller Mint er for gammel.
#0: Synes jeg har prøvet alt....
Hvad mere præcist har du allerede prøvet?

#1 lib6 2.27-3ubuntu1
Den siger det samme på min.


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
#2 Er det mon NordVPN

#2
Er det mon NordVPN pakken, eller libc6-dbg pakken, der giver fejlmeldingen?

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
#3Det er et godt

#3
Det er et godt spørgsmål. Jeg ved det ikke, for jeg har heller ikke NordVPN installeret, men nordvpn-release_1.0.0_all.deb fra deres hjemmeside, fortæller at alle afhængigheder er opfyldt på Mint 19 Cinnamon.

Edit:
Mit gæt er at #0 har Mint 18 installeret (hvor libc6-2.23-Oubuntu10 gælder) og forsøger at installere NordVPN klienten til Mint 19. Det kommer ikke til at fungere, men #5 's foreslag vil formentlig, forudsat der er tale om opdateret Mint 18.3 og #0 har en installer. hvor afhængighederne er kompatible med libc6-2.23-Oubuntu10

En hurtig test på Mint 18.3 med NordVPN's nyeste version, fortæller at alle afhængigheder er opfyldt. Derfor tror jeg at #0 ikke har opdateret sit system.


OracleJMT
OracleJMT's picture
Antal: 517
Tilmeldt:
26-05-2013
User is offline
Den skal køres som apt

Den skal køres som

sudo apt install ./nordvpn.release>versionsnummer.deb

Derefter

sudo apt install nordvpn
.

Så er den installeret.

Derefter er det nordvpn login >indtast brugernavn, dernæst adgangskode<

Så er det nordvpn connect >indsæt nordvpn server<

Og så er du kørende