Software til at arbejde med D64/PRG filer på Linux?

brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Software til at arbejde med D64/PRG filer på Linux?

Hej alle.
Jeg roder med gamle computere som min hobby, og har efterhånden en god samling/setup af Commodore64 maskiner. Til samlingen har jeg fået et SD2IEC drev (SD kort baseret diskette emulator drev) og jeg har også fået et datasette drev (Kasettebånd drev). Jeg har så fået den galninge-ide, at ville overføre programmer og software fra diskette images, til tape og gemme det ved brug af mine maskiner. Såå... Jeps... Jeg har modtaget 4 tomme ubrugte og fabriksforseglede Maxell 60 minutter kasette bånd, købt for 70 kroner med forsendelse fra Japan.

Da jeg kun benytter Linux, så udbudet er ekstremt lille hvad programmer til at ekstracte PRG filer fra D64 filer angår. Jeg kender programmer "DROID64" som er et Java program. Det virker fint til at fiske PRG ud af D64 med. Herefter gemmer jeg PRG filerne på SD kort og benytter et C64 program til at skrive til datasette. Naturligvis kan det gøres med en del kommando linje tools, men det er ikke lige min kop the.

Jeg tænker om findes der findes andre GUI baserede løsninger end DROID64?


mich
mich's picture
Antal: 971
Tilmeldt:
13-10-2007
User is offline
Commodore 64

En ting vil jeg give dig ret i: Det er galmandsværk at ville køre Commodore 64 programmer på emuleret hardware i 2019, men held og lykke og god fornøjelse, hvis det er din lyst.
Jeg ved ikke, om det er langsommere eller hurtigere end det originale, men Commodores 1541 diskdrev var notorisk meget meget langsomt, selv da det var nyt.
Man skulle virkeligt have god tid og ikke noget at bruge den til, og det er vel ikke blevet bedre de seneste 40 år?

Desværre kan jeg ikke hjælpe direkte med dit spørgsmål, men jeg har en CBM 8050 Dual Diskdrive, der tidligere har været anvendt sammen med en Commodore 64.
https://en.wikipedia.org/wiki/Commodore_8050
Det er et dobbelt drev, og det er væsentligt hurtigere end 1541. Been there, done that.

PM hvis det har din interesse.

./mich


osjensen
osjensen's picture
Antal: 1402
Tilmeldt:
14-01-2007
User is offline
#0 Midnight Commander mc kan

#0
Midnight Commander
mc
kan let åbne dine *.D64 filer, og vise indholdet.

10thFrame(1986)(Access Software)[cr TSC][a2].d64 >
10th frame docs.prg
bootframe.prg
mainframe.prg
tenth frame.prg

c1541, skal også være installeret, feks fra Vice pakken.
$ ls -l /usr/bin/c1541
-rwxr-xr-x 1 bruger bruger 272384 apr 22 05:15 /usr/bin/c1541*

Udpak, kopier / flyt, let og hurtigt.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Tjoo... Dual disk drev

#1:

Tjoo... Dual disk drev er fine, men jeg har valgt fysisk drev fra og benytter SD kort drev på mine gamle C64'ere. Det er sådan noget der hedder SD2IEC, som også kan bruges på C16, C128 og andre maskiner. Loade tiden er den samme, men med et 2gb kort, har jeg mere plads end jeg har brug for. Faktisk så er det ikke drevet som er langsomt, men selve bussen på en C64 der er langsom. Så selv om SD2IEC drevet havde været kompatibel med Class10 kort, og ikke 4, så ville loade tiden stadig være langsom i forhold til moderne hardware. Dog forkommer der jo variationer, så visse drev er stadig lidt hurtigere end andre. Bånd vil jeg dog rigtig gerne fortsætte med at benytte. Det er nostalgi faktoren for mit vedkommende. Selv om jeg har en små 30 disketter liggende, takker jeg pænt nej til drevet. Det er rigtig dejligt at få tilbudet, men jeg har ikke pladsen til det. Da jeg også skal have plads til mine Amigaer og gamle 286/486/Pentium computere. Jeg har kun et enkelt skab og en reol samt et nogenlunde stort skrivebord til min hobby. Faktisk er min hobby ikke at spille retro/vintage spil som man ser det ved ungdommen i dag, men mere selve hardwaren og så lære/genlære fordoms teknikker og måder at gøre tingene på. F.eks. at restaurere gammelt hardware, og få det til at køre igen.

Så mit spørgsmål gik nu mest af alt på at finde programmer som jeg kan hente PRG filer ud af D64 filer med, ved brug af Linux og ikke OsX eller Windows. Selve programmet til at skrive software/programmer/spil til Datasette på en Commodore64 maskine, har jeg allerede fundet. Så dem skal jeg ikke ud og lede efter. Jeg har også fundet en 4-pack med 60 minutter maxell bånd på eBay, som jeg har fået købt. Planen er at lægge så mange spil som muligt i turbo-tape udgave. Der skulle være plads til omkring 15/20 stykker på hver side af et 60 minutters bånd. Men om det bare er rygter eller skrøner fra nettet er jeg ikke helt med på. Det skal da testes af, bare fordi jeg aldrig har prøvet at gøre det før i mit liv, og jeg prøvede trods alt en Commodore64 for første gang tilbage i 1985/86 stykker eller noget i den retning. :-) Der er bare så meget jeg er nysgerrig på, men aldrig prøvet. :-D


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Jeg har forsøgt, da jeg

#2:

Jeg har forsøgt, da jeg tænkte at når nu star commander kan, så kunne MC også. Specielt efter at erkende at der ikke findes en Linux udgave af star commander. Men på min installation af MC, kan jeg ikke åbne nogle D64 filer. Det er nok det eneste tekstmode baserede tool jeg ville bruge, da jeg foretrækker en GUI udgave af tingene hvis der findes et GUI alternativ til konsol eller tekstmode program. Konsollen bruger jeg mest med MC loadet, men også når jeg skal bruge APT eller ind og rette i en tekstfil. Så 95% af tiden er jeg i den GUI'en.

Hvordan får jeg MC til at kunne læse D64 filer? Jeg er faktisk pænt interesseret i at bruge MC.


osjensen
osjensen's picture
Antal: 1402
Tilmeldt:
14-01-2007
User is offline
#4I en terminal which

#4
I en terminal -

which c1541

Er c1541 installeret?

Mangler den, kan du åbne synaptic, søg efter vice pakken og installer den.

VICE is a set of accurate emulators for the Commodore 64, 128, VIC20,
PET and CBM-II 8-bit computers, all of which run under the X Window
System.

Mc burde nu kunne åbne dine *.d64 filer.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Det tror jeg ikke den

#5:

Det tror jeg ikke den er. Er det noget der kan gøres via APT-GET?


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Denne fejl

MC kommer med følgende fejl..... Jeg mener at det er et plugin eller noget, der ikke fungerer som det skal. Men lige hvad det er, ved jeg ikke.

Billede på PostIMG


osjensen
osjensen's picture
Antal: 1402
Tilmeldt:
14-01-2007
User is offline
Når du bruger apt-get, skal

Når du bruger apt-get, skal du vide nøjagtigt hvad pakkerne hedder, ellers finder du ingenting. Og derfor finder du aldrig ud af hvad du ellers, har til rådighed.
OK - Jeg ved at jeg taler for døve ører, i "ubuntu-land". LOL.

Har du prøvet med apt-get install vice?
Når du nu foretrækker GUI, så prøv evt
apt-get install synaptic

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


OracleJMT
OracleJMT's picture
Antal: 515
Tilmeldt:
26-05-2013
User is offline
apt-get bliver ikke brugt

apt-get bliver ikke brugt så meget mere på Debian-baserede distributioner. Idag kan man nøjes med

sudo apt install >pakke<

sudo apt update

sudo apt search >pakke<

sudo apt upgrade

sudo apt dist-upgrade

sudo apt remove >pakke<

sudo apt purge >pakke<


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Næææ....

Du snakker såmænd ikke for døve ører her. Jeg benytter selv en blanding af kommando linje og GUI, når jeg skal slette, opgradere og installere software. Med 95% af alt arbejde, mente jeg bare alt hvad jeg bruger maskinen til. Det er jo ikke sjovt at surfe nettet og tilgå steder som linuxin, igennem konsollen eller kommandolinje om man vil. Selve APT er jeg helt inde i.


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Installerede Vice....

Jeg smed Vice på og nu kan MC godt tilgå en D64 fil. Tak for tippet. Jeg havde godt nok en anden udgave af Vice installeret i forvejen, da den man installerer igennem synaptic (jeps, jeg har 3 forskellige programmer til installation på min maskine) ikke vil fungere ordentligt på Ubuntu Mate.


osjensen
osjensen's picture
Antal: 1402
Tilmeldt:
14-01-2007
User is offline
Godt det lykkedes.Du har

Godt det lykkedes.

God oversigt over værktøjer:
http://www.fairlight.to/tools/unix.html
http://www.fairlight.to/tools/pc.html

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


brostenen
Antal: 29
Tilmeldt:
30-05-2015
User is offline
Så er det løst....Jeg

Så er det løst....
Jeg benyttede det program som hedder "Copy 235" på min C64'er. Filerne hentede jeg ud fra D64 filer eller som rene PRG, ved hjælp af Midnight Commander på Linux, og overførte dem til SD kortet jeg benytter på min SD2IEC. Så lagde jeg ABC-Turbo 2.0 som det første, og gemte spillene som TurboLoader udgave.

Tusinde tak for input og hjælp. Jeg har smidt billede af resultatet op på postimg...

https://i.postimg.cc/8PGpxszW/First-Mix-Tape.jpg


marlar
Antal: 2938
Tilmeldt:
05-12-2009
User is offline
apt-get bliver ikke

#9: apt-get bliver ikke brugt så meget mere på Debian-baserede distributioner.

Jeg foretrækker aptitude. Bl.a. fordi den har en fin tekstbaseret GUI med søgemuligheder mv. Og så er der bedre til at udrede afhængigheder end apt-get.

Men ellers har de fleste distroer jo en en grafisk programhåndtering.


frogmaster
frogmaster's picture
Antal: 4065
Tilmeldt:
20-05-2010
User is offline
Jeg foretrækker

#14: Og så er der bedre til at udrede afhængigheder end apt-get.
Det vil jeg gerne, med forlov, høre et praktisk eksempel på, hvis det er muligt.

Så vidt jeg ved, så er der ikke længere forskel på apt-get og apt på Debian, hvor Ubuntu var foran Debian med at implementere ændringen. Der var tidligere forskel på Debian, men ændret allerede på Ubuntu 16.04

Det jeg ikke ved er om aptitude er bedre til at håndtere afhængigheder end apt, hvor apt-get nu ser ud for mig som være funktionelt merged med apt.

Ændringen til apt er begrundet, hvor der også er nævnt Mint's APT python wrapper:
https://itsfoss.com/apt-vs-apt-get-difference/

Jeg har ikke en Debian installeret, men Kali Linux, som er et Debian derivat. På den oplevede jeg tidligere afhængighedsproblemer med apt-get versus apt, der resulterede i ominstallering, men det gør jeg ikke længere.

Eksempelvis, hvis jeg benytter apt-get dist-upgrade i Kali, så fungerer det tilsyneladende helt efter hensigten. Den tilsvarende apt command er: apt full-upgrade

Som jeg forstår det, så er aptitude anderledes end apt og apt-get, men uden forskel iht til afhængiheder. .