c/c++ program

1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
c/c++ program

Hej

Findes der et program hvor man kan skrive sine cpp-filer og compile med tilhørene fejltekst i linux??

Jeg har lade mig erfare at det er g++ for c++ filer og gcc for c filer som bruges i terminalen, og man danner cpp-filerne i sin editor, men jeg ved ik hvilken editor der er den bedste at bruge ifm programmering.

I sin tid på windows var det borland compilerprogram jeg brugte, ligesom microsoft også lavede et oversætterprogram, senere brugte jeg eclipse, hvor hele moliviten var inde i programmet.

Findes det program overhovedet som jeg efterspørger til linux??

/allan


ejvindh
Antal: 86
Tilmeldt:
17-05-2010
User is offline
Eclipse fungerer fint på

Eclipse fungerer fint på Linux.


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
HVILKET PROGRAM ER BEDST TIL PROGRAMMERING I ÅR2020

Hej ejvindh

Er der andre programmer ala borland eller er eclipse det man/fleste bruger ifm programmering??

/allan


ejvindh
Antal: 86
Tilmeldt:
17-05-2010
User is offline
Hvad man generelt bruger,

Hvad man generelt bruger, ved jeg ikke. Jeg har lært at holde af Eclipse, fordi den kan bruges til mange forskellige programmeringssprog.

Eclipse havde nok sin storhedstid i forbindelse med, at den var den primære indgangsvej til Android-programmering, og efter at Google forlod den strategi, er det mit indtryk, at Eclipse er lidt i aftagen.


julemand101
julemand101's picture
Antal: 1701
Tilmeldt:
17-01-2004
User is offline
Bruger generelt IntelliJ da

Bruger generelt IntelliJ da det også er værktøjet vi bruger på arbejdet og det kører skam ganske udmærket på Linux hvor jeg bruger community udgaven. Jeg bruger det så til udvikling af Java og Dart programmer men jeg kan se det også er muligt at programmere C og C++ programmer i det.

Før brugte jeg Eclipse som også virkede ganske fint og som også blev brugt på arbejdet før i tiden.


marlar
Antal: 3112
Tilmeldt:
05-12-2009
User is offline
Er der andre programmer

#2: Er der andre programmer ala borland eller er eclipse det man/fleste bruger ifm programmering??

Prøv Lazarus. Det minder meget om Borlands Delphi.


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
Hej igen Jeg har prøvet at

Hej igen

Jeg har prøvet at installere deb-filen, men min distro "xubuntu18.04" er angrebet af "snap" og det er derfor jeg installere deb-filer. Filen "lazarus-project_2.0.6-0_amd64.deb" gav fejlene som står i note 1 og jeg vil gerne undgå en reinstallation pga manglene overblik over hvad jeg har installeret siden nov2018 i min distro.

Jeg fik igår set/læst en hjemmeside LINKet til siden der skriver om 10 programmer:
1: Atom – Linux code editor
2: Brackets – Linux HTML Editor
3: Sublime Text 3 – An Amazing Text Editor
4: Vim (Free – GNU Compatible) Code Editor
5: Gedit – Integrated Development Environment
6: Bluefish – Linux HTML Editor
7: CodeLite – Linux Code Editor
8: Eclipse – IDE
9: Code::Blocks – Code Editor
10: Geany – Linux Text Editor

Jeg fandt også en anden side LINKet til siden der giver 5 programmer:
1: Atom
2: Vim
3: VS Code (Visual Studio Code)
4: Notepad++
5: Sublime Text

Og hvad skal jeg så bruge editoren/oversætteren til er det næste spørgsmål, og det er for at lære at skrive kode (stadigvæk i et program) samt makroer i basic i libreoffice.

Jeg har erfareret at verden ser meget anderledes ud idag end for 10-15års tid siden mht compilere/oversættere og så alligevel ik for man skal kende til programmerne.

/allan

note 1)

allan@linux:~/Downloads$ sudo dpkg -i lazarus-project_2.0.6-0_amd64.deb
Selecting previously unselected package lazarus-project.
(Reading database ... 347152 files and directories currently installed.)
Preparing to unpack lazarus-project_2.0.6-0_amd64.deb ...
Unpacking lazarus-project (2.0.6) ...
dpkg: dependency problems prevent configuration of lazarus-project:
lazarus-project depends on libgtk2.0-dev (>= 2.6.0); however:
  Package libgtk2.0-dev is not installed.
lazarus-project depends on fpc-laz (= 3.0.4); however:
  Package fpc-laz is not installed.
lazarus-project depends on fpc-src (= 3.0.4); however:
  Package fpc-src is not installed.

dpkg: error processing package lazarus-project (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Errors were encountered while processing:
lazarus-project


phoenix
Antal: 34
Tilmeldt:
23-03-2004
User is offline
IDE'er til C/C++

Jeg bruger typisk Vi(m) og kommandolinien, men har tidligere brugt Qt Creator og det er et ret komplet udviklingsmiljø. Qt Creator er et kommercielt produkt men der findes stadig en fri udgave (på samme vis som fx IntelliJ). Qt er cross platform og findes til Linux, MacOS og Windows.

Hvis man er til KDE ser KDevelop ret fornuftigt ud


marlar
Antal: 3112
Tilmeldt:
05-12-2009
User is offline
Filen

#6: Filen "lazarus-project_2.0.6-0_amd64.deb" gav fejlene som står i note 1

Har du prøvet at installere med din pakkemanager (apt-get)?

#6: 3: VS Code (Visual Studio Code)

Det er en fremragende editor/IDE som jeg er blevet meget glad for. Virkelig god!


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
svar på #8 med ref til #6

Hej Marlar

Er VS Code ik microsoft (propritært)?? og deb-filen er commandoen "sudo dpkg -i *.deb" altså ik apt-get, men mener du installing via synaptic eller software storen??

./allan


julemand101
julemand101's picture
Antal: 1701
Tilmeldt:
17-01-2004
User is offline
Er VS Code ik microsoft

Er VS Code ik microsoft (propritært)??

Det er Open Source med en MIT licens:
https://github.com/microsoft/vscode

Ikke at jeg har brugt det men det lader til ret mange er glade for det.


marlar
Antal: 3112
Tilmeldt:
05-12-2009
User is offline
men mener du installing

#9: men mener du installing via synaptic eller software storen??

Ja, via "software storen" (repositoriet),

#10: Ikke at jeg har brugt det men det lader til ret mange er glade for det.

Den er fremragende. For et par år siden installerede jeg Atom idet jeg havde brug for at arbejde med TypeScript. Den er også fin, men da jeg først prøvede VS Code var der ingen vej tilbage. Den er så meget bedre. Det ses også på populariteten på Stackoverflow, VSC har langt overhalet Atom.


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
svar på indlæg#11 med ref til #8 og #6

Hej marlar

For at starte med første punkt (se note 1) har jeg tidligere prøvet apt-get og erfaret at deb-filen giver bedre resultater generelt pga en fejl som jeg ik kan verificere (frogmaster har også prøvet i efteråret i år2019) og jeg mangler overblik over mine programmer installeret her på min xubuntu18.04.

Jeg må indrømme at software storen her i ubuntu har jeg glemt hvordan tilgåes pga at jeg har mere haft interesse i terminalen samt installation (primært gennem den) den vej rundt.
Nå jeg taler om undtagelser er det deb-filerne samt filer via wine.

./allan

note 1)

allan@linux:~$ sudo apt-get install lazarus
[sudo] password for allan:
Reading package lists... Done
Bulding dependency tree
Reading state infomation... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies.
lazarus : Depends: lazarus-1.8 but it is not going to be installed
youtube-dlg : Depends: python-wxgtk3.0 but it is not going to be installed
               Depends: python-twodict (>= 1.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

marlar
Antal: 3112
Tilmeldt:
05-12-2009
User is offline
Har du prøvet det som

Har du prøvet det som foreslås?

sudo apt --fix-broken install


frogmaster
frogmaster's picture
Antal: 4575
Tilmeldt:
20-05-2010
User is offline
jeg mangler overblik

#12: jeg mangler overblik over mine programmer installeret her på min xubuntu18.04.
Jeg er nødt til at bede om svar på hvad dit behov er.

Eksempelvis, er det et fungerende Linux LTS OS, for brugere i almindelighed, eller en udviklings platform for avancerede brugere?

Hvad er egentligt dit behov? ... Hvad forventer du, helt overordent, at en eller anden Linux, tiltænkt avancerede, fx Debian, MX Linux e.g., kan gøre for dig, som en LTS ikke kan?

Installerede programmer i 18.04 LTS er dækket ind fra distroens Programhåndtering, inklusiv Synaptis programmet.

Det er samtlige programmer, bortset fra visse manuelt installerede. Behøver du hjælp til dem? I så fald er det nødvendigt du explicit beskiver hvilke programmer det handler om.

Du har aldrig besvaret spørgsmålet og det er ikke tilfredstillende.


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
svar på indlæg#13 med ref til #11, #8 og #6

Hold da op og mange tak martin (se evt note 1)!!

DET HJALP IFM DEN ORANGE MARKERING NEDE VED URET I HØJRE HJØRNE AF SKRIVEBORDET!!

Jeg prøvede at køre kommandoen "sudo apt update && sudo apt upgrade" i terminalen (note 2), men jeg vil lige vente med compilerprogrammet lidt endnu da jeg godt lige se nærmere på note 1 og 2.

MEN TAK ENDNU EN GANG MARTIN ;o))

./allan

note 1)

allan@linux:~$ sudo apt --fix-broken install
[sudo] password for allan:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  autoconf automake autopoint autotools-dev debhelper dh-autoreconf
  dh-strip-nondeterminism libarchive-cpio-perl libcairo-gobject2 libcairo2
  libcairo2:i386 libexpat1 libexpat1:i386 libfile-stripnondeterminism-perl
  libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libltdl-dev
  libmail-sendmail-perl libpng16-16 libpng16-16:i386 libpython3-stdlib
  libpython3.6 libpython3.6-minimal libpython3.6-stdlib libssl1.1
  libssl1.1:i386 libsys-hostname-long-perl libtool libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 libx11-6 libx11-6:i386 libxcb-render0
  libxcb-render0:i386 libxcb-shm0 libxcb-shm0:i386 libxcb1 libxcb1:i386 m4
  po-debconf python-twodict python-wxgtk3.0 python-wxversion python3
  python3-minimal python3.6 python3.6-minimal
Suggested packages:
  autoconf-archive gnu-standards autoconf-doc dh-make dwz libtool-doc gfortran
  | fortran95-compiler gcj-jdk m4-doc libmail-box-perl wx3.0-doc python3-doc
  python3-tk python3-venv python3.6-venv python3.6-doc
The following packages will be REMOVED
  lazarus-project
The following NEW packages will be installed
  autoconf automake autopoint autotools-dev debhelper dh-autoreconf
  dh-strip-nondeterminism libarchive-cpio-perl
  libfile-stripnondeterminism-perl libltdl-dev libmail-sendmail-perl
  libsys-hostname-long-perl libtool libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5 m4
  po-debconf python-twodict python-wxgtk3.0 python-wxversion
The following packages will be upgraded:
  libcairo-gobject2 libcairo2 libcairo2:i386 libexpat1 libexpat1:i386
  libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libpng16-16 libpng16-16:i386
  libpython3-stdlib libpython3.6 libpython3.6-minimal libpython3.6-stdlib
  libssl1.1 libssl1.1:i386 libx11-6 libx11-6:i386 libxcb-render0
  libxcb-render0:i386 libxcb-shm0 libxcb-shm0:i386 libxcb1 libxcb1:i386
  python3 python3-minimal python3.6 python3.6-minimal
28 to upgrade, 20 to newly install, 1 to remove and 651 not to upgrade.
2 not fully installed or removed.
Need to get 0 B/26,9 MB of archives.
After this operation, 601 MB disk space will be freed.
Do you want to continue? [Y/n] y
Extract templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 363672 files and directories currently installed.)
Removing lazarus-project (2.0.6) ...
Selecting previously unselected package python-wxversion.
(Reading database ... 347154 files and directories currently installed.)
Preparing to unpack .../00-python-wxversion_3.0.2.0+dfsg-7_all.deb ...
Unpacking python-wxversion (3.0.2.0+dfsg-7) ...
Preparing to unpack .../01-libexpat1_2.2.5-3ubuntu0.2_amd64.deb ...
De-configuring libexpat1:i386 (2.2.5-3) ...
Unpacking libexpat1:amd64 (2.2.5-3ubuntu0.2) over (2.2.5-3) ...
Preparing to unpack .../02-libexpat1_2.2.5-3ubuntu0.2_i386.deb ...
Unpacking libexpat1:i386 (2.2.5-3ubuntu0.2) over (2.2.5-3) ...
Selecting previously unselected package libwxbase3.0-0v5:amd64.
Preparing to unpack .../03-libwxbase3.0-0v5_3.0.4+dfsg-3_amd64.deb ...
Unpacking libwxbase3.0-0v5:amd64 (3.0.4+dfsg-3) ...
Preparing to unpack .../04-libpng16-16_1.6.34-1ubuntu0.18.04.2_i386.deb ...
De-configuring libpng16-16:amd64 (1.6.34-1ubuntu0.18.04.1) ...
Unpacking libpng16-16:i386 (1.6.34-1ubuntu0.18.04.2) over (1.6.34-1ubuntu0.18.04.1) ...
Preparing to unpack .../05-libpng16-16_1.6.34-1ubuntu0.18.04.2_amd64.deb ...
Unpacking libpng16-16:amd64 (1.6.34-1ubuntu0.18.04.2) over (1.6.34-1ubuntu0.18.04.1) ...
Preparing to unpack .../06-libxcb1_1.13-2~ubuntu18.04_amd64.deb ...
De-configuring libxcb1:i386 (1.13-1) ...
Unpacking libxcb1:amd64 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../07-libxcb1_1.13-2~ubuntu18.04_i386.deb ...
Unpacking libxcb1:i386 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../08-libx11-6_2%3a1.6.4-3ubuntu0.2_i386.deb ...
De-configuring libx11-6:amd64 (2:1.6.4-3ubuntu0.1) ...
Unpacking libx11-6:i386 (2:1.6.4-3ubuntu0.2) over (2:1.6.4-3ubuntu0.1) ...
Preparing to unpack .../09-libx11-6_2%3a1.6.4-3ubuntu0.2_amd64.deb ...
Unpacking libx11-6:amd64 (2:1.6.4-3ubuntu0.2) over (2:1.6.4-3ubuntu0.1) ...
Preparing to unpack .../10-libxcb-render0_1.13-2~ubuntu18.04_i386.deb ...
De-configuring libxcb-render0:amd64 (1.13-1) ...
Unpacking libxcb-render0:i386 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../11-libxcb-render0_1.13-2~ubuntu18.04_amd64.deb ...
Unpacking libxcb-render0:amd64 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../12-libxcb-shm0_1.13-2~ubuntu18.04_i386.deb ...
De-configuring libxcb-shm0:amd64 (1.13-1) ...
Unpacking libxcb-shm0:i386 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../13-libxcb-shm0_1.13-2~ubuntu18.04_amd64.deb ...
Unpacking libxcb-shm0:amd64 (1.13-2~ubuntu18.04) over (1.13-1) ...
Preparing to unpack .../14-libcairo2_1.15.10-2ubuntu0.1_amd64.deb ...
De-configuring libcairo2:i386 (1.15.10-2) ...
Unpacking libcairo2:amd64 (1.15.10-2ubuntu0.1) over (1.15.10-2) ...
Preparing to unpack .../15-libcairo2_1.15.10-2ubuntu0.1_i386.deb ...
Unpacking libcairo2:i386 (1.15.10-2ubuntu0.1) over (1.15.10-2) ...
Preparing to unpack .../16-libglib2.0-bin_2.56.4-0ubuntu0.18.04.4_amd64.deb ...
Unpacking libglib2.0-bin (2.56.4-0ubuntu0.18.04.4) over (2.56.3-0ubuntu0.18.04.1) ...
Preparing to unpack .../17-libglib2.0-0_2.56.4-0ubuntu0.18.04.4_amd64.deb ...
De-configuring libglib2.0-0:i386 (2.56.3-0ubuntu0.18.04.1) ...
Unpacking libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) over (2.56.3-0ubuntu0.18.04.1) ...
Preparing to unpack .../18-libglib2.0-0_2.56.4-0ubuntu0.18.04.4_i386.deb ...
Unpacking libglib2.0-0:i386 (2.56.4-0ubuntu0.18.04.4) over (2.56.3-0ubuntu0.18.04.1) ...
Selecting previously unselected package libwxgtk3.0-gtk3-0v5:amd64.
Preparing to unpack .../19-libwxgtk3.0-gtk3-0v5_3.0.4+dfsg-3_amd64.deb ...
Unpacking libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-3) ...
Selecting previously unselected package python-wxgtk3.0.
Preparing to unpack .../20-python-wxgtk3.0_3.0.2.0+dfsg-7_amd64.deb ...
Unpacking python-wxgtk3.0 (3.0.2.0+dfsg-7) ...
Selecting previously unselected package python-twodict.
Preparing to unpack .../21-python-twodict_1.2-1_all.deb ...
Unpacking python-twodict (1.2-1) ...
Preparing to unpack .../22-libssl1.1_1.1.1-1ubuntu2.1~18.04.5_amd64.deb ...
De-configuring libssl1.1:i386 (1.1.0g-2ubuntu4.3) ...
Unpacking libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.5) over (1.1.0g-2ubuntu4.3) ...
Preparing to unpack .../23-libssl1.1_1.1.1-1ubuntu2.1~18.04.5_i386.deb ...
Unpacking libssl1.1:i386 (1.1.1-1ubuntu2.1~18.04.5) over (1.1.0g-2ubuntu4.3) ...
Preparing to unpack .../24-python3.6_3.6.9-1~18.04_amd64.deb ...
Unpacking python3.6 (3.6.9-1~18.04) over (3.6.6-1~18.04) ...
Preparing to unpack .../25-libpython3.6_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6:amd64 (3.6.9-1~18.04) over (3.6.6-1~18.04) ...
Preparing to unpack .../26-libpython3.6-stdlib_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6-stdlib:amd64 (3.6.9-1~18.04) over (3.6.6-1~18.04) ...
Preparing to unpack .../27-python3.6-minimal_3.6.9-1~18.04_amd64.deb ...
Unpacking python3.6-minimal (3.6.9-1~18.04) over (3.6.6-1~18.04) ...
Preparing to unpack .../28-libpython3.6-minimal_3.6.9-1~18.04_amd64.deb ...
Unpacking libpython3.6-minimal:amd64 (3.6.9-1~18.04) over (3.6.6-1~18.04) ...
Setting up libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.5) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Setting up libssl1.1:i386 (1.1.1-1ubuntu2.1~18.04.5) ...
Checking for services that may need to be restarted...done.
Checking for services that may need to be restarted...done.
Setting up libpython3.6-minimal:amd64 (3.6.9-1~18.04) ...
Setting up libexpat1:amd64 (2.2.5-3ubuntu0.2) ...
Setting up libexpat1:i386 (2.2.5-3ubuntu0.2) ...
Setting up python3.6-minimal (3.6.9-1~18.04) ...
(Reading database ... 347701 files and directories currently installed.)
Preparing to unpack .../python3-minimal_3.6.7-1~18.04_amd64.deb ...
Unpacking python3-minimal (3.6.7-1~18.04) over (3.6.5-3ubuntu1) ...
Setting up python3-minimal (3.6.7-1~18.04) ...
(Reading database ... 347701 files and directories currently installed.)
Preparing to unpack .../00-python3_3.6.7-1~18.04_amd64.deb ...
running python pre-rtupdate hooks for python3.6...
Unpacking python3 (3.6.7-1~18.04) over (3.6.5-3ubuntu1) ...
Preparing to unpack .../01-libpython3-stdlib_3.6.7-1~18.04_amd64.deb ...
Unpacking libpython3-stdlib:amd64 (3.6.7-1~18.04) over (3.6.5-3ubuntu1) ...
Selecting previously unselected package m4.
Preparing to unpack .../02-m4_1.4.18-1_amd64.deb ...
Unpacking m4 (1.4.18-1) ...
Selecting previously unselected package autoconf.
Preparing to unpack .../03-autoconf_2.69-11_all.deb ...
Unpacking autoconf (2.69-11) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../04-autotools-dev_20180224.1_all.deb ...
Unpacking autotools-dev (20180224.1) ...
Selecting previously unselected package automake.
Preparing to unpack .../05-automake_1%3a1.15.1-3ubuntu2_all.deb ...
Unpacking automake (1:1.15.1-3ubuntu2) ...
Selecting previously unselected package autopoint.
Preparing to unpack .../06-autopoint_0.19.8.1-6ubuntu0.3_all.deb ...
Unpacking autopoint (0.19.8.1-6ubuntu0.3) ...
Selecting previously unselected package libtool.
Preparing to unpack .../07-libtool_2.4.6-2_all.deb ...
Unpacking libtool (2.4.6-2) ...
Selecting previously unselected package dh-autoreconf.
Preparing to unpack .../08-dh-autoreconf_17_all.deb ...
Unpacking dh-autoreconf (17) ...
Selecting previously unselected package libfile-stripnondeterminism-perl.
Preparing to unpack .../09-libfile-stripnondeterminism-perl_0.040-1.1~build1_all.deb ...
Unpacking libfile-stripnondeterminism-perl (0.040-1.1~build1) ...
Selecting previously unselected package dh-strip-nondeterminism.
Preparing to unpack .../10-dh-strip-nondeterminism_0.040-1.1~build1_all.deb ...
Unpacking dh-strip-nondeterminism (0.040-1.1~build1) ...
Selecting previously unselected package po-debconf.
Preparing to unpack .../11-po-debconf_1.0.20_all.deb ...
Unpacking po-debconf (1.0.20) ...
Selecting previously unselected package debhelper.
Preparing to unpack .../12-debhelper_11.1.6ubuntu2_all.deb ...
Unpacking debhelper (11.1.6ubuntu2) ...
Selecting previously unselected package libarchive-cpio-perl.
Preparing to unpack .../13-libarchive-cpio-perl_0.10-1_all.deb ...
Unpacking libarchive-cpio-perl (0.10-1) ...
Preparing to unpack .../14-libcairo-gobject2_1.15.10-2ubuntu0.1_amd64.deb ...
Unpacking libcairo-gobject2:amd64 (1.15.10-2ubuntu0.1) over (1.15.10-2) ...
Selecting previously unselected package libltdl-dev:amd64.
Preparing to unpack .../15-libltdl-dev_2.4.6-2_amd64.deb ...
Unpacking libltdl-dev:amd64 (2.4.6-2) ...
Selecting previously unselected package libsys-hostname-long-perl.
Preparing to unpack .../16-libsys-hostname-long-perl_1.5-1_all.deb ...
Unpacking libsys-hostname-long-perl (1.5-1) ...
Selecting previously unselected package libmail-sendmail-perl.
Preparing to unpack .../17-libmail-sendmail-perl_0.80-1_all.deb ...
Unpacking libmail-sendmail-perl (0.80-1) ...
Setting up libpython3.6-stdlib:amd64 (3.6.9-1~18.04) ...
Setting up python3.6 (3.6.9-1~18.04) ...
Setting up libltdl-dev:amd64 (2.4.6-2) ...
Setting up po-debconf (1.0.20) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up libpng16-16:amd64 (1.6.34-1ubuntu0.18.04.2) ...
Setting up libpng16-16:i386 (1.6.34-1ubuntu0.18.04.2) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up python-wxversion (3.0.2.0+dfsg-7) ...
Setting up libglib2.0-0:i386 (2.56.4-0ubuntu0.18.04.4) ...
Setting up libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) ...
Setting up libarchive-cpio-perl (0.10-1) ...
Setting up m4 (1.4.18-1) ...
Setting up libwxbase3.0-0v5:amd64 (3.0.4+dfsg-3) ...
Setting up libsys-hostname-long-perl (1.5-1) ...
Setting up python-twodict (1.2-1) ...
Setting up libmail-sendmail-perl (0.80-1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up autotools-dev (20180224.1) ...
Processing triggers for doc-base (0.10.8) ...
Processing 1 changed doc-base file, 2 added doc-base files...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for shared-mime-info (1.9-2) ...
Setting up libglib2.0-bin (2.56.4-0ubuntu0.18.04.4) ...
Setting up libxcb1:amd64 (1.13-2~ubuntu18.04) ...
Setting up libxcb1:i386 (1.13-2~ubuntu18.04) ...
Setting up autopoint (0.19.8.1-6ubuntu0.3) ...
Setting up libpython3.6:amd64 (3.6.9-1~18.04) ...
Setting up libfile-stripnondeterminism-perl (0.040-1.1~build1) ...
Setting up libtool (2.4.6-2) ...
Setting up libpython3-stdlib:amd64 (3.6.7-1~18.04) ...
Setting up libxcb-render0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libxcb-render0:i386 (1.13-2~ubuntu18.04) ...
Setting up python3 (3.6.7-1~18.04) ...
running python rtupdate hooks for python3.6...
running python post-rtupdate hooks for python3.6...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Setting up libx11-6:amd64 (2:1.6.4-3ubuntu0.2) ...
Setting up libx11-6:i386 (2:1.6.4-3ubuntu0.2) ...
Setting up autoconf (2.69-11) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up automake (1:1.15.1-3ubuntu2) ...
update-alternatives: using /usr/bin/automake-1.15 to provide /usr/bin/automake (automake) in auto mode
Setting up libxcb-shm0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libxcb-shm0:i386 (1.13-2~ubuntu18.04) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Setting up libcairo2:amd64 (1.15.10-2ubuntu0.1) ...
Setting up libcairo2:i386 (1.15.10-2ubuntu0.1) ...
Setting up libcairo-gobject2:amd64 (1.15.10-2ubuntu0.1) ...
Setting up libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-3) ...
Setting up python-wxgtk3.0 (3.0.2.0+dfsg-7) ...
update-alternatives: using /usr/lib/wx/python/wx3.0.pth to provide /usr/lib/wx/python/wx.pth (wx.pth) in auto mode
Setting up youtube-dlg (0.4-1~webupd8~bionic9) ...
Setting up dh-autoreconf (17) ...
Setting up debhelper (11.1.6ubuntu2) ...
Setting up dh-strip-nondeterminism (0.040-1.1~build1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
allan@linux:~$

note 2)

allan@linux:~$ sudo apt update && sudo apt upgrade
[sudo] password for allan:
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]     
Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]   
Get:5 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [846 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [638 kB]
Hit:8 http://ppa.launchpad.net/alexx2000/doublecmd/ubunt... bionic InRelease    
Hit:9 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu bionic InRelease     
Get:10 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [296 kB]
Get:3 https://ftp.fau.de/ctan/systems/win32/miktex/setup... bionic InRelease [2.034 B]
Hit:11 http://ppa.launchpad.net/bluetooth/bluez/ubuntu bionic InRelease       
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [294 kB]
Ign:13 http://ppa.launchpad.net/cpug-devs/ppa/ubuntu bionic InRelease         
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73,8 kB]
Hit:15 http://ppa.launchpad.net/dhor/myway/ubuntu bionic InRelease            
Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [140 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [29,6 kB]
Err:3 https://ftp.fau.de/ctan/systems/win32/miktex/setup... bionic InRelease 
  The following signatures were invalid: EXPKEYSIG 277A7293F59E4889 MiKTeX Packager <packager@miktex.org>
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [7.824 B]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [1.006 kB]
Hit:20 http://ppa.launchpad.net/nilarimogard/webupd8/ubun... bionic InRelease  
Get:21 https://brave-browser-apt-release.s3.brave.com bionic InRelease [3.170 B]
Hit:23 http://ppa.launchpad.net/rolfbensch/sane-git/ubunt... bionic InRelease   
Hit:24 http://ppa.launchpad.net/rolfbensch/sane-release/u... bionic InRelease
Hit:25 http://ppa.launchpad.net/ubuntuhandbook1/shutter/u... bionic InRelease
Get:26 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1.047 kB]
Err:27 http://ppa.launchpad.net/cpug-devs/ppa/ubuntu bionic Release           
  404  Not Found [IP: 91.189.95.83 80]
Get:22 http://ppa.launchpad.net/otto-kesselgulasch/gimp/u... bionic InRelease [15,4 kB]
Hit:28 http://download.virtualbox.org/virtualbox/debian bionic InRelease      
Err:21 https://brave-browser-apt-release.s3.brave.com bionic InRelease        
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8580BDC82D3DC6C
Get:29 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [323 kB]
Get:30 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [264 kB]
Get:31 http://archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [200 kB]
Get:32 http://archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [451 kB]
Get:33 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2.464 B]
Get:34 http://archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [4.024 B]
Get:35 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [4.028 B]
Get:36 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7.960 B]
E: Repository 'http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic InRelease' changed its 'Label' value from 'gimp' to 'gimp stable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y
Get:37 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages [622 kB]
Get:38 http://archive.ubuntu.com/ubuntu bionic-security/main i386 Packages [427 kB]
Get:39 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,5 kB]
Get:40 http://archive.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Get:41 http://archive.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Get:42 http://archive.ubuntu.com/ubuntu bionic-security/universe i386 Packages [609 kB]
Get:43 http://archive.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [636 kB]
Get:44 http://archive.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42,1 kB]
Get:45 http://archive.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Get:46 http://archive.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [111 kB]
Get:47 http://ppa.launchpad.net/otto-kesselgulasch/gimp/u... bionic/main amd64 Packages [10,2 kB]
Get:48 http://archive.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.460 B]
Get:49 http://ppa.launchpad.net/otto-kesselgulasch/gimp/u... bionic/main i386 Packages [10,2 kB]
Get:50 http://ppa.launchpad.net/otto-kesselgulasch/gimp/u... bionic/main Translation-en [5.944 B]
Reading package lists... Done                                                 
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://ftp.fau.de/ctan/systems/win32/miktex/setup... bionic InRelease: The following signatures were invalid: EXPKEYSIG 277A7293F59E4889 MiKTeX Packager <packager@miktex.org>
E: The repository 'http://ppa.launchpad.net/cpug-devs/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://brave-browser-apt-release.s3.brave.com bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8580BDC82D3DC6C
N: Skipping acquire of configured file 'contrib/binary-i386/Packages' as repository 'http://download.virtualbox.org/virtualbox/debian bionic InRelease' doesn't support architecture 'i386'
allan@linux:~$

frogmaster
frogmaster's picture
Antal: 4575
Tilmeldt:
20-05-2010
User is offline
sudo apt --fix-broken

sudo apt --fix-broken install

Udmærket. 1bot læs grundigt og forsøg, før du farer i blækhuset. Det kan være temmeligt irriterende, du ikke nærlæser en kommentar, du ovenikøbet selv har indsat ...


marlar
Antal: 3112
Tilmeldt:
05-12-2009
User is offline
note 2) Fejlene i note

#15: note 2)

Fejlene i note 2 betyder at du bruger nogle personlige repositorier (PPA) som ikke virker længere.


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
Fejlene i note 2

#17: Fejlene i note 2 betyder at du bruger nogle personlige repositorier (PPA) som ikke virker længere.
Okay, så er vel ik megetandet at gøre end at få overblik over programmerne og se at få reinstalleret til en ny distro, men tak alligevel for at du gad se note 2 igennem for det sagde mig ik særlig meget da jeg selv så den igennem.
./allan


1bot.dk
Antal: 330
Tilmeldt:
16-12-2017
User is offline
lidt lnux-reflektion på mit første år siden nov2018

Hej igen

Jeg kom til at tænke på at jeg har også virkelig prøvet denne distro af, nok pga at det var den først og at jeg ville se hvad jeg kunne med linux, og jeg har fundet mange hjemmesider som jeg har fulgt mht ppa (nok for mange og derved det manglende overblik!!). Jeg er ihvertefald fået nok af ppa's og snap, som nok udmyndter sig i at jeg enten bruger apt (apt-get) eller henter deb-filen iformaf "dpkg -i *.deb".

DET HAR NOK VÆRET EN PRØVEBALLON, MEN OGSÅ EN LÆRERIG PROCES OG TAKKETVÆRE FORUMMET HERINDE HAR JEG LÆRT EN MASSE NYT - TAK FOR DET !!!

./allan