(Løst) Problem med Nemo

copycat
Antal: 210
Tilmeldt:
25-09-2007
User is offline
(Løst) Problem med Nemo

Jeg kører Mint 19.3 med Cinnamon 4.4.8 og Nemo 4.4.2.

Problemet er at Nemo ”sander til”, når jeg åbner flere mapper efter hinanden, specielt hvis mapperne indeholder jpg filer. Helt galt går det, hvis jeg åbner billeder med et eller andet program.
Jeg har fulgt med på systemovervågning, og problemet ER Nemo, det er der cpu belastningen stiger.
Det, der sker, er at en af cpu-kernerne stikker af og rammer loftet, først oppe at røre, og hvis man fortsætter, så i længere og længere tid.
Google viser, at det er et generelt problem, der har persisteret i adskillige år. Løsningen er meget enkel: luk Nemo og start den igen, men det er irriterende, hvis man lige har fundet den fil man leder efter, og så er det jo symptombehandling, ikke løsning af problemet.
Er der nogen her på Linuxin, der har/har haft samme problem, og eventuelt har en løsning?


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
#0 Problemet er at Nemo

#0 Problemet er at Nemo ”sander til”, når jeg åbner flere mapper efter hinanden, specielt hvis mapperne indeholder jpg filer. Helt galt går det, hvis jeg åbner billeder med et eller andet program

Jeg har ikke haft problemet og heller ingen færdig løsning.

Det kunne muligvis, efter din beskrivelse, handle om grafikkortet. Kan du sætte mere info ind om din hardware og driver, RAM med mere.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Selvom det ikke er den

Selvom det ikke er den eksakte filoperation, som Copycat laver med Nemo, så har jeg en kraftig mistanke om, at problemet kan være beslægtet med denne bug:

Link

Det kan løses ved, at tilføje de pågældende linjer i /etc/sysctl.conf:

vm.dirty_background_ratio = 5
vm.dirty_ratio = 10

Og efter filen er gemt,

sudo sysctl -p

Hvis dette ikke løser problemet, kan disse linjer nemt fjernes i /etc/sysctl.conf, men det er værd, at forsøge og se, om det løser overtegnedes problem.


copycat
copycat's picture
Antal: 210
Tilmeldt:
25-09-2007
User is offline
#1 Jeg kører med GeForce 1660

Jeg kører med GeForce 1660 Super og Nvidia driver 435.21.

Problemet er der både på min Pc og min laptop, og var der på min gamle Pc, hvad enten jeg bruger GeForce eller Intel. Problemet opstår ikke ved Mint med Xfce, altså Thunar file manager.
Ok, så kan jeg jo bare skifte til Xfce, men jeg kan nu mægtig godt kan lide Cinnamon.

8 GB RAM, hvor forbruget generelt er 30-40%, så der skulle være luft nok (eller?).

Der er en bug i 435 driveren, den får hele systemet til at fryse en gang imellem, og er løst i 440 driveren, som desværre ikke er med Mint.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Jamen så er sagen jo klar.

Jamen så er sagen jo klar.

Din CPU kompenserer for hvad din GPU ikke foretager sig. Så bliver det for meget, og så fryser det.

*EDIT:

Jeg fejllæste forrige kommentar, som 30% 40% CPU forbrug, når trådens forfatter mente ram. Der beklages for fejlen.


copycat
copycat's picture
Antal: 210
Tilmeldt:
25-09-2007
User is offline
#2 Det er sandsynligvis den bug

Det er sandsynligvis den bug, der er skyld i misseren.

Jeg er lidt blank, så vil du være rar at guide mig lidt?

/etc/sysctl.conf er skrivebeskyttet, hvordan åbner jeg den som Root?

Skal de to linjer i /etc/sysctl.conf bare indsættes til sidst, altså efter alt det, der står der i forvejen?

Med enkelt eller dobbelt linjeskift før linjerne indsættes?


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
sudo nano

sudo nano /etc/sysctl.conf

Indsæt linjerne nederst i filen.

Gerne med dobbelt linjeskift. De skal været adskillet.

ctrl +x, skriv "j" eller "y" for at gemme, tryk enter.

Bagefter, genstart.


copycat
copycat's picture
Antal: 210
Tilmeldt:
25-09-2007
User is offline
Tak for hjælpen

Tak for hjælp. Det tæmmede problemet en hel del, jeg har som test lige lukket 100 billedmapper op i træk, uden problemer sic! Max 40% Cpu og 22% Ram.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Jeg tænkte det nok. Det er

Jeg tænkte det nok. Det er ærlig talt lidt utroligt, at den bug stadig eksisterer og at man er nødt til, at gå ind i maskinrummet og justere. Jeg tror den bug har eksisteret siden 2014.

Men jeg er glad for, at det virkede!


linuxuser42
linuxuser42's picture
Antal: 297
Tilmeldt:
05-01-2008
User is online
Kendter vist ikke nemo.

Kendte vist ikke nemo. Hvorfor ikke bare nautilus om man må spørge?


Spitten
Antal: 172
Tilmeldt:
05-02-2012
User is offline
Kendte vist ikke nemo.

#9: Kendte vist ikke nemo. Hvorfor ikke bare nautilus om man må spørge?
Nemo er standard filemanger i Cinnamon


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
#9 Kendte vist ikke nemo.

#9 Kendte vist ikke nemo. Hvorfor ikke bare nautilus om man må spørge?

Nemo er lidt mere brugervenlig end Nautilus, mener nogle muligvis.

Både i Mint Cinnamon og Ubuntu Gnome kan man udmærket installere dem begge, hvis man synes. De kan sagtens koeksistere:

https://www.dropbox.com/s/u3g84abcf9fgua2/nemo%20v...
https://www.dropbox.com/s/mluyijaki5dk7lm/nautilus...

Jeg skal huske at nævne, for en ordens skyld, at det kun er de to filmanagere der er installeret. Ikke hele Desktop Environments.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Nemo har også flere shell

Nemo har også flere shell context muligheder på højreklik, end Nautilus har. Og mulighed for bogmærke i panelet af f.eks. Dropbox-mappe.


linuxuser42
linuxuser42's picture
Antal: 297
Tilmeldt:
05-01-2008
User is online
Jamen her er et eksempel på

Jamen her er et eksempel på fordel og ulempe i opensource.
Flere features i alternativet(nemo) , men knap så mange brugere, og derved mindre udviklerpres for at fixe fejl. Sat på spidsen: Det er derfor vi har 117 Window managere der næsten virker. Noget for enhver smag der så ikke gøres færdig.


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
#13 Noget for enhver smag

#13 Noget for enhver smag der så ikke gøres færdig
Hvis det er #0's problem du mener, så har det ikke noget med Nemo at gøre, eller Nautilus for den sags skyld. Det er kun der problemet viser sig.

Alternativt kan #0 tilføje Nvidia's PPA, eventuelt blackliste 435 driveren, og så installere 440 driveren.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Alternativt kan #0 tilføje

Alternativt kan #0 tilføje Nvidia's PPA, eventuelt blackliste 435 driveren, og så installere 440 driveren.

Men problemet er jo løst, og har intet med grafikdriveren at gøre, men en bug i Linux,(der har eksisteret siden 2013!! og stadig gør) der gør, at diskcachen får skrivebordet til, (og filmanageren) at blive iresponsivt, imens der kopieres, unzippes, vises, eller på anden måde arbejdes med et stort antal filer på samme tid.

Dermed ikke sagt, at det ikke hjælper at opdatere drivere. Det gør det ofte, hvis der er driver-bugs - og det er der ofte mht NVIDIA. Eller undgå nouveau for den sags skyld.


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
Men problemet er jo

#15: Men problemet er jo løst, og har intet med grafikdriveren at gøre
Det er lidt et spørgsmål om det ikke hænger sammen. Jeg kan ikke selv afprøve det, fordi jeg ikke har det grafikkort, men #0 nævner:

#3: Der er en bug i 435 driveren, den får hele systemet til at fryse en gang imellem, og er løst i 440 driveren, som desværre ikke er med Mint.

#0 nævner i #7:
#7: Tak for hjælp. Det tæmmede problemet en hel del, jeg har som test lige lukket 100 billedmapper op i træk, uden problemer sic! Max 40% Cpu og 22% Ram.

Det er stadig rimeligt meget CPU forbrug, men der er også tale om 100 mapper. Så mange billedemapper har jeg ikke, så det kan jeg heller ikke teste efter.

Muligvis bør #0 også opgradere til 440 driveren.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Det er lidt et spørgsmål

Det er lidt et spørgsmål om det ikke hænger sammen.

Det vil nok kunne løse resten. Jeg mistænker det høje cpu-forbrug med, at video acceleration ikke er ordentligt i brug.
Så tager CPU'en over, hvor GPU'en ikke arbejder.


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
#17Det lyder sandsynligt.

#17

Det lyder sandsynligt. Jeg vil tilføje at selvom jeg ikke har så mange billedemapper, så er det hverdag for mig at håndtere overordentligt mange filer samtidigt, bl.a. medie filer (overførsel til netværksdrev), uden at opleve #0's problem. Som nævnt uden Nvidia eller ændringer i sysctl.


OracleJMT
OracleJMT's picture
Antal: 841
Tilmeldt:
26-05-2013
User is offline
Hsar du prøvet, at unzippe

Har du prøvet, at unzippe et arkiv med f.eks. over 10 eller 20GB? Det behøver ikke engang være så stort, bare 1 til 2GB, så skulle markøren meget gerne fryse i 1-2 sekunder imens det sker. Det er buggen i sin fulde udfoldelse.

Ved det fix jeg gav trådstarter løses netop det problem (men også trådstarters) ved, at bede kernen om, at vente med at lave det med diskcachen, den som standard gør (som får markøren til, at fryse imens) til et meget senere tidspunkt.


frogmaster
frogmaster's picture
Antal: 4498
Tilmeldt:
20-05-2010
User is offline
Har du prøvet, at

#19: Har du prøvet, at unzippe et arkiv med f.eks. over 10 eller 20GB? Det behøver ikke engang være så stort, bare 1 til 2GB, så skulle markøren meget gerne fryse i 1-2 sekunder imens det sker. Det er buggen i sin fulde udfoldelse
Jeg synes ikke jeg lige kan huske det, men det lyder rigtigt at der går nogle sekunder før reaktion. Jeg åbner ofte meget store filer over netværket, eller USB, både medie filer og VM's, hvor netop de nemt kan være helt op til 100 GB store.

VM's ligger indimellem på USB på grund af pladsmangel på systemdisken.