Problemer med PXI Express to M.2 adapter

marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Problemer med PXI Express to M.2 adapter

Jeg har for længe siden købt en Samsung 970 EVO NVMe M.2 SSD samt denne PCI Express to M.2 adapter.

Nu tog jeg mig så endelig sammen til at installere tingene og løb øjeblikkeligt ind i et problem jeg ikke lige kan greje. Bundkortet er et ASUS B85M-G bundkort som ifølge spec'en bruger PCI Express 3.0. Hvilket adapteren iflg. producenten understøtter.

Jeg kan dog ikke lige se hvordan adapteren skal kunne sættes ned i bundkortet.

Nogen der har noget bud?


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Hmm der står noget her:

Hmm der står noget her: https://www.hardwaresecrets.com/everything-you-nee...

Der er åbenbart forskellige sokkelstandarder. Men så vidt jeg kan læse mig frem til kan jeg bare smide adapteren i den store sokker.

Ønsker dog stadig gode råd og kommentarer ...


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
pcie-kort mht nvme ssd

Hej marlar

Jeg er ik klar over om dit pcie-kort er bootabel, men lagt de fleste pcie-kort mht nvme ssd diske er ik bootabel og jeg er heller ik klar over om du skal bruge ssd-disken som primær eller sekundær disk.

./allan


Domiino
Domiino's picture
Antal: 545
Tilmeldt:
26-03-2008
User is offline
Du har i følge dit link 2 x

Du har i følge dit link 2 x PCIe slots, der sætter du bare kortet i. Men om den kan boote fra den er jeg meget i tvivl om.


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Problemet var at adapteren

Problemet var at adapteren har en X4 connector og bundkortet har 2 stk. X1. Her passer adapteren ikke i. Men som der stod i linket i #1, kan man sætte den i en større sokkel, så den kom i X16 soklen. Og ja, det virkede fint.

Det er meningen at jeg vil boote fra den om muligt. Og det skulle det være ved at opdatere BIOS. Problemet er her at det kan man vistnok kun gøre fra Windows, og ikke fra en VM, så jeg er nok nødt til at installere Windows midlertidigt på en anden HD og så opdatere BIOS.

Skulle boot ikke være muligt er det ikke nogen katastrofe da jeg jo har en anden SSD i forvejen. Men den er kun 256 GB så jeg har desperat brug for plads. For tiden kører jeg aht. noget udvikling en virtuel Windows 7 fra min NAS, og det er i sagens natur ikke det hurtigste selv om det er over en gigabit-forbindelse.


Domiino
Domiino's picture
Antal: 545
Tilmeldt:
26-03-2008
User is offline
Altså jeg vil ikke udelukke

Altså jeg vil ikke udelukke at det ikke kan lade sig gøre, men... læser jeg specifikationerne på dit PCIe kort, så er det bygget til extra lagerplads og hastighedsboost - der står intet omkring boot :(


copycat
copycat's picture
Antal: 210
Tilmeldt:
25-09-2007
User is offline
#4 An. boot

Hej marlar

Hvis installationsprogrammet ikke kan se din M2, så tjek i Bios om den er sat til (Intel) Optane Mode, er den det, så skal du ændrer det til AHCI.

Min Pc booter fint fra M2 (efter at jeg ændrede til AHCI), men den er så også født med den.


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
Hej marlar #2: lagt de

Hej marlar

#2: lagt de fleste pcie-kort mht nvme ssd diske er ik bootabel
Som sagt tror jeg du skal have fat i et nyt bundkort for at få nvme ssd-disken bootable, som kræver en ny cpu da det er intel ellers kan du købe en ekstern boks til nvme-disken og kører disken som lagerplads via usb3 eller 3.1.

#4: opdatere BIOS
Der ville jeg nok boote maskinen og enten DEL eller F2 og igennem bios'en opdatere bundkortet og IK GENNEM WINDOWS!!

./allan


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
læser jeg

#5: læser jeg specifikationerne på dit PCIe kort

Mener du adapteren fra Startech?

så er det bygget til extra lagerplads og hastighedsboost - der står intet omkring boot

Hvad skulle der være specielt ved boot? Hvis bios overhovedet kan se disken (det kan den ikke endnu) hvorfor skulle den så ikke kunne boote fra den?

#6: Hvis installationsprogrammet ikke kan se din M2, så tjek i Bios om den er sat til (Intel) Optane Mode, er den det, så skal du ændrer det til AHCI.

Det vil jeg tjekke.

#7: Der ville jeg nok boote maskinen og enten DEL eller F2 og igennem bios'en opdatere bundkortet og IK GENNEM WINDOWS!!

Det vidste jeg ikke at man kunne! Må tjekke det ud.


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
grafikken via bundkortet

Hej marlar

Det positive er at du har valgt en intel cpu, hvor du kan kører grafikken via bundkortet og bruge pcie-porten via 16x og så må du undvære grafikkortet.

DET KØRER STADIGVÆK HURTIGERE VIA PCIE END USB3.1!!

./allan


Domiino
Domiino's picture
Antal: 545
Tilmeldt:
26-03-2008
User is offline
Tror ikke hans bundkort

#6: Tror ikke hans bundkort understøtter Optane Mode. Bundkortet understøtter 4. gen Intel cpu'er. Tror Optane er noget nyere.


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Det positive er at du

#9: Det positive er at du har valgt en intel cpu, hvor du kan kører grafikken via bundkortet

Ja, jeg bruger det indbyggede grafikkort. Det er fint for mig. Jeg spiller alligevel aldrig.

Har i øvrigt tjekket det med BIOS-opdatering. Ganske rigtigt, man kan opdatere via et USB-stik med opdateringen på.


copycat
copycat's picture
Antal: 210
Tilmeldt:
25-09-2007
User is offline
#10 Det tror jeg heller ikke.

Du har ret Domiino, en hurtig søgning på ASUS B85M-G bundkortet, ser ud til at udelukke Optane Mode.

Men så håber jeg, at rigtig mange har set indlægget, i det tilfælde, at de løber ind i problemet.


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
Du har ret Domiino, en

#12: Du har ret Domiino, en hurtig søgning på ASUS B85M-G bundkortet, ser ud til at udelukke Optane Mode.
Optane (accelerated SATA) er, så vidt jeg ved, og iøvrigt ikke at forveksle med AHCI, alligevel ikke kompatibel med Linux, men kun Windows.


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Nu fik jeg så opdateret

Nu fik jeg så opdateret BIOS til nyeste version. Man kan dog stadig ikke ses den nye NVMe disk. BIOS skal moddes for at kunne dette.

Men det mærkelige er at efter opdateringen kan jeg ikke længere boote fra den gamle SSD, med mindre jeg gør det manuelt via BOOT-menuen. Så virker det fint. Men disken står ikke på listen hvor man vælger boot-rækkefølge. Derfor forsøger den at boote op på en 500 GB HD idet den står som nummer 2, dvs.efter DVD-drevet.

Hvordan pokker kan det være at jeg ikke kan vælge den oprindelige SSD som standard-bootdrev når jeg sagtens kan vælge den fra bootmenuen?


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
#14 Har du en mulighed for

#14

Har du en mulighed for at vælge AHCI fra BIOS?


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Har du en mulighed for

#15: Har du en mulighed for at vælge AHCI fra BIOS?

Hvor skal jeg lede i BIOS'en - hvad hedder det overordnede "menupunkt"?

(Der burde være en søgefunktion i BIOS'er - der er jo et hav af indstillingsmuligheder)


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
Hvor skal jeg lede i

#16: Hvor skal jeg lede i BIOS'en - hvad hedder det overordnede "menupunkt"?
Det ved jeg sørme ikke. Det er BIOS specifikt.

Har du et menu punkt noget lignende:
General Section > Boot Sequence?

Jeg vil tro du også skal kikke på om UEFI er valgt. Muligvis skal UEFI være aktiv før det virker.

Du kan starte den gamle SSD manuelt via BOOT-menuen, men hverken den nye eller gamle SSD booter automatisk efter BIOS opgraderingen.

Er det korrekt forstået?


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
efter opdateringen kan

#14: efter opdateringen kan jeg ikke længere boote fra den gamle SSD

Prøv, marlar, at gå ind i bios via del eller f2 og nederst i højre hjørne (velkomstvinduet) kan man vælge boot-rækkefølgen eller kan du vælge avangeceret opsætning med f7 for evt at slå ahci fra/til (jeg kan se i spec på "ASUS B85M-G" hjemmeside at bios er sat til uefi.

Det kan jo evt være at du har sat bios til legacy-mode og via biosopdate har bios glemt denne opsætning, og din linux os er installeret i legacy-mode (dette scenario er kun et tænkt eks for at hjælpe dig!!).

./allan


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Du kan starte den gamle

#17: Du kan starte den gamle SSD manuelt via BOOT-menuen, men hverken den nye eller gamle SSD booter automatisk efter BIOS opgraderingen. Er det korrekt forstået?

Ja, helt rigtigt.

#18: Prøv, marlar, at gå ind i bios via del eller f2 og nederst i højre hjørne (velkomstvinduet) kan man vælge boot-rækkefølgen

Det der er problemet er at jeg slet ikke kan vælge SSD'en i bootrækkefølgen. Den mangler. Men den er der i boot-menuen.

#18: Det kan jo evt være at du har sat bios til legacy-mode og via biosopdate har bios glemt denne opsætning, og din linux os er installeret i legacy-mode

Det er i al fald helt korrekt at bios har glemt opsætningen, det bemærkede jeg med det samme. Den er helt jomfruelig.

Nå, men jeg forsker videre i morgen. Jeg kan jo heldigvis sagtens boote mit system, omend der lige skal lidt ekstra tastetryk til.


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
sataport-1 eller 0 på bundkortet

Hej marlar

En ting jeg kom til at tænke på var om du ik har brugt sataport-1 eller 0 på bundkortet til din OS pga nulstilingen i bios efter opdateringen, for ellers kan det godt give problemmer. Jeg har hørt om dette problem, når bios ik vil boote. Hvor og hvornår i de mange timers youtube video af carey holzman kan jeg ik huske, men han anbefaler at man bruger sataport-1 eller 0 på bundkortet når der er problemmer med at boote.

./allan

PS: Du jo altid mulighed for at nulstille bios enten ved at tage batteriet ud af bundkortet et par minutter og sætte det i igen, eller cleare CMOS på bundkortet hvis alt gå galt i biosopsætningen.


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
eg har hørt om dette

#20: Jeg har hørt om dette problem, når bios ik vil boote

Men den vil jo godt boote. Den gider bare ikke boote til SSD'en som default.

#20: Du jo altid mulighed for at nulstille bios enten ved at tage batteriet ud af bundkortet et par minutter og sætte det i igen, eller cleare CMOS på bundkortet hvis alt gå galt i biosopsætningen.

Der er også en "nulstil alt" i BIOS-menuen. Det har jeg prøvet.


1bot.dk
Antal: 332
Tilmeldt:
16-12-2017
User is offline
svar på #21

#21: Men den vil jo godt boote. Den gider bare ikke boote til SSD'en som default.
Jeg mente bare ved at vælge sataport-1 kunne der måske være en mulighed at få din maskine tilbage som den var.

Hvilke sataport bruger dit linux OS (disk) nu??

og igen var det bare for at hjælpe dig ;o))

./allan


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
Men den vil jo godt

#21: Men den vil jo godt boote. Den gider bare ikke boote til SSD'en som default.
- Kan Mint OS se den ene, eller begge SSD'er, fra Diske?
- Har du forsøgt at afmontere henholdsvis Samsung 970 EVO NVMe M.2 SSD og din gamle SSD, således kun den ene er monteret (på bundkortet)?
- Kan M.2 disken bootes?
- Er der UEFI på maskinen?
- Er Secure Boot deaktiveret?
- Hvilke partitioner er oprettet på diskene?
- Er der andet du kan tilføje ...

Der er for mange uafklarede spørgsmål ...


marlar
Antal: 3114
Tilmeldt:
05-12-2009
User is offline
Der er for mange

#23: Der er for mange uafklarede spørgsmål ...

Jeg vender tilbage med mere info senere. Har lige et par travle dage. Og heldigvis fungerer det jo, det er bare opstarten der tager nogle sekunder længere :)