NX forbindelse, men ingen netadgang via Firefox, Thunderbird mv - LØST

jenss
Antal: 192
Tilmeldt:
03-08-2007
User is offline
NX forbindelse, men ingen netadgang via Firefox, Thunderbird mv - LØST

Hej!
Jeg har en ældre (86 år) medborger (må det vist hedder i disse dage) jeg hjælper med computer ting.
Jeg har desværre ved en opgradering for nogen tid siden glemt at disable info om opdateringer og opgraderinger.
Han har så her i dag trykket på OK i en meddelelsesboks om han ville opgradere, og med hans egne ord undervejs trykket på nogle knapper der nok var blå... Af en eller anden grund, husker han først at han er i gang med noget jeg udtrykkeligt har sagt han ikke må gøre, da Genstart system knappen dukker op (det er den 3. over 80 i denne uge der har glemt mine "pc-instrukser", og fået rodet rundt i deres setups mv (forståligt)).
Efter genstart er der ingen adgang til nettet fra Firefox, Thunderbird mv.
Jeg tilgår hans maskine med NoMachine/NX (fast ip og port forward) og DET FUNGERER!
Distro er Xubuntu (opgraderet fra 16.04 til 18.04)
Jeg har bl.a. forsøgt at ændre DNS fra auto til faste (bl.a. TDC og Goggles DNS), og manuel opsætning af IP, gateway etc., med genstarter af maskinen.
Udfordringen er lidt at jeg skal passe på ikke at miste NX forbindelsen, da medborgeren er meget svær at forklare selv meget enkle ting.
ufw status = inactive
Jeg er løbet lidt tør for ideer og google-søgninger, så jeg håber der er en der kan give mig et skub i den rigtige retning.
:-)
(og ja han burde ikke have en sudo-konto - fy mig)


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
Jeg har bl.a. forsøgt

#0: Jeg har bl.a. forsøgt at ændre DNS fra auto til faste (bl.a. TDC og Goggles DNS), og manuel opsætning af IP, gateway etc., med genstarter af maskinen.
Har du også flushed DNS Cache, fx efter denne vejledning: https://vitux.com/how-to-flush-dns-cache-on-ubuntu...

#0: (og ja han burde ikke have en sudo-konto - fy mig)
LOL

Hvis du mister forbindelsen til hans maskine, fordi ingen ved hvad han har foretaget sig, og fordi diverse forsøg på at rette netværksfejlen kan medføre det, så vil det muligvis blive nødvendigt at aflægge ham et besøg. Eventuelt, i sidste ende, for at geninstallere OS.

Det kan PT også blive et problem i forbindelse med Covid-19 situationen.


jenss
jenss's picture
Antal: 192
Tilmeldt:
03-08-2007
User is offline
DNS flush hjalp desværre ikke

Hej frogmaster, tak for hjælp, men det løste desværre ikke problemet.
sudo systemd-resolve - -statictics viser no og 0 i alle væredier (både før og efter flush-caches)
Det virker som om du også tror det har noget at gøre med DNS, men der må være et eller andet korrupt i nogle config-filer.
Har prøvet at tilføje opsætning manuelt til /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.1.21
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 8.8.8.8 4.4.2.2
men kan se at det stadig er det oprindelige setup der vises i forbindelsesinformation.
Skal/kan man evt. disable network manager /etc/NetworkManager “managed=false”, eller tager dette hele systemet, må indrømme at jeg er lidt ude i kanten af min viden.
frogmaster: Som du siger er det lidt op af bakke med Covid-19, det må være hans datter der skal tage stilling til om hun vil gå ind og skifte pc ud med en fungerende.


jenss
jenss's picture
Antal: 192
Tilmeldt:
03-08-2007
User is offline
Nu virker det

Nu virker det! En ekstra genstart for prins Knud hjalp.
Løsningen (her) er så manuelt at tilføje statisk setup til /etc/network/interfaces
(gui i xubuntu har selv disablet sig).
TAK - det hjælper altid at ping-ponge med andre.


frogmaster
frogmaster's picture
Antal: 4584
Tilmeldt:
20-05-2010
User is offline
#3 Godt gået jenss og tak

#3
Godt gået jenss og tak for tilbagemeldningen.