Wifi-bøvl

marvin0628
Antal: 10
Tilmeldt:
11-03-2020
User is offline
Wifi-bøvl

Hej.

For noget tid siden måtte jeg sige farvel til min gamle router og købe en ny. Det blev til en Cisco RV340W.

Den fungerer sådan set fint; hastigheden på Wifi er højere end før og mere stabil - men nogle gange sker der underlige ting:

- Windows 10 - ingen problemer

- Diverse BSD-distroer - ingen problemer

- Diverse Linux-distroer (har prøvet PClinuxOS, openSuse Leap, Artix, Devuan, MXlinux) - her er der problemer. PC'erne kan "se" det trådløse netværk men det kniber for PC'en at blive godkendt (selvom koden helt sikkert passer) og selv hvis det lykkes, risikere man ofte at blive smidt af enten umiddelbart efter eller efter et stykke tid.

- Diverse mobiltelefoner og Chromecast - hver for sig fungerer forbindelsen fint og stabilt, men af og til kan mobilen pludselig ikke se Chromecasten igen, selvom de er på samme netværk. Så skal man slukke for wifi på mobilen og tænde det igen.

Det drejer sig helt sikkert om en eller anden indstilling på routeren, men jeg har ingen ide om hvilken. Navnlig ikke, når det nu kører så problemfrit på Windows og xBSD...

Nogen ideer?


osjensen
osjensen's picture
Antal: 1633
Tilmeldt:
14-01-2007
User is offline
Du har sikker været der

marvin0628
Antal: 10
Tilmeldt:
11-03-2020
User is offline
Jep, og noget af det har

#1:
Jep, og noget af det har jeg også prøvet af.

Inden jeg møjsommeligt fortsætter med at ændre en parameter af gangen, ville jeg lige høre, om nogen måske var stødt på noget lignende.

Det undrer mig jo virkelig, at det kan drille for nogle distroer og virke fint for andre...


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
Det undrer mig jo virkelig,

Det undrer mig jo virkelig, at det kan drille for nogle distroer og virke fint for andre...

Wink wink!

WIFI b, g, n, etc. og manglende understøttelse af disse kan variere alt efter ældre eller nyere kerneversion. Måske det kan spille en rolle?

Routerindstillinger mht. 2.4 Ghz og 5Ghz kan være problematiske nogle gange - jeg taler af erfaring, alt efter om 2.4 Ghz eller 5Ghz er understøttet bedst. - Prøv at omdøbe 2.4 Ghz forbindelsen til 2.4Ghz og 5Ghz forbindelsen til 5Ghz, og brug den af de to der er understøttet. De vil vise sig seperat som SSID'er.


marvin0628
Antal: 10
Tilmeldt:
11-03-2020
User is offline
Det med kerneversionerne

#3:
Det med kerneversionerne kunne være en mulighed, men jeg har testet med helt nye distroer - men jeg kan da prøve at undgå de nyeste og se, om det går bedre.

Hm - så du mener undgå mellemrum i SSID'erne?


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
Hm - så du mener undgå

Hm - så du mener undgå mellemrum i SSID'erne?

Nej, separere 2.4Ghz forbindelsen og 5Ghz forbindelsen, så du kan bruge dem hver for sig med samme Wifi adgangskode. I dine routerindstillinger burde du have to punkter, en a 2.4Ghz med dit almindelige SSID, og et a 5Ghz med dit almindelige SSID. Omdøb 2.4 Ghz med alm. SSID til 2.4Ghz, omdøb 5Ghz med alm. SSID til 5Ghz. Nu kan du vælge 2.4Ghz eller 5Ghz, alt efter hvilken device, der kan trække det ene eller det andet.


ejvindh
Antal: 117
Tilmeldt:
17-05-2010
User is offline
Jeg har også til tider haft

Jeg har også til tider haft bøvl med udvalgte trådløse netværk (ubuntubaseret distro). Det plejer at hjælpe at geninstallere bcmwl-kernel-source. Det kunne du da i hvert fald prøve:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source
sudo reboot


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
Ovenstående vil ikke virke

Ovenstående vil ikke virke hvis du ikke bruger Broadcom Wireless i din computer, Marvin0628.


ejvindh
Antal: 117
Tilmeldt:
17-05-2010
User is offline
Det er klart. Ligesom

#7: Det er klart. Ligesom det heller ikke er sikkert at dine råd virker. Når jeg skød mit forslag ind, var det fordi, marvin0628 meldte tilbage at det syntes at være uafhængigt af kernelversioner. Derfor tænkte jeg at mønsteret lød mere som mine oplevelser end dine, og så bød jeg ind med dem. Også fordi jeg tænker problemet jo vil kunne opstå på andre routere også (hvor man altså ikke har admin adgang), og der kan man jo ikke regne med selv at kunne ændre på SSID hver gang.


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
#7 No worries.

#8 No worries.


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
(hvor man altså ikke har

(hvor man altså ikke har admin adgang), og der kan man jo ikke regne med selv at kunne ændre på SSID hver gang.

Hvorfor problemet ikke vil være så tiltalt, hvis der er tale om moderne computere med B/G/N-understøttelse, da 5Ghz båndet er afhængig af af understøttelse af den teknologi. Jeg ved ikke om marvin's computer er fra de seneste tre år, eller ældre. Men jeg ved, at routeren er ny. Derfor lagde jeg 2+2 sammen. Pointen er, at koble maskiner med understøttelse af X på X, og maskiner med understøttelse af Y på Y. Normalt kan ældre maskiner kun bruge 2.4Ghz WIFI båndet, i værste fald, og i bedste fald kun have forringet understøttelse af 5Ghz båndet.


marvin0628
Antal: 10
Tilmeldt:
11-03-2020
User is offline
D'herrer - I skal have tak

D'herrer - I skal have tak for jeres input. Tak fordi I ville give det lidt overvejelser :-)

Måske har jeg fundet svaret - eller i hvert fald en del af det; det, der vedrører Linux.

Jeg fjernede et par flueben i routeren vedrørende WWM og Frame buffer og - tadaa - det lod til at virke!

Linux-PC'en (en HP ProBook med MXlinux i dette tilfælde) havde pludselig forbindelse til nettet, selvom jeg havde vendt ryggen til. Batteriet var fuldt opladet, så jeg fjernede strømforsyningen - og fem minutter senere havde den mistet forbindelsen til nettet.

Nå - øv.

Men hov - mon forbindelsen ville være stabil, hvis den fik konstant strøm fra strømforsyninngen? Svaret var ja.

Noget kunne tyde på, at det har noget med strømstyring at gøre, hvilket kunne forklare, hvorfor jeg ikke oplevede problemerne på BSD-maskinerne, hvor strømstyringen enten slet ikke er sat op eller er sat til at vente meget længere (på MXlinux er strømbesparelse for skærm f.eks. efter 10 min.)

Men hvorfor ind i hede hule himmerige oplevede jeg så ikke det samme med min gamle router?

Måske fordi jeg på præcis samme tidspunkt, som jeg skiftede routeren, begyndte at installere en ny Linux-PC til min nevø - der oplevede jeg så balladen med wifi, gav distroen skylden og skiftede distroer som en vild... pt. har jeg ikke en PC med en Linux-distro, som jeg brugte før router-skiftet.

Så altså - jeg skal have kigget på strømstyringsindstillingerne på diverse Linux'er. Ifølge systemindstillingerne på MXlinux skulle wifi ikke blive påvirket af, om den kører på batteri eller ej - det gør den så øjensynligt alligevel, såe - hvad kigger man efter her..?

Problemerne med mobiltelefonernes afbrydelse til "Krom Karsten" lader til at være afhjulpet - jeg gætter på det skyldes ovennævnte flueben til "WWM", men det kræver lidt flere eksperimenter.


OracleJMT
OracleJMT's picture
Antal: 1344
Tilmeldt:
26-05-2013
User is offline
BSD-maskinerne, hvor

BSD-maskinerne, hvor strømstyringen enten slet ikke er sat op eller er sat til at vente meget længere

powerd er mægtigt intelligent.