Sløv harddisk

mich
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Sløv harddisk

Hej Forum!

Jeg har to eksterne harddiske, som jeg bruger regelmæssigt til backup. De har hidtil været omtrent lige længe om en backup, den ene en smule længere end den anden, men ikke meget.
For nylig er den ene til min forundring blevet meget langsommere, mere end 2,5 gange langsommere, og jeg undrer mig over hvorfor.

Kan nogen her foreslå en mulig årsag, og meget gerne en mulig afhjælpning, vil jeg være taknemmelig

./mich


julemand101
julemand101's picture
Antal: 1717
Tilmeldt:
17-01-2004
User is offline
Kan du lige se om der står

Kan du lige se om der står en masse diskfejl når du kører dmesg kommandoen efter du har lavet nogle filoverførsler?


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Re: Kan du lige se om der står

Tak for input.
Jeg prøvede at kopiere en cirka 350 MB fil, og den sløve HD producerede nogle fejlmeddelelser i dmesg.

Først WD_Elements, der har kørt som den plejer hele vejen.
Dernæst Seagate_Backup+, der er blevet sløvere, end den plejer.
Sidst WD My Passport, der i første omgang var den sløveste af dem alle, men nu var den hurtigste. Den har jeg ikke brugt så ofte, så sammenligning er ret usikker.
De to andre bruger jeg som regel parvis ved backup.

Jeg ville fremhæve fejlmeddelelserne fra dmesg, men desværre kan jeg ikke få html-tags til at virke, så jeg markerede begyndelsen af fejlmeddelelserne med (****)
Et par andre mulige fejl, er 'usb 2-1: stat urb: status -71', der optræder et par gange.

Jeg har kun set fejlmeddelelser ved Seagate-disken.

[root@corax 2020-12-29]# time rsync -av 20201227-201243_70D.mov /run/media/mich/WD_Elements/backup/.
sending incremental file list
20201227-201243_70D.mov

sent 381,269,905 bytes  received 35 bytes  33,153,907.83 bytes/sec
total size is 381,176,736  speedup is 1.00

real    0m10.663s
user    0m2.391s
sys     0m0.893s
[root@corax 2020-12-29]#

[138282.132100] usb 2-1: new high-speed USB device number 11 using ehci-pci
[138282.327142] usb 2-1: New USB device found, idVendor=1058, idProduct=25a2
[138282.327148] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[138282.327152] usb 2-1: Product: Elements 25A2
[138282.327154] usb 2-1: Manufacturer: Western Digital
[138282.327157] usb 2-1: SerialNumber: 57584631413636354C554B37
[138282.327565] usb-storage 2-1:1.0: USB Mass Storage device detected
[138282.328879] scsi host14: usb-storage 2-1:1.0
[138283.331955] scsi 14:0:0:0: Direct-Access     WD       Elements 25A2    1014 PQ: 0 ANSI: 6
[138283.338157] sd 14:0:0:0: [sdb] Spinning up disk...
[138284.340040] ......ready
[138289.360723] sd 14:0:0:0: [sdb] 3906963456 512-byte logical blocks: (2.00 TB/1.82 TiB)
[138289.361719] sd 14:0:0:0: [sdb] Write Protect is off
[138289.361725] sd 14:0:0:0: [sdb] Mode Sense: 47 00 10 08
[138289.362715] sd 14:0:0:0: [sdb] No Caching mode page found
[138289.362721] sd 14:0:0:0: [sdb] Assuming drive cache: write through
[138289.458141]  sdb: sdb1
[138289.462475] sd 14:0:0:0: [sdb] Attached SCSI disk
[138293.594091] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[mich@corax ~]$

[root@corax 2020-12-29]# time rsync -av 20201227-201243_70D.mov /run/media/mich/Seagate_Backup+/backup/.
sending incremental file list
20201227-201243_70D.mov

sent 381,269,905 bytes  received 35 bytes  23,107,269.09 bytes/sec
total size is 381,176,736  speedup is 1.00

real    0m15.529s
user    0m2.396s
sys     0m0.937s
[root@corax 2020-12-29]#

[137150.301108] usb 2-1: new high-speed USB device number 7 using ehci-pci
[137150.419717] usb 2-1: New USB device found, idVendor=0bc2, idProduct=ab24
[137150.419723] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[137150.419726] usb 2-1: Product: BUP Slim BL
[137150.419729] usb 2-1: Manufacturer: Seagate
[137150.419731] usb 2-1: SerialNumber: NA7L3G5Y
[137150.421279] scsi host10: uas
[137150.422463] scsi 10:0:0:0: Direct-Access     Seagate  BUP Slim BL      0302 PQ: 0 ANSI: 6
[137150.424575] sd 10:0:0:0: [sdb] Spinning up disk...
[137151.425034] ...ready
[137153.427613] sd 10:0:0:0: [sdb] 3907029167 512-byte logical blocks: (2.00 TB/1.82 TiB)
[137153.427616] sd 10:0:0:0: [sdb] 2048-byte physical blocks
[137153.684025] sd 10:0:0:0: [sdb] Write Protect is off
[137153.684033] sd 10:0:0:0: [sdb] Mode Sense: 4f 00 00 00
[137153.684734] sd 10:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[137153.702642]  sdb: sdb1
[137153.705739] sd 10:0:0:0: [sdb] Attached SCSI disk
[137165.960273] EXT4-fs (sdb1): recovery complete
[137165.980148] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[137316.644696] usb 2-1: USB disconnect, device number 7
[137316.645475] blk_update_request: I/O error, dev sdb, sector 0    (****)
[137316.757024] sd 10:0:0:0: [sdb] Synchronizing SCSI cache
[137316.760036] blk_update_request: I/O error, dev sdb, sector 0
[137316.763039] blk_update_request: I/O error, dev sdb, sector 1950613504
[137316.763047] Buffer I/O error on dev sdb1, logical block 243826688, lost sync page write
[137316.763066] JBD2: Error -5 detected when updating journal superblock for sdb1-8.
[137316.763069] Aborting journal on device sdb1-8.
[137316.763083] JBD2: Error -5 detected when updating journal superblock for sdb1-8.
[137316.835081] sd 10:0:0:0: [sdb] Synchronize Cache(10) failed: Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
[137317.058024] usb 2-1: new high-speed USB device number 8 using ehci-pci
[137317.175696] usb 2-1: New USB device found, idVendor=0bc2, idProduct=ab24
[137317.175701] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[137317.175703] usb 2-1: Product: BUP Slim BL
[137317.175705] usb 2-1: Manufacturer: Seagate
[137317.175707] usb 2-1: SerialNumber: NA7L3G5Y
[137317.182069] scsi host11: uas
[137317.187700] scsi 11:0:0:0: Direct-Access     Seagate  BUP Slim BL      0302 PQ: 0 ANSI: 6
[137317.190842] sd 11:0:0:0: [sdb] Spinning up disk...
[137318.192037] .ready
[137318.193119] sd 11:0:0:0: [sdb] 3907029167 512-byte logical blocks: (2.00 TB/1.82 TiB)
[137318.193123] sd 11:0:0:0: [sdb] 4096-byte physical blocks
[137318.243203] usb 2-1: stat urb: status -71
[mich@corax ~]

[root@corax 2020-12-29]# time rsync -av 20201227-201243_70D.mov /run/media/mich/My_Passport/backup/.
sending incremental file list
20201227-201243_70D.mov

sent 381,269,905 bytes  received 35 bytes  44,855,287.06 bytes/sec
total size is 381,176,736  speedup is 1.00

real    0m8.261s
user    0m2.426s
sys     0m0.887s
[root@corax 2020-12-29]#

[137718.572107] usb 2-1: new high-speed USB device number 10 using ehci-pci
[137718.760188] usb 2-1: New USB device found, idVendor=1058, idProduct=0820
[137718.760193] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[137718.760197] usb 2-1: Product: My Passport 0820
[137718.760199] usb 2-1: Manufacturer: Western Digital
[137718.760202] usb 2-1: SerialNumber: 57584331413834324130304A
[137718.760593] usb-storage 2-1:1.0: USB Mass Storage device detected
[137718.762017] scsi host13: usb-storage 2-1:1.0
[137719.763871] scsi 13:0:0:0: Direct-Access     WD       My Passport 0820 1012 PQ: 0 ANSI: 6
[137719.768831] scsi 13:0:0:1: Enclosure         WD       SES Device       1012 PQ: 0 ANSI: 6
[137719.770330] sd 13:0:0:0: [sdb] Spinning up disk...
[137719.775080] ses 13:0:0:1: Attached Enclosure device
[137720.773040] .ready
[137725.489774] sd 13:0:0:0: [sdb] 3906963456 512-byte logical blocks: (2.00 TB/1.82 TiB)
[137725.491760] sd 13:0:0:0: [sdb] Write Protect is off
[137725.491765] sd 13:0:0:0: [sdb] Mode Sense: 47 00 10 08
[137725.493132] sd 13:0:0:0: [sdb] No Caching mode page found
[137725.493137] sd 13:0:0:0: [sdb] Assuming drive cache: write through
[137725.508060]  sdb: sdb1
[137725.512885] sd 13:0:0:0: [sdb] Attached SCSI disk
[137734.810286] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[mich@corax ~]$

./mich


OracleJMT
OracleJMT's picture
Antal: 1439
Tilmeldt:
26-05-2013
User is offline
Har du kørt fsck -f eller

Har du kørt fsck -f eller med -c flaget på de diske? Det kunne du med fordel prøve.

Pragmatisk, apolitisk teknologifreak. Tungnem overfor politisk korrekte, pladrende softwareaktivister i deres såkaldte gode, hellige sags tjeneste.

The Unix way or the highway.

"One of my most productive days was throwing away 1,000 lines of code."
- Ken Thompson

*************************
https://mewe.com/join/linuxbsd


julemand101
julemand101's picture
Antal: 1717
Tilmeldt:
17-01-2004
User is offline
#0 Ja, de diske ser sku ikke

#0
Ja, de diske ser sku ikke sunde ud. Det kan være det bare er et spørgsmål om en dårlig tilstrand i filsystemet (kan opstå siden det er en ekstern disk som jo kan være blevet koblet af på et dårligt tidspunkt. En anden mulighed er at disken har en hardware fejl.

Prøv som #3 foreslår men personligt tror jeg nu mere at disken er død da det ser ud til den har problemer med at skrive til flere sektorer.


marlar
Antal: 3214
Tilmeldt:
05-12-2009
User is offline
#0Hvis du har nogle ting

#0

Hvis du har nogle ting på harddisken som du ikke har andre steder, så skal du nok til at kopiere det et andet sted hen. Diskfejl kan hurtige brede sig så du står med en helt død disk.

Du kan evt prøve at omformatere den (efter du sørget for evt backup).


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Ja, naturligvis vil jeg

Ja, naturligvis vil jeg køre en e2fsck og se, om ikke det hjælper. Ellers må jeg jo tage skrappere midler i brug, som #5 foreslår.
Det er dog altid rart, at få andre til at kigge på et problem og give en kommentar. Tak for det.
Jeg synes ikke disken virker død, men skulle det være tilfældet, er det nok ikke verdens undergang. Jeg plejer at tage backup på to diske hver gang, så er det ikke på den ene, er det forhåbentlig på den anden.
#4: Ja, de diske ser sku ikke sunde ud.
Mener du ikke "Den disk"?
Seagate melder flere fejl, men de to andre ser vel ret ok ud. Eller kan du se fejl eller bekymringer i dem også?

./mich


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Jeg synes ikke disken

#6: Jeg synes ikke disken virker død,
Måske lidt ustabil. Af og til mister den forbindelsen til PC'en.
Problemer med kabel eller stik, måske?

./mich


julemand101
julemand101's picture
Antal: 1717
Tilmeldt:
17-01-2004
User is offline
#6-7 Ja, beklager det er

#6-7
Ja, beklager det er self. kun den ene disk jeg mente. Din teori omkring kabel kunne også godt forklare problemet da det kan ses i loggen at kort efter diskfejlen så meldes disken ind på ny (som om kablet er lige sat i igen). Vil dog stadig ikke udelukket at disken er dårlig. Få dig et ordentligt kabel og få kørt en scanning efter badblocks på hele disken.


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Jeg gentog kopieringen fra i

Jeg gentog kopieringen fra i går med et andet kabel uden at få fejl i dmesg, og nu kører den e2fsck -c -f. Det ser dog ud til at tage en rum tid, og jeg venter ikke svar før i morgen tidlig.

./mich


phoenix
Antal: 39
Tilmeldt:
23-03-2004
User is offline
Smartmontools

Prøv evt. og tag et kig på Smartmontools, det er et værktøj til at teste harddiske.
SMART https://en.wikipedia.org/wiki/S.M.A.R.T. er en standard til harddisk test/monitorering.


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Smartmontools Tak, det

#10: Smartmontools
Tak, det kigger jeg på, men den igangværende test skal lige være færdig, og det ser ud til at tage nogle timer endnu.

Det gode er, at badblocks er 65% færdig og har endnu ingen fejl fundet.

./mich


mich
mich's picture
Antal: 1019
Tilmeldt:
13-10-2007
User is offline
Badblocks kørte i 14-15

Badblocks kørte i 14-15 timer uden at finde fejl, og derefter kørte e2fsck meget hurtigt og endte med at skrive

Seagate_Backup+: ***** FILE SYSTEM WAS MODIFIED *****
Seagate_Backup+: 1120086/122101760 files (4.3% non-contiguous), 370605961/488378389 blocks

Dog fik jeg ikke at vide, hvad der var ændret, men nu skulle den vel være i orden, og så må jeg bare holde øje med den fremover.
Tak til jer alle.

./mich