kiba-dock installation på Fedora Core 6

Fedora

Dette er en guide der er lavet til alle der bruger Fedora Core 6, der gerne vil have lidt ekstra guf. Kiba-Dock er et program der giver dig muligheden for at få en fed "Mac-Dock" på linux.

Det installeres ved at åbne terminalen og ved at gennemgå underpunkterne.

1. # yum install librsvg2-devel libglade2-devel pango-devel gtk2-devel glitz-glx-devel

2. # cvs -d:pserver:anonymous@metascape.afraid.org:/cvsroot co kiba-dock

2.b hvis at du får fejlen : # bash: cvs: command not found

Så skal du installere cvs :

# yum install cvs

og så skal du gå tilbage til step 2 igen.

3. # cd kiba-dock/

4. # ./autogen.sh

4.b hvis at du får fejl nr # ./autogen.sh: line 9: autoreconf: command not found

så skal du installere autoconf :

# yum install autoconf

og så skal du gå tilbage til step 4 igen.

4.c hvis at du får fejlen # ./autogen.sh
Can't exec "aclocal": Ingen sådan fil eller filkatalog at /usr/bin/autoreconf line 174.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 174.
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal --output=aclocal.m4t
Can't exec "aclocal": Ingen sådan fil eller filkatalog at /usr/share/autoconf/Autom4te/FileUtils.pm line 288.
autoreconf: failed to run aclocal: Ingen sådan fil eller filkatalog

så skal du installere automake:

# yum install automake

og så skal du gå tilbage til step 4 igen.

4.d hvis at du får fejlen error # ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal
autoreconf: configure.in: tracing
autoreconf: configure.in: creating directory config
autoreconf: configure.in: not using Libtool
autoreconf: running: /usr/bin/autoconf
configure.in:30: error: possibly undefined macro: AC_PROG_LIBTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

så skal du installere libtool :

# yum install libtool

og så skal du gå tilbage til step 4 igen.

4.e if you get the error # No package 'libgtop-2.0' found

så skal du installere libgtop2-devel :

# yum install libgtop2-devel-2.14.4-2.fc6

og så skal du gå tilbage til step 4 igen.

5. # make

6. # make install-schemas

7. # sudo make install

8. Så er du færdig, og hvis alt er gået vel, så skulle kiba-dock starte op med denne terminalkode # kiba-dock

andre problemer :

1. kiba-dock ikonet/overfladen kan være "messed up", hvis at det er det, så skal du huske at installere beryl ;)

// GonzoDark

ps. stavefejl kommer gratis