Undertekster på vlc-videoer lidt ligesom på youtube

1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Undertekster på vlc-videoer lidt ligesom på youtube

Hej

Er der nogen som kan hjælpe mig med at få undertekster på vlc-videoer lidt ligesom på youtube??

/allan


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Start filmen Træk og slip

Start filmen
Træk og slip undertekst filen oven på VLC.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Tale til tekst (lydgenerator)

Det er en youtube video som jeg har fundet og downloadet fra y2mate.com (link: "https://y2mate.com/youtube/G6LAIrGeIjo"), men jeg kan ik finde subtitelfilen til videoen.

Jeg troede at det var en lydgenerator som dannede en tekststreng udfra hvad der blev sagt i videoen lidt ligesom når du sætter undertekst på når du ser youtubevideoen online (den kan enten fåes frem med tasten "c" eller klikke ned i højre hjørne hvor et tekstikon er synligt, hvis ham der har lavet videoen har husket at sætte denne funktion til).

Videoen jeg har linket til har tidligere har undertekster online (link: "https://www.youtube.com/watch?v=G6LAIrGeIjo").

/allan


frugtoase
Antal: 106
Tilmeldt:
26-07-2005
User is offline
#2 Du kan downloade

#2 Du kan downloade undertekster fra YouTube med Firefox-udvidelsen Youtube Subtitle Downloader.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
1botDet er nødvendigt du

1bot

Det er nødvendigt du har en synkroniseret undertekst fil til præcist den video du ønsker.
Undertekster er ikke genereret fra lydfiler (eller lydspor i film), men af et individ, en person, der har brugt timer på at kreere den. Med andre ord, findes underteksten ikke, så skal du selv lave den.

Det har ikke specielt med Linux at gøre, men med al computing. Problemet med software, der kan oversætte tale til tekst, endnu ikke er tilstrækkeligt udviklede. Disse programmer er stadig så fejlramte at de praktisk taget er ubrugelige. Det går bedre med tekst til tale programmer.

Af den samme årsag skal du downloade den aktuelle undertekst.

Hvis den findes, men på et andet sprog end du ønsker, så kan den oversættes af maskiner, men heller ikke uden problemer. Er det aktuelt, så se fx https://www.linuxin.dk/node/22543#comment-92568 til en start.


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
#0Hvis du har en youtube

#0
Hvis du har en youtube konto, er der nogle muligheder:
https://www.wikihow.com/Add-Subtitles-to-YouTube-V...

Som "Contributing Subtitles to Videos of Others".
Vil du undervise andre, med videoen?

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
undertekstfilen til youtube-videoen

Hej Frogmaster

Programmet tale-til-tekst er ik udviklet endnu som du så rigtigt selv siger, men jeg undre mig over at man via y2mate.com kan downloade youtube-video i en mp4/mp3 fil uden at kunne hente undertekst-filen dertil.

/allan

#3: Jeg er ik klar over hvordan linket skal bruges (ik særlig selvforklarende!!).


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
#5 Kan du så hente

#5
Kan du så hente undertekstfilen ned, som trejde mand så du henter den som bruger ligesom videoen kan hentes ned via y2mate.com??

/allan


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Vil du kun have

Vil du kun have underteksten, kan du i en terminal køre:

youtube-dl --all-subs --skip-download https://www.youtube.com/watch?v=G6LAIrGeIjo

eller

youtube-dl --all-subs https://www.youtube.com/watch?v=G6LAIrGeIjo

hvis du vil have video + undertekster.

Det giver dig, den engelske under-tekst.
Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.en.vtt

Du skal selvfølgelig have
youtube-dl
installeret.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Det bedste svar jeg kan give

Det bedste svar jeg kan give er at såfremt du opretter en undertekst (subtitle), så upload den for at deltage i fællesskabet.

#6: Jeg er ik klar over hvordan linket skal bruges (ik særlig selvforklarende!!)
Forstår du engelsk? Det er ganske klart beskrevet. Hvis du ikke forstår engelsk, så skriv det.

Er det iøvrigt linket i #3 eller #4 du mener?

1bot. Du undlod allerede i #0 at beskrive præcist hvad du ønsker. Kun hvordan man viser undertekster i VLC. Lidt ligesom i Youtube er ikke fyldestgørende.

Prøv at høre, hvis underteksten eksisterer, men bare ikke på dansk, så skal den oversættes, Det kan du bruge Subtitle Cat til.

Jeg vil gerne bede dig gøre dig lidt mere umage, for ikke at spilde både din og min tid.

Du har fået en masse mulige svar allerede og iøvrigt var det ikke for sjov jeg skrev denne kommentar: https://www.linuxin.dk/node/22550


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Det skulle jo prøves.Jeg

Det skulle jo prøves.
Jeg har nu 3 filer i en mappe -

$ ls
Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.da.vtt
Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.en.vtt
Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.mp4

vlc viser videoen, med mine danske undertekster (google oversat), automatisk.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Hej igen og tak for hjælpen

Hej igen og tak for hjælpen mht undertekst youtube-videoer afspillet vha VLCplayeren.

Jeg fik installeret youtube-dl via terminalen (sudo install youtube-dl) og hentet "youtube-dl --all-subs https://www.youtube.com/watch?v=G6LAIrGeIjo" som osjensen gav i #8, og derefter fandt jeg videoen på min maskine som jeg startede i VLC. Så tilføjede jeg vtt-filen i VLC og bingo der var undertekster på videoen, og den ekstra bonus var at der ik er de infame reklamer (nogengange 2stk i træk) på som du efterhånden ik kan undgå.

som frugtoase i #3 linker til "https://addons.mozilla.org/da/firefox/addon/youtube-subtitle-downloader/", hvor jeg ik har tilføjet denne add-ons som igen gør at det er ik en hjemmeside, men en fortælling fra mozilla firefox om at denne add-ons ik er tilføjet browseren.

Og frogmaster JEG FORSTÅ GODT ENGELSK, men fortrækker dansk!!

/allan

PS: Sku vi nu ik holde en sober tone uden diverse private kodekser!!


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
PS: Sku vi nu ik holde

#11: PS: Sku vi nu ik holde en sober tone uden diverse private kodekser!!
Du starter ganske enkelt enhver henvendelse, af hensyn til supporterne, med at beskrive dine problemer i overensstemmelse med dine behov. Gør du dig selv den ulejlighed, så vil du ikke opleve at få en over næsen. Du skal forstå at du spilder en masse af andres tid ved ikke at gøre dig umage.

Overholder du ikke hensynet, så er denne henvendelse den absolut sidste for mit vedkommende.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
update - youtube-dl programmet - update

Hej igen igen

Jeg har erfaret her til aften at #8's, hentning af underteksterne til youtube-video, gik galt og jeg blev nød til at fjerne programmet med følgende kommando: "sudo apt-get remove -y youtube-dl" pga min pakke manager apt (i mit tilfælde fra xubuntu) installerede en gammel version af youtube-dl.

Derefter installerede jeg programmet igen med følgende kommandoer:
- sudo wget https://yt-dl.org/latest/youtube-dl -O /usr/local/bin/youtube-dl
- sudo chmod a+x /usr/local/bin/youtube-dl
- hash -r

Nu skulle det gerne være den nyeste version af youtube-dl (2019.04.24) hvilket kan tjekkes med kommandoen "youtube-dl --version".

Og man kan igen hente underteksterne til youtube-videoer ned (håber jeg!!) og linket jeg har brugt er "https://github.com/ytdl-org/youtube-dl/blob/master/README.md#how-do-i-update-youtube-dl", da jeg ik fik kommandoen "sudo youtube-dl -U" til at virke.

Ellers har programmet virket upåklageligt førhen!! (TAK FOR HINTET TIL PROGRAMMET OSJENSEN!!)

/allan


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Problemer med at hente "vtt"-filen ned fra youtube

Hej

Jeg er begyndt at youtube-dl programmet ik længere henter "vtt"-filer ned på min maskine selvom at jeg bruger kommandoen som #8 gave (youtube-dl --all-subs --skip-download https://www.youtube.com/watch?v=G6LAIrGeIjo) og efter jeg har opdaterede programmet er jeg begyndt at tilføje "-k" efter "--all-subs", men faktum er selvom jeg kan se en youtube-video online og vælge underteksterne til kan jeg ik hente "vtt"-filen ned længere på min egen maskine som før. Youtube-dl programmet fortæller mig så at "vtt"-filen ik findes og derfor ik er hentet.

Er der nogle som kan hjælpe mig muligvis i form af alternative programmer til at downloade "vtt"-filen??

/allan


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Hvad for en version af

Her virker det stadigvæk.

efter jeg har opdaterede programmet er jeg begyndt at tilføje "-k" efter "--all-subs"

Vis nu hele den kommando linie, du kører.

Som nævnt før - hvis du vil have video + undertekster.

youtube-dl --all-subs https://www.youtube.com/watch?v=G6LAIrGeIjo

Alternativ - brug #3 forslaget.
Åben Firefox
installer plugin
Åben youtube videoen, og under video-vinduet, vil du se
Subtitle: English
Klik på English, for at downloade.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Er der nogle som kan

#14: Er der nogle som kan hjælpe mig muligvis i form af alternative programmer til at downloade "vtt"-filen?
Terminal versionen af youtube-dl virker, men du skal ikke forvente alle youtube videoer har undertekster. Hvis underteksten ikke eksisterer, så kan den naturligvis ikke downloades.

Youtube-dl har en GUI version, og her ser du hvordan det virker med den: https://www.dropbox.com/s/iwkipivrmqiq1ok/youtube-...


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Problemer med at hente "vtt"-filen ned fra youtube - update

Hej alle. Nu har jeg vist hvad min terminal skriver til mig og jeg har linket til to forskellige videoer (en uden undertekster (1) og en med undertekster (2)), men jeg forstå stadigvæk ik helt hvordan du kan sætte undertekster til når du ser en youtube-video online og ik kan hente ".vtt / .srt / .sbv" filen ned så du kan se videoen offline med tilhørende undertekstning (hvis den findes eller er gjort tilgængelig burde den være online!!), så i min verden kunne man hente underteksterne ned offline hvis de fantes og hvis man ik kunne se dem på youtube-videoen var der ingen undertekster til videoen.

min terminalen (først 1 uden undertekst og derefter 2 med undertekst):
allan@linux:~$ cd temp/
allan@linux:~/temp$ youtube-dl --all-subs -k https://www.youtube.com/watch?v=2jMInHnpNfQ
[youtube] 2jMInHnpNfQ: Downloading webpage
[youtube] 2jMInHnpNfQ: Downloading video info webpage
WARNING: video doesn't have subtitles
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[download] Destination: Email on the terminal with mutt-2jMInHnpNfQ.f248.webm
[download] 100% of 84.17MiB in 00:42
[download] Destination: Email on the terminal with mutt-2jMInHnpNfQ.f140.m4a
[download] 100% of 15.18MiB in 00:08
[ffmpeg] Merging formats into "Email on the terminal with mutt-2jMInHnpNfQ.mkv"
allan@linux:~/temp$ youtube-dl --all-subs -k https://www.youtube.com/watch?v=G6LAIrGeIjo
[youtube] G6LAIrGeIjo: Downloading webpage
[youtube] G6LAIrGeIjo: Downloading video info webpage
[info] Writing video subtitles to: Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.en.vtt
[download] Destination: Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.f248.webm
[download] 100% of 8.20MiB in 00:04
[download] Destination: Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.f251.webm
[download] 100% of 3.05MiB in 00:01
[ffmpeg] Merging formats into "Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.webm"
allan@linux:~/temp$

linket til youtube.com (1 uden undertekst og 2 med undertekst)
1: https://www.youtube.com/watch?v=2jMInHnpNfQ
2: https://www.youtube.com/watch?v=G6LAIrGeIjo

youtube-dlg linux installation
frogmasteren jeg var ik klar over at dette program fantes youtube-dlg (gui vers) eller youutube-dl (linje vers)!!

/allan


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Nr 1 - har ikke en skrevet

Nr 1 - har ikke en skrevet undertekst, men youtube kan vise en engelsk-autogenereret tale > tekst.

Nr 2 - har en skrevet under-tekst, og kan desuden vise autogenereret tale > tekst.

Du kan kun downloade en skrevet undertekst.

Google translate, har en mikrofon indgang.
https://translate.google.com/?hl=da#view=home&op=t...
Du kan måske fodre Google translate, med lyden fra din video, og få den oversat.
Jeg har ikke prøvet.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
En hjertelig TAK herfra...

Jeg var ik klar over at der var forskel på nr1 og nr2 mht subtitles, da "tale til tekst" ik fungerede endnu qva #4. jeg har godt lagt mærke til skrivefejlene i underteksterne, men stadigvæk ik klar over at de var autogenereret. Og jeg går også mere specefikt ind og ser om subtitles er på videoen.

/allan

PS: Hvordan danner I tekst i den blå firkant ligesom #16??


frugtoase
Antal: 106
Tilmeldt:
26-07-2005
User is offline
#19 SaveSubs kan downloade

#19 SaveSubs kan downloade autogenererede undertekster fra YouTube. Link


frugtoase
Antal: 106
Tilmeldt:
26-07-2005
User is offline
youtube-dl kan såmænd

youtube-dl kan såmænd også

youtube-dl --write-auto-sub --skip-download https://www.youtube.com/watch?v=2jMInHnpNfQ

frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
PS: Hvordan danner I

#19: PS: Hvordan danner I tekst i den blå firkant ligesom #16??
Ved at markere specielt den tekst du vil enten svare på eller spørge om og derefter trykke på Svar m/citat.

Problemet med tale til tekst generatore sker over to omgange.

I første at den engelske tekst fejlrammes, fordi programmet ikke kan skelne mellem forskellig udtale af et ord.

I anden når den, i forvejen fejlramte engelske tekst, oversættes til et andet sprog. Især polysemantiske (flertydige) ord, men også på grund af forskelle i grammatik.

Resultatet bliver, mere eller mindre, meningsforstyrrende. Det duer ikke til tekniske opskrifter, men er lidt mere acceptable i underholdningsprogrammer.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
HOLD DA OP, DET ER STORT..

SÅ JEG TAKKER MANGE GANGE!!

Jeg prøvede at installere youtube-dlG på min xubuntu 18.04 (de=xfce) og os'et kom frem til at jeg manglede "python-wxgtk3.0" og "python-twodict (>= 1.2)" for at jeg kunne teste hvordan det fungede sat overfor youtube-dl. Er der nogle som kan hjælpe med installation??

kommandoerne
1: sudo dpkg -i youtube-dlg_0.4-1~webupd8~bionic9_all.deb
2: 3 næste linjer i hver sin kommandoprompt
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install youtube-dlg

/allan

PS: Jeg prøvede også lige mint 19.1 (de=xfce) og der var det de samme to programmer. Jeg testede kun med (1) "sudo dpkg -i youtube-dlg_0.4-1~webupd8~bionic9_all.deb"


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Test af #22 vejledning mht <cite>...</cite>

#23: PS: Jeg prøvede også lige mint 19.1 (de=xfce) og der var det de samme to programmer. Jeg testede kun med (1) "sudo dpkg -i youtube-dlg_0.4-1~webupd8~bionic9_all.deb"


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Autogenerering af "tale til tekst"

#22: Problemet med tekst til tale generatore sker over to omgange.
Jeg håber at denne kommando kan holde sig til orginalsproget (engelsk):
youtube-dl --write-auto-sub --skip-download https://www.youtube.com/watch?v=2jMInHnpNfQ

/allan

PS: Hvordan generer du den grå farve (jeg troede at den blev dannede med ...


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Jeg prøvede også lige

#24: Jeg prøvede også lige mint 19.1
Mint 19.1 er en af de mest arbejds-parate brugervenlige Linux.

Hvis man har brug for et system der er parat til andre arbejdsopgaver, end fx at lære Linux systemet fra grunden, så er Mint et af de bedste valg.

Især Debian, og til dels Ubuntu, kræver mere tilpasning. Andre Linux kræver endnu mere viden om hvordan et operativ system fungerer.


frugtoase
Antal: 106
Tilmeldt:
26-07-2005
User is offline
#23 Det er bedre at

#23 Det er bedre at installere youtube-dlg fra PPA'en. Hvis du bare vil installere en downloadet deb-fil er det nemmere med gdebi end dpkg, da gdebi selv installerer de nødvendige afhængigheder såfremt de er tilgængelige.

sudo apt install gdebi-core && sudo gdebi youtube-dlg_0.4-1~webupd8~bionic9_all.deb


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
#27 Det hvad terminalen gav

#27 Det hvad terminalen gav mig af svar og det er stadig "python-wxgtk3.0" og "python-twodict (>= 1.2)" os'et mangler:

allan@linux:~$ sudo apt install gdebi-core && sudo gdebi youtube-dlg_0.4-1~webupd8~bionic9_all.deb
[sudo] password for allan:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies.
youtube-dlg : Depends: python-wxgtk3.0 but it is not going to be installed
               Depends: python-twodict (>= 1.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
allan@linux:~$

frugtoase
Antal: 106
Tilmeldt:
26-07-2005
User is offline
#28 Løser sudo apt

#28 Løser sudo apt --fix-broken install problemet med afhængheder?


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Det hvad terminalen gav

#28: Det hvad terminalen gav mig af svar og det er stadig "python-wxgtk3.0" og "python-twodict (>= 1.2)" os'et mangler
Der er to tredjepart PPA Repositories der virker for at installere Youtube dl GUI version. gældende for både for Ubuntu 18.03 og Mint 19.1

Man må ikke installere mere end den ene. Har man alligevel gjort det, så skal den anden fjernes inklusiv PPA Repository.

Jeg har testet dem begge og de fungerer.

1. (Denne har jeg beholdt):

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt update
sudo apt install youtube-dlg

2.

sudo add-apt-repository ppa:flexiondotorg/youtube-dl-gui
sudo apt-get update
sudo apt install youtube-dl-gui

osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
Vil man have "indbygget

Vil man have "indbygget under-tekst", kan det gøres med -

youtube-dl --all-subs --embed-subs https://www.youtube.com/watch?v=G6LAIrGeIjo

eller

youtube-dl --write-auto-sub --embed-subs https://www.youtube.com/watch?v=2jMInHnpNfQ

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Youtube-dlg (GUI version)

Youtube-dlg (GUI version) installeret på Ubuntu 18.04, med youtube-dlg eller Youtube-dl-gui, der ikke i forvejen er installeret, vist i en kort video. Der er ingen problemer med python-wxgtk3.0 eller python-twodict.

Derfor er der grund til at antage, for så vidt der er tale om sådanne problemer, at bruger har rodet med noget uden først at spørge ...

https://www.dropbox.com/s/sgqr7itk4mth5zs/youtube-...

Edit: Videos som disse vil blive slettet over tid ...


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Lidt afrunding og opsumering af youtube-dl (youtube-dlG)

Hej igen

Først vil jeg godt sige mangetak for jeres indlæg. Jeg har prøvet installationen af youtube-dlg (youtube-dl-gui) på mint vers19.1 (de=xfce), xubuntu vers18.04 og den nyeste vers19.04 af xubuntu. Jeg ved ik hvad der er sket mht xubuntu vers19.04 for der virker frogmasteren 1&2 ik (ref#30). Jeg kan godt åbne youtube-dlG, men ik få lov at afvikle linket mht at downloade filerne fra youtube.

Jeg skal nok vende mig til youtube-dlG, da youtube-dl virker jeg mest tryg ved, men det at man kan afvikle flere videoer på samme tid virker lidt tillokkende sat overfor youtube-dl. Men samlet set er jeg utrolig priviligeret over at have adgang til begge programmer, TAK FOR DET.

Jeg er glad over at være sluppet ud af dilemaet mht "python-wxgtk3.0" og "python-twodict (>= 1.2)". Jeg havde nok læst nogle forkerte artikler vedr youtube-dlG og ik lagt så meget vægt på at ppa'en på 1&2 ik måtte blandes sammen, men hovedsagden er at nu virker den på mint vers19.1 og xubuntu vers18.04 (begge er de=xfce).

osjensen kom mig nok lidt i forkøbet (ref#31) for jeg var selv begyndt at fabulere om man ik kun få subtitlen ind i videoen (jeg har ik fundet ud af endnu om VLCplayeren kan tolke at en mp4-fil hænger sammen med en vtt-fil, hvis de hedder det samme i filnavnet. Men jeg var glad nok for indlæget (ref#31) for jeg har fået en heldel point's her på tråden i det hele taget.

/allan


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
#33Det er udmærket ;)I

#33
Det er udmærket ;)

I forbindelse til vtt formatet, så er det ikke kompatibelt med srt samt diverse andre undertekst formater. Det har især betydning iht sprogoversættelser.

Det er srt det hovedsagligt handler om. vtt, og flere andre, kan online formateres til srt herfra: https://subtitletools.com/convert-to-srt-online

srt er defacto standard til global sprog oversættelse ... Det er nødvendigt at undertekstfiler konverteres til srt før de oversættes ... men nogle ønsker ikke at verdens folkeslag forstår hinanden..

Spørger du mig hvorfor det forholder sig således, så er mit svat kort, at det bestemmes af en flok politiske tosser (establishment), der lidt minder om religiøs fanatisme.


marlar
Antal: 2949
Tilmeldt:
05-12-2009
User is offline
srt er defacto standard

#34: srt er defacto standard til global sprog oversættelse ...

Ja. TV4ever forstår 5 forskellige formater (srt, ttml, xml, m3u8 og webttv) men alt bliver konverteret til srt internt og ender således hos brugeren som srt. Det er uden sammenligning det mest kompatible format.

#34: Det er nødvendigt at undertekstfiler konverteres til srt før de oversættes

Njaa, det er nu ikke helt korrekt. Der er intet til hinder for at man åbner en vtt fil i en editor og derpå oversætter teksten. Men jeg vil til enhver tid anbefale at man arbejder i srt formatet uanset hvad.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Njaa, det er nu ikke

#35: Njaa, det er nu ikke helt korrekt. Der er intet til hinder for at man åbner en vtt fil i en editor og derpå oversætter teksten
Enig og jeg formulerer mig lidt ukorrekt. vtt er et tekst format og kan derfor manuelt sprogoversættes uden videre.

Problemet opstår ved online maskinelle sprogoversættelser som fx Subtitle Cat og Google Translate. Maskinerne vil gerne have et srt format (GT et txt format), så hvis man giver dem et vtt, ass eller et af de øvrige formater, går der ged i formateringen.Det er derfor nødvendigt først at konvertere underteksten til srt, eller med GT til txt.

Man kan ikke bare omdøbe undertekst filen til srt, eller txt, for at få den maskinelle oversætter til at acceptere filen.

Eksempelvis bliver --> til -> og der opstår mellemrum i tidsangivelserne, der medfører at medie afspillerne ikke kan vise underteksten.


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
http://www.bing.com/Translato

http://www.bing.com/Translator
oversætter Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.en.vtt, syntaksen fejlfrit.

Jeg har installeret -
Crow translate
https://www.linuxlinks.com/crow-translate-free-des...

hvor man kan vælge mellem
Google
Bing
yandex

oversætning.

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Installation af youtube-dlG på debian vers9.9 (de=xfce)

Hej alle

Youtube-dl og youtube-dlG (youtube-dl-gui) programlinks
Linket til programmet youtube-dlG på https://mrs0m30n3.github.io/youtube-dl-gui/ og linket til youtube-dl på http://ytdl-org.github.io/youtube-dl/ (fundet via omveje på #13 mht https://yt-dl.org/latest/youtube-dl >=> https://yt-dl.org/ >=> og tilsidst trykke på "homepage"-iconet).

Debian 9

wget http://ppa.launchpad.net/nilarimogard/webupd8/ubun...
sudo dpkg -i youtube-dlg_0.4-1~webupd8~xenial4_all.deb
sudo apt-get install -f

Debian 10

wget http://ppa.launchpad.net/nilarimogard/webupd8/ubun...
sudo dpkg -i youtube-dlg_0.4-1~webupd8~bionic9_all.deb
sudo apt-get install -f

Fundet på https://www.addictivetips.com/ubuntu-linux-tips/sa...

Hvordan kan det være at jeg ik rigtig kan finde nogen hjælp til installation af youtube-dlG (youtube-dl-gui) på debian vers9.9 (de=xfce)??

Når jeg bruger ppa (følger instruks 1 eller 2 (den første linje), som #30, frogmaster har vist) i debian fortæller system'et at det ik kan bruges, men når jeg så bruger wget installationen (debian 9) for jeg at vide at pakkerne "python-wxgtk3.0" og "python-twodict (>= 1.2)" mangler (fortalt i #23 og #28 af mig selv). Jeg har lige prøvet gdebi (fortalt af #27 af frugtoase) og der manglede den igen pakkerne "python-wxgtk3.0" og "python-twodict (>= 1.2)", og foreslog "apt --fix-broken install" (omtalt i #29 af frugtoase), men jeg ved ik rigtig hvordan denne kommando skal bruges da den ik fortæller hvad der skal efter install.

/allan

PS: Jeg håber ik I ser dette indlæg som et kviolat indlæg og skylder det til hjørne mht at jeg er nybegynder, og deraf skal bruge linuxmint vers19.1 (de=xfce).


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
PS: Jeg håber ik I ser

#38: PS: Jeg håber ik I ser dette indlæg som et kviolat indlæg og skylder det til hjørne mht at jeg er nybegynder, og deraf skal bruge linuxmint vers19.1 (de=xfce).

Nej, du har forstået, eller er ved at forstå, hvorfor Debian ikke er en begynder Linux.

IHT dit spørgsmål, så kan du ikke tilføje PPA Reposities fra et operativ system på et andet, med mindre de er kompatible. Det er Debian og Ubuntu/Mint ikke, mens Mint og Ubuntu er.

Bemærk, og det er vigtigt, at xenial er det samme som Ubuntu 16.04. Hvad siger det dig, siden det ser ud som om du forsøger at installere den på Debian?

Endvidere kan man ikke installere et PPA fra en ældre Ubuntu, Debian eller anden Linux, på en nyere, på trods af der er tale om samme OS.

#38: for jeg at vide at pakkerne "python-wxgtk3.0" og "python-twodict (>= 1.2)" mangler (fortalt i #23 og #28 af mig selv).

Du får formentlig også at vide at der er afhængighedsproblemer på Debian. Hvis du ikke gør, så skal disse to pakker installeres før GUI versionen af Youtube-dl kan installeres på Debian.

Hvis vi antager at pakkerne ikke kan installeres, så kræver det at du, med Debian, selv løser problemet, hvis andre ikke allerede har gjort det. Det er den korte forklaring på det kan være klogt at begyndere holder snuden væk fra Debian.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
oversætter Burn ISO to

#37: oversætter Burn ISO to USB in Linux (GUI)-G6LAIrGeIjo.en.vtt, syntaksen fejlfrit.
Jeg har endnu ikke prøvet med Bing's oversætter og Crow translate. Det skal tjekkes ud ;)

Crow med Google Translate laver ged i formateringen (srt formatet) IHT sidste bemærkning i #36

Eksempelvis bliver --> til -> og der opstår mellemrum i tidsangivelserne, der medfører at medie afspillerne ikke kan vise underteksten.

Det kan nogenlunde nemt rettes med Søg og Erstat i en Tekst Editor, men ikke uden problemer. Medie afspillerene er ikke fejltolerante.

Edit: Det virker bedre med Bing, men desværre smider Bing et komma og et mellemrum væk i tidsangivelserne, der også medfører manuelle rettelser. Mange tak osjensen ;)

Eksempel:
2
00:00:30,416 --> 00:00:32,216
CHRIS:
My name is Chris Norton.

bliver til:
2
00:00:30416--> 00:00:32216
Chris:
Mit navn er Chris Norton.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Bemærk, og det er

#39: Bemærk, og det er vigtigt, at xenial er det samme som Ubuntu 16.04. Hvad siger det dig, siden det ser ud som om du forsøger at installere den på Debian?

Jeg havde selv undret mig over disse fire navne "bionic9, vivid4, xenial4 og zesty4" ( http://ppa.launchpad.net/nilarimogard/webupd8/ubun... ).

bionic9 ( https://en.wikipedia.org/wiki/Bionic_%28software%2... ): Bionic is the standard C library.

vivid4 ( https://unix.stackexchange.com/questions/322349/ho... ): Kan det passe at "vivid" ref til ubuntu vers 15.04??

xenial4 (fortalt af #39, frogmasteren): ubuntu vers 16.04.

zesty4 ( https://www.itzgeek.com/how-tos/linux/ubuntu-how-t... ): Kan det passe at "zesty" ref til ubuntu vers 17.04??

/allan


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
#41Præcist. Tidligere

#41

Præcist. Tidligere Windows, og nogle Mac brugere, oplever at Linux er noget helt andet end hvad de kender i forvejen.

Det er samtidig forklaringen hvorfor det er så vigtigt for begynderen at installere en Linux, der er bruger parat.

Du skal bemærke betegelsen LTS. Det betyder Long Term Support. Det er Linux med sædvanligvis 5 års support. De andre, der ikke er LTS bør begynderen undgå.

De er beta udgaver, sædvanligvis kun supporteret i et halvt år. Det vil sige at du skal ominstallere operativ systemet hvert halve år.

De kan også være såkaldte rollings som fx Debian, der heller ikke er blandt de helt nemme Linux.


osjensen
osjensen's picture
Antal: 1430
Tilmeldt:
14-01-2007
User is offline
#41 #42Slip for

#41 #42
Slip for bøvlet:
pip install youtube-dlg

Som nævnt i
https://www.linuxin.dk/node/22517

Flere "førende distroer", er håbløst bag ud, med opdatering af youtube-dl, minitube mm.
Minitube, kan desværre ikke installeres med pip, men der er en færdig minitube.deb pakke.
https://flavio.tordini.org/minitube

Windows, giver dig det du betaler for.
Linux, giver dig det du vælger.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
#42, svar

Til frogmasteren

Nu må du tager at holde op. Nu bruger jeg tid på at skrive mine indlæg og så kommer du alligevel med den der forklaring med at jeg er nybegynder. JEG SKAL VEL HAVE MIN INFORMATION ET STED FRA, og så må du undskylde at det er dig der giver mig den!!

/allan


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
Til 1botten Beklager jeg

Til 1botten

Beklager jeg bruger tid på at svare på dine spørgsmål. Det skal ikke gentage sig.


1bot.dk
Antal: 137
Tilmeldt:
16-12-2017
User is offline
Frogmaster, der er intet der

Frogmaster, der er intet der er spil af tid for jeg få stadigvæk noget ud af dine og andres tid/svar her på forumet. /allan


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
#46Glimrende#37

#46
Glimrende

#37 osjensen.
Jeg forsøgte med Crow Translate og Bing igen og denne gang skete der næsten ingen formateringsfejl, og dem der opstod kunne nemt klares med Søg og Erstat.

Det tog ialt ca 3 min. at oversætte en hel film, med godt 1300 sætninger..
Bing Translate oversætter iøvrigt engelsk til dansk bedre end Google Translate.

https://github.com/crow-translate/crow-translate/r...

Det at oversætte en film,manuelt, kan nemt tage 16 timer, inkluderet sprog oversættelser såvel som tidsangivelser, så få minutter med en maskin oversætter er noget af en forbedring. Også selvom der forekommer sproglige meningsforstyrrelser..


marlar
Antal: 2949
Tilmeldt:
05-12-2009
User is offline
Det at oversætte en

#47: Det at oversætte en film,manuelt, kan nemt tage 16 timer, inkluderet sprog oversættelser såvel som tidsangivelser, så få minutter med en maskin oversætter er noget af en forbedring. Også selvom der forekommer sproglige meningsforstyrrelser..

Ja, maskinoversættelser er som regel et godt udgangspunkt for manuelle oversættelser. Så kan man koncentrere sig om de forkerte eller knudrede sætninger og derved spare bunker af tid.


frogmaster
frogmaster's picture
Antal: 4121
Tilmeldt:
20-05-2010
User is offline
I forbindelse med maskinelle

#48: og derved spare bunker af tid
Det bliver øjensynligt endnu bedre.

I forbindelse med maskinelle oversættelser, så har jeg lige konstateret at Yandex, med Crow Translate, oversætter engelsk til dansk næsten perfekt og oven i hatten, ikke laver ged i formateringen på srt undertekster.

Tak til osjensen for at nævne Crow Translate (Kragen),

Edit:
Jeg er naturligvis klar over hvem organisationerne er bag Yandex: https://www.google.dk/search?q=Yandex&oq=Yandex&aq...

Tag det med i betragtning, før nogen skulle finde på den overordentligt tåbelige ide at oversætte noget, der indeholder så meget som skyggen af fortrolige data ...

Det kunne være forklaringenen på at de nyeste scam (phishing) forsøg, er på næsten perfekt dansk ...

Edit 2
Yandex laver desværre alligevel også ged i formateringen på subtitles, blot nogle andre end Bing og Google. De ser ud til at være nemmere at rette med Søg og Erstat, men med Yandes er det også nødvendigt at gennemgå undertekst filen for formateringsfejl. Alligevel spares en masse tid samlet set.